summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
Diffstat (limited to 'common')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
index c574041b..9e407ea5 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -13,3 +13,11 @@ SRCREV_intel-x86-common = "a1e2ef7ec912902d8142e7cb5830cbfb47dba86c"
13include systemd-boot/${EFI_PROVIDER}.inc 13include systemd-boot/${EFI_PROVIDER}.inc
14 14
15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" 15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
16
17do_compile_append() {
18 oe_runmake linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
19}
20
21do_deploy_append() {
22 install ${B}/linux*.efi.stub ${DEPLOYDIR}
23}