summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-07-06 18:30:44 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-10 12:08:20 -0700
commitfa6f2d28960ec7ac48117423bad9945b9b30265a (patch)
tree163da814c753d215a410c833bef6ef5481b4a38c /common
parenta7077153afda971b3c526bf23dd082e615ac2069 (diff)
downloadmeta-intel-fa6f2d28960ec7ac48117423bad9945b9b30265a.tar.gz
systemd-boot_%.bbappend: compile and deploy EFI stub
The EFI stub can be used to directly boot a kernel + initramfs. This addition was taken from meta-refkit. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
index c574041b..9e407ea5 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -13,3 +13,11 @@ SRCREV_intel-x86-common = "a1e2ef7ec912902d8142e7cb5830cbfb47dba86c"
13include systemd-boot/${EFI_PROVIDER}.inc 13include systemd-boot/${EFI_PROVIDER}.inc
14 14
15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" 15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
16
17do_compile_append() {
18 oe_runmake linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
19}
20
21do_deploy_append() {
22 install ${B}/linux*.efi.stub ${DEPLOYDIR}
23}