summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/rmc')
-rw-r--r--common/recipes-bsp/rmc/rmc-efi.bb39
-rw-r--r--common/recipes-bsp/rmc/rmc.bb3
2 files changed, 40 insertions, 2 deletions
diff --git a/common/recipes-bsp/rmc/rmc-efi.bb b/common/recipes-bsp/rmc/rmc-efi.bb
new file mode 100644
index 00000000..ea096197
--- /dev/null
+++ b/common/recipes-bsp/rmc/rmc-efi.bb
@@ -0,0 +1,39 @@
1SUMMARY = "RMC (Runtime Machine Configuration) EFI library"
2
3DESCRIPTION = "The RMC EFI library adds RMC support to existing EFI bootloaders"
4
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=ade413c694d3aaefc9554b24a8814ee8"
8
9SRC_URI = "git://git.yoctoproject.org/rmc"
10
11SRCREV = "027ac76f642dcab1a9f237a00f03a3a714bd04b9"
12
13S = "${WORKDIR}/git"
14
15COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
16
17TARGET_CFLAGS +="-Wl,--hash-style=both"
18
19EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
20 RMC_INSTALL_LIB_PATH=${D}${libdir} \
21 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
22
23SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
24
25python () {
26 ccargs = d.getVar('TUNE_CCARGS').split()
27 if '-mx32' in ccargs:
28 ccargs.remove('-mx32')
29 ccargs.append('-m64')
30 d.setVar('TUNE_CCARGS', ' '.join(ccargs))
31}
32
33do_compile() {
34 oe_runmake -f Makefile.efi
35}
36
37do_install() {
38 oe_runmake -f Makefile.efi install
39}
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index 93fdd3aa..fb0d1737 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -28,14 +28,13 @@ EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc" 28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
29 29
30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
31
31do_compile_class-target() { 32do_compile_class-target() {
32 oe_runmake 33 oe_runmake
33 oe_runmake -f Makefile.efi
34} 34}
35 35
36do_install() { 36do_install() {
37 oe_runmake install 37 oe_runmake install
38 oe_runmake -f Makefile.efi install
39} 38}
40 39
41do_install_class-native() { 40do_install_class-native() {