summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc/rmc-efi.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/rmc/rmc-efi.bb')
-rw-r--r--common/recipes-bsp/rmc/rmc-efi.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/common/recipes-bsp/rmc/rmc-efi.bb b/common/recipes-bsp/rmc/rmc-efi.bb
new file mode 100644
index 00000000..ea096197
--- /dev/null
+++ b/common/recipes-bsp/rmc/rmc-efi.bb
@@ -0,0 +1,39 @@
1SUMMARY = "RMC (Runtime Machine Configuration) EFI library"
2
3DESCRIPTION = "The RMC EFI library adds RMC support to existing EFI bootloaders"
4
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=ade413c694d3aaefc9554b24a8814ee8"
8
9SRC_URI = "git://git.yoctoproject.org/rmc"
10
11SRCREV = "027ac76f642dcab1a9f237a00f03a3a714bd04b9"
12
13S = "${WORKDIR}/git"
14
15COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
16
17TARGET_CFLAGS +="-Wl,--hash-style=both"
18
19EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
20 RMC_INSTALL_LIB_PATH=${D}${libdir} \
21 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
22
23SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
24
25python () {
26 ccargs = d.getVar('TUNE_CCARGS').split()
27 if '-mx32' in ccargs:
28 ccargs.remove('-mx32')
29 ccargs.append('-m64')
30 d.setVar('TUNE_CCARGS', ' '.join(ccargs))
31}
32
33do_compile() {
34 oe_runmake -f Makefile.efi
35}
36
37do_install() {
38 oe_runmake -f Makefile.efi install
39}