summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorYew, Chang Ching <chang.ching.yew@intel.com>2021-06-22 13:58:33 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-06-22 17:23:53 +0800
commite56859c9012e572ec77f822a41df5fe13c37fca5 (patch)
tree143b434f444f4820ffe9676898cda64f719080dc /recipes-multimedia
parentf4955ea96c2acdf34cc160960132e9f88364464a (diff)
downloadmeta-intel-e56859c9012e572ec77f822a41df5fe13c37fca5.tar.gz
onevpl: Fix wayland lib install
1. Include libvpl_wayland.so in standard package instead of -dev package 2. Fix CMake install path of libvpl_wayland.so to $LIBDIR Signed-off-by: Yew, Chang Ching <chang.ching.yew@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch53
-rw-r--r--recipes-multimedia/onevpl/onevpl_2021.2.2.bb10
2 files changed, 61 insertions, 2 deletions
diff --git a/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch b/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch
new file mode 100644
index 00000000..032c416d
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch
@@ -0,0 +1,53 @@
1From 0e2c56260a3ccddcccb5daa0c8aac3c6b92214ac Mon Sep 17 00:00:00 2001
2From: tengjinchung <jin.chung.teng@intel.com>
3Date: Thu, 17 Jun 2021 14:43:48 +0800
4Subject: [PATCH] Corrected the install path
5
6Fix CMake install path of libvpl_wayland.so to
7$LIBDIR
8
9Upstream-Status: Pending
10inner-source pr #133
11
12Signed-off-by: jinchung <jin.chung.teng@intel.com>
13Signed-off-by: Yew, Chang Ching <chang.ching.yew@intel.com>
14---
15 tools/legacy/sample_common/src/vaapi_utils.cpp | 2 +-
16 tools/legacy/sample_misc/wayland/CMakeLists.txt | 4 ++--
17 2 files changed, 3 insertions(+), 3 deletions(-)
18
19diff --git a/tools/legacy/sample_common/src/vaapi_utils.cpp b/tools/legacy/sample_common/src/vaapi_utils.cpp
20index 833b4c1..23edf86 100644
21--- a/tools/legacy/sample_common/src/vaapi_utils.cpp
22+++ b/tools/legacy/sample_common/src/vaapi_utils.cpp
23@@ -163,7 +163,7 @@ Xcbpresent_Proxy::~Xcbpresent_Proxy() {}
24 #if defined(LIBVA_WAYLAND_SUPPORT)
25
26 VA_WaylandClientProxy::VA_WaylandClientProxy()
27- : lib("libmfx_wayland.so"),
28+ : lib("libvpl_wayland.so"),
29 SIMPLE_LOADER_FUNCTION(WaylandCreate) {}
30
31 VA_WaylandClientProxy::~VA_WaylandClientProxy() {}
32diff --git a/tools/legacy/sample_misc/wayland/CMakeLists.txt b/tools/legacy/sample_misc/wayland/CMakeLists.txt
33index 95057d4..90b55ca 100644
34--- a/tools/legacy/sample_misc/wayland/CMakeLists.txt
35+++ b/tools/legacy/sample_misc/wayland/CMakeLists.txt
36@@ -2,7 +2,7 @@ if (NOT PKG_WAYLAND_CLIENT_FOUND)
37 return()
38 endif()
39
40-set(TARGET mfx_wayland)
41+set(TARGET vpl_wayland)
42
43 find_package(PkgConfig REQUIRED)
44 pkg_check_modules(PKG_WAYLAND_CLIENT wayland-client)
45@@ -26,4 +26,4 @@ target_sources(${TARGET} PRIVATE
46
47 target_link_libraries(${TARGET} sample_common wayland-client va drm drm_intel)
48
49-install( TARGETS ${TARGETS} LIBRARY DESTINATION ${CMAKE_INSTALL_BINDIR} )
50+install( TARGETS ${TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
51--
522.32.0
53
diff --git a/recipes-multimedia/onevpl/onevpl_2021.2.2.bb b/recipes-multimedia/onevpl/onevpl_2021.2.2.bb
index 6812ccfa..6e08b42b 100644
--- a/recipes-multimedia/onevpl/onevpl_2021.2.2.bb
+++ b/recipes-multimedia/onevpl/onevpl_2021.2.2.bb
@@ -18,6 +18,7 @@ SRC_URI = "git://github.com/oneapi-src/oneVPL.git;protocol=https \
18 file://0001-Fix-NV12-input-format-in-legacy-samples.patch \ 18 file://0001-Fix-NV12-input-format-in-legacy-samples.patch \
19 file://0001-Fix-sample_vpp-sample_encode-alignment-issue.patch \ 19 file://0001-Fix-sample_vpp-sample_encode-alignment-issue.patch \
20 file://0001-Fix-sample_encode-i010-input.patch \ 20 file://0001-Fix-sample_encode-i010-input.patch \
21 file://0001-Corrected-the-install-path.patch \
21 " 22 "
22SRCREV = "17968d8d2299352f5a9e09388d24e81064c81c87" 23SRCREV = "17968d8d2299352f5a9e09388d24e81064c81c87"
23S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
@@ -41,9 +42,14 @@ do_install_append () {
41 find "${D}${datadir}/vpl/examples/" -type d \! -name 'examples' \! -name 'content' -exec rm -rf {} + 42 find "${D}${datadir}/vpl/examples/" -type d \! -name 'examples' \! -name 'content' -exec rm -rf {} +
42} 43}
43 44
44
45FILES_${PN}-examples = "${bindir}/dpcpp-blur \ 45FILES_${PN}-examples = "${bindir}/dpcpp-blur \
46 ${bindir}/hello-* \ 46 ${bindir}/hello-* \
47 ${datadir}/vpl/examples \ 47 ${datadir}/vpl/examples \
48 " 48 "
49FILES_${PN} += "${datadir}" 49
50FILES_SOLIBSDEV = ""
51FILES_${PN}-dev += "${libdir}/libvpl.so"
52
53FILES_${PN} += "${datadir} \
54 ${libdir}/libvpl_wayland.so \
55 "