summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch')
-rw-r--r--recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch b/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch
new file mode 100644
index 00000000..032c416d
--- /dev/null
+++ b/recipes-multimedia/onevpl/onevpl/0001-Corrected-the-install-path.patch
@@ -0,0 +1,53 @@
1From 0e2c56260a3ccddcccb5daa0c8aac3c6b92214ac Mon Sep 17 00:00:00 2001
2From: tengjinchung <jin.chung.teng@intel.com>
3Date: Thu, 17 Jun 2021 14:43:48 +0800
4Subject: [PATCH] Corrected the install path
5
6Fix CMake install path of libvpl_wayland.so to
7$LIBDIR
8
9Upstream-Status: Pending
10inner-source pr #133
11
12Signed-off-by: jinchung <jin.chung.teng@intel.com>
13Signed-off-by: Yew, Chang Ching <chang.ching.yew@intel.com>
14---
15 tools/legacy/sample_common/src/vaapi_utils.cpp | 2 +-
16 tools/legacy/sample_misc/wayland/CMakeLists.txt | 4 ++--
17 2 files changed, 3 insertions(+), 3 deletions(-)
18
19diff --git a/tools/legacy/sample_common/src/vaapi_utils.cpp b/tools/legacy/sample_common/src/vaapi_utils.cpp
20index 833b4c1..23edf86 100644
21--- a/tools/legacy/sample_common/src/vaapi_utils.cpp
22+++ b/tools/legacy/sample_common/src/vaapi_utils.cpp
23@@ -163,7 +163,7 @@ Xcbpresent_Proxy::~Xcbpresent_Proxy() {}
24 #if defined(LIBVA_WAYLAND_SUPPORT)
25
26 VA_WaylandClientProxy::VA_WaylandClientProxy()
27- : lib("libmfx_wayland.so"),
28+ : lib("libvpl_wayland.so"),
29 SIMPLE_LOADER_FUNCTION(WaylandCreate) {}
30
31 VA_WaylandClientProxy::~VA_WaylandClientProxy() {}
32diff --git a/tools/legacy/sample_misc/wayland/CMakeLists.txt b/tools/legacy/sample_misc/wayland/CMakeLists.txt
33index 95057d4..90b55ca 100644
34--- a/tools/legacy/sample_misc/wayland/CMakeLists.txt
35+++ b/tools/legacy/sample_misc/wayland/CMakeLists.txt
36@@ -2,7 +2,7 @@ if (NOT PKG_WAYLAND_CLIENT_FOUND)
37 return()
38 endif()
39
40-set(TARGET mfx_wayland)
41+set(TARGET vpl_wayland)
42
43 find_package(PkgConfig REQUIRED)
44 pkg_check_modules(PKG_WAYLAND_CLIENT wayland-client)
45@@ -26,4 +26,4 @@ target_sources(${TARGET} PRIVATE
46
47 target_link_libraries(${TARGET} sample_common wayland-client va drm drm_intel)
48
49-install( TARGETS ${TARGETS} LIBRARY DESTINATION ${CMAKE_INSTALL_BINDIR} )
50+install( TARGETS ${TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
51--
522.32.0
53