summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libyami/libyami_git.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-06-20 09:26:28 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-06-21 11:58:20 +0800
commitae4b623eff97025867bbb0006796565a3cfbce27 (patch)
tree3a4244024ec61407d50707f55f050da58426f228 /recipes-multimedia/libyami/libyami_git.bb
parent05f3f87decab8987ccd90d3762587240f9407aab (diff)
downloadmeta-intel-ae4b623eff97025867bbb0006796565a3cfbce27.tar.gz
libyami: update to latest SRCREV
Fixes errors with musl: | ../../git/codecparsers/vp8_parser.cpp: In member function 'YamiParser::Vp8ParserResult YamiParser::Vp8Parser::ParseFrame(const uint8_t*, size_t, YamiParser::Vp8FrameHeader*)': | ../../git/codecparsers/vp8_parser.cpp:98:32: error: 'void* memset(void*, int, size_t)' clearing an object of non-trivial type 'struct YamiParser::Vp8FrameHeader'; use assignment or value-initialization instead [-Werror=class-memaccess] | memset(fhdr, 0, sizeof(*fhdr)); | ^ | In file included from ../../git/codecparsers/vp8_parser.cpp:44: | ../../git/codecparsers/vp8_parser.h:131:8: note: 'struct YamiParser::Vp8FrameHeader' declared here | struct Vp8FrameHeader { | ^~~~~~~~~~~~~~ | cc1plus: all warnings being treated as errors Also, remove the upstreamed patch and change upstream checks to use git commits instead. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia/libyami/libyami_git.bb')
-rw-r--r--recipes-multimedia/libyami/libyami_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-multimedia/libyami/libyami_git.bb b/recipes-multimedia/libyami/libyami_git.bb
new file mode 100644
index 00000000..7ff9effd
--- /dev/null
+++ b/recipes-multimedia/libyami/libyami_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Yami is media infrastructure base on libva"
2DESCRIPTION = "Yet Another Media Infrastructure \
3light weight hardware codec library base on VA-API "
4
5HOMEPAGE = "https://github.com/intel/libyami"
6BUGTRACKER = "https://github.com/intel/libyami/issues/new"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11SRC_URI = "git://github.com/intel/libyami.git;branch=apache \
12 file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \
13 file://0002-typecast-index-from-size_t-to-int.patch \
14 file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \
15 file://0004-Typecast-POWER32SUB2-to-uint8_t.patch \
16 file://0005-move-c-definitions-out-of-extern-C-block.patch \
17 file://0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch \
18 file://0007-Delete-unused-variables.patch \
19 file://0008-NalUnit-is-declared-in-different-namespace.patch \
20 file://0009-Fix-clang-warnings.patch \
21"
22SRCREV = "49f32de0e537577927b98deb551e16a7fa89d892"
23S = "${WORKDIR}/git"
24PV = "1.3.0+git${SRCPV}"
25
26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
27PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
28
29DEPENDS = "libva"
30inherit autotools pkgconfig distro_features_check
31
32REQUIRED_DISTRO_FEATURES = "opengl"
33
34UPSTREAM_CHECK_COMMITS = "1"