summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-06-20 09:26:28 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-06-21 11:58:20 +0800
commitae4b623eff97025867bbb0006796565a3cfbce27 (patch)
tree3a4244024ec61407d50707f55f050da58426f228
parent05f3f87decab8987ccd90d3762587240f9407aab (diff)
downloadmeta-intel-ae4b623eff97025867bbb0006796565a3cfbce27.tar.gz
libyami: update to latest SRCREV
Fixes errors with musl: | ../../git/codecparsers/vp8_parser.cpp: In member function 'YamiParser::Vp8ParserResult YamiParser::Vp8Parser::ParseFrame(const uint8_t*, size_t, YamiParser::Vp8FrameHeader*)': | ../../git/codecparsers/vp8_parser.cpp:98:32: error: 'void* memset(void*, int, size_t)' clearing an object of non-trivial type 'struct YamiParser::Vp8FrameHeader'; use assignment or value-initialization instead [-Werror=class-memaccess] | memset(fhdr, 0, sizeof(*fhdr)); | ^ | In file included from ../../git/codecparsers/vp8_parser.cpp:44: | ../../git/codecparsers/vp8_parser.h:131:8: note: 'struct YamiParser::Vp8FrameHeader' declared here | struct Vp8FrameHeader { | ^~~~~~~~~~~~~~ | cc1plus: all warnings being treated as errors Also, remove the upstreamed patch and change upstream checks to use git commits instead. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch29
-rw-r--r--recipes-multimedia/libyami/libyami_git.bb (renamed from recipes-multimedia/libyami/libyami_1.3.0.bb)7
2 files changed, 3 insertions, 33 deletions
diff --git a/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch b/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch
deleted file mode 100644
index 673969cf..00000000
--- a/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 00fc21a41bf7e11d468227487c4e9de9e6d608e6 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 5 Feb 2018 11:16:18 +0800
4Subject: [PATCH] Makefile.am: point to build dir for generated headers
5
6Otherwise it will give out errors for missing YamiVersion.h.
7
8Upstream-Status: Submitted [https://github.com/intel/libyami/pull/827]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 common/Makefile.am | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/common/Makefile.am b/common/Makefile.am
16index 5ee61da..1a788e5 100644
17--- a/common/Makefile.am
18+++ b/common/Makefile.am
19@@ -40,6 +40,7 @@ extra_includes = \
20 libyami_common_cppflags = \
21 $(LIBVA_CFLAGS) \
22 -I$(top_srcdir)/interface \
23+ -I$(top_builddir)/interface \
24 $(extra_includes) \
25 $(NULL)
26
27--
282.7.4
29
diff --git a/recipes-multimedia/libyami/libyami_1.3.0.bb b/recipes-multimedia/libyami/libyami_git.bb
index ce4f253a..7ff9effd 100644
--- a/recipes-multimedia/libyami/libyami_1.3.0.bb
+++ b/recipes-multimedia/libyami/libyami_git.bb
@@ -18,10 +18,10 @@ SRC_URI = "git://github.com/intel/libyami.git;branch=apache \
18 file://0007-Delete-unused-variables.patch \ 18 file://0007-Delete-unused-variables.patch \
19 file://0008-NalUnit-is-declared-in-different-namespace.patch \ 19 file://0008-NalUnit-is-declared-in-different-namespace.patch \
20 file://0009-Fix-clang-warnings.patch \ 20 file://0009-Fix-clang-warnings.patch \
21 file://0001-Makefile.am-point-to-build-dir-for-generated-headers.patch \
22" 21"
23SRCREV = "0192c3c041e02e8eb753e9e3e02bfc7b55756ce2" 22SRCREV = "49f32de0e537577927b98deb551e16a7fa89d892"
24S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24PV = "1.3.0+git${SRCPV}"
25 25
26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" 26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
27PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" 27PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
@@ -31,5 +31,4 @@ inherit autotools pkgconfig distro_features_check
31 31
32REQUIRED_DISTRO_FEATURES = "opengl" 32REQUIRED_DISTRO_FEATURES = "opengl"
33 33
34UPSTREAM_CHECK_URI = "https://github.com/intel/libyami/releases" 34UPSTREAM_CHECK_COMMITS = "1"
35UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"