summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libyami/libyami_1.3.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-05 14:25:53 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-02-16 15:38:35 -0800
commit278376a80118ecace6c1c85c8568b5f91d72d816 (patch)
tree9f697a2ca4dfb922a20b72c99fd3bd1963c96ca4 /recipes-multimedia/libyami/libyami_1.3.0.bb
parent433e4f31e92e228d2df21646d838a261077a3041 (diff)
downloadmeta-intel-278376a80118ecace6c1c85c8568b5f91d72d816.tar.gz
libyami: upgrade to 1.3.0
Major changes: *Implement H.264 SVC-T new reference mode *Implement H.264 low latency mode *Improve v4l2 interface,support dynamic resolution change *JPEG decoder fixes and Y800 support The 1.3.0 release tag isn't on any branch so use the SRCREV that is one commit behind. Added a patch to fix build because of change in location of headers in this release. Also, point to renamed intel repository. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-multimedia/libyami/libyami_1.3.0.bb')
-rw-r--r--recipes-multimedia/libyami/libyami_1.3.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-multimedia/libyami/libyami_1.3.0.bb b/recipes-multimedia/libyami/libyami_1.3.0.bb
new file mode 100644
index 00000000..ce4f253a
--- /dev/null
+++ b/recipes-multimedia/libyami/libyami_1.3.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Yami is media infrastructure base on libva"
2DESCRIPTION = "Yet Another Media Infrastructure \
3light weight hardware codec library base on VA-API "
4
5HOMEPAGE = "https://github.com/intel/libyami"
6BUGTRACKER = "https://github.com/intel/libyami/issues/new"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11SRC_URI = "git://github.com/intel/libyami.git;branch=apache \
12 file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \
13 file://0002-typecast-index-from-size_t-to-int.patch \
14 file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \
15 file://0004-Typecast-POWER32SUB2-to-uint8_t.patch \
16 file://0005-move-c-definitions-out-of-extern-C-block.patch \
17 file://0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch \
18 file://0007-Delete-unused-variables.patch \
19 file://0008-NalUnit-is-declared-in-different-namespace.patch \
20 file://0009-Fix-clang-warnings.patch \
21 file://0001-Makefile.am-point-to-build-dir-for-generated-headers.patch \
22"
23SRCREV = "0192c3c041e02e8eb753e9e3e02bfc7b55756ce2"
24S = "${WORKDIR}/git"
25
26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
27PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
28
29DEPENDS = "libva"
30inherit autotools pkgconfig distro_features_check
31
32REQUIRED_DISTRO_FEATURES = "opengl"
33
34UPSTREAM_CHECK_URI = "https://github.com/intel/libyami/releases"
35UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"