summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch29
-rw-r--r--recipes-multimedia/libyami/libyami_1.3.0.bb (renamed from recipes-multimedia/libyami/libyami_1.2.0.bb)11
2 files changed, 35 insertions, 5 deletions
diff --git a/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch b/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch
new file mode 100644
index 00000000..673969cf
--- /dev/null
+++ b/recipes-multimedia/libyami/libyami/0001-Makefile.am-point-to-build-dir-for-generated-headers.patch
@@ -0,0 +1,29 @@
1From 00fc21a41bf7e11d468227487c4e9de9e6d608e6 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 5 Feb 2018 11:16:18 +0800
4Subject: [PATCH] Makefile.am: point to build dir for generated headers
5
6Otherwise it will give out errors for missing YamiVersion.h.
7
8Upstream-Status: Submitted [https://github.com/intel/libyami/pull/827]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 common/Makefile.am | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/common/Makefile.am b/common/Makefile.am
16index 5ee61da..1a788e5 100644
17--- a/common/Makefile.am
18+++ b/common/Makefile.am
19@@ -40,6 +40,7 @@ extra_includes = \
20 libyami_common_cppflags = \
21 $(LIBVA_CFLAGS) \
22 -I$(top_srcdir)/interface \
23+ -I$(top_builddir)/interface \
24 $(extra_includes) \
25 $(NULL)
26
27--
282.7.4
29
diff --git a/recipes-multimedia/libyami/libyami_1.2.0.bb b/recipes-multimedia/libyami/libyami_1.3.0.bb
index 1d1d02fa..ce4f253a 100644
--- a/recipes-multimedia/libyami/libyami_1.2.0.bb
+++ b/recipes-multimedia/libyami/libyami_1.3.0.bb
@@ -2,13 +2,13 @@ SUMMARY = "Yami is media infrastructure base on libva"
2DESCRIPTION = "Yet Another Media Infrastructure \ 2DESCRIPTION = "Yet Another Media Infrastructure \
3light weight hardware codec library base on VA-API " 3light weight hardware codec library base on VA-API "
4 4
5HOMEPAGE = "https://github.com/01org/libyami" 5HOMEPAGE = "https://github.com/intel/libyami"
6BUGTRACKER = "https://github.com/01org/libyami/issues/new" 6BUGTRACKER = "https://github.com/intel/libyami/issues/new"
7 7
8LICENSE = "Apache-2.0" 8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57" 9LIC_FILES_CHKSUM = "file://LICENSE.md;md5=3b83ef96387f14655fc854ddc3c6bd57"
10 10
11SRC_URI = "git://github.com/01org/libyami.git;branch=apache \ 11SRC_URI = "git://github.com/intel/libyami.git;branch=apache \
12 file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \ 12 file://0001-bitWriter.cpp-Delete-unused-CACHEBYTES.patch \
13 file://0002-typecast-index-from-size_t-to-int.patch \ 13 file://0002-typecast-index-from-size_t-to-int.patch \
14 file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \ 14 file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \
@@ -18,8 +18,9 @@ SRC_URI = "git://github.com/01org/libyami.git;branch=apache \
18 file://0007-Delete-unused-variables.patch \ 18 file://0007-Delete-unused-variables.patch \
19 file://0008-NalUnit-is-declared-in-different-namespace.patch \ 19 file://0008-NalUnit-is-declared-in-different-namespace.patch \
20 file://0009-Fix-clang-warnings.patch \ 20 file://0009-Fix-clang-warnings.patch \
21 file://0001-Makefile.am-point-to-build-dir-for-generated-headers.patch \
21" 22"
22SRCREV = "c884fc3facbf1a0adf2082a1cf95cb146300a5ca" 23SRCREV = "0192c3c041e02e8eb753e9e3e02bfc7b55756ce2"
23S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
24 25
25PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" 26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
@@ -30,5 +31,5 @@ inherit autotools pkgconfig distro_features_check
30 31
31REQUIRED_DISTRO_FEATURES = "opengl" 32REQUIRED_DISTRO_FEATURES = "opengl"
32 33
33UPSTREAM_CHECK_URI = "https://github.com/01org/libyami/releases" 34UPSTREAM_CHECK_URI = "https://github.com/intel/libyami/releases"
34UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)" 35UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"