summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-06 16:38:19 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-02-16 15:38:35 -0800
commit433e4f31e92e228d2df21646d838a261077a3041 (patch)
tree0225109b8fa7355b4e133800d336d00c5042304f /recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb
parenta6a0dbc65eb418082b858e259253ee56be9503cf (diff)
downloadmeta-intel-433e4f31e92e228d2df21646d838a261077a3041.tar.gz
intel-vaapi-driver: upgrade to 2.0.0
Major changes: * Bump version to 2.0.0 * Add support for Coffee Lake (aka. CFL) - Decoding: H.264/MPEG-2/VC-1/JPEG/VP8/HEVC/HEVC 10-bit/VP9/VP9 10-bit - Encoding: H.264/MPEG-2/JPEG/VP8/VP9/HEVC/HEVC 10-bit/AVC low power CQP/CBR/VBR mode - VPP: CSC/scaling/NoiseReduction/Deinterlacing{Bob, MotionAdaptive, MotionCompensated}/ColorBalance/STD * Add support for H264 FEI * Add support for HEVC ROI encoding * Add support for intensity compensation for VC-1 decoding * Improve the quality of the H264 encoder on BDW/BSW * Improve the CSC performance between I420/NV12/P010/YUY2/VYUY format * Improve the performace of va{Get, Put}Image for I420/NV12/P010/YUY2/VYUY format * Fix image corruption for VP9 decoding * Fix race condition in wayland support * Fix ROI support in VDEnc support * Fix corrupted stream when using VDEnc CBR/VBR * Fix GCC 7.1.1 warnings/errors * Update the shader for HEVC encoding The upstream package name now is intel-vaapi-driver instead of libva-intel-driver. Updated to point to release tarball instead of git. Also, changed the URLs to point to new project page. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb')
-rw-r--r--recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb b/recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb
new file mode 100644
index 00000000..e651107c
--- /dev/null
+++ b/recipes-multimedia/libva/intel-vaapi-driver_2.0.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "VA driver for Intel G45 & HD Graphics family"
2DESCRIPTION = "intel-vaapi-driver is the VA-API implementation \
3for Intel G45 chipsets and Intel HD Graphics for Intel Core \
4processor family."
5
6HOMEPAGE = "https://github.com/intel/intel-vaapi-driver"
7BUGTRACKER = "https://github.com/intel/intel-vaapi-driver/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
11
12COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
13
14DEPENDS = "libva libdrm"
15
16SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.bz2"
17SRC_URI[md5sum] = "1288657b572b563b24ca27c60a10a032"
18SRC_URI[sha256sum] = "10f6b0a91f34715d8d4d9a9e0fb3cc0afe5fcf85355db1272bd5fff31522f469"
19
20UPSTREAM_CHECK_URI = "https://github.com/intel/intel-vaapi-driver/releases"
21
22inherit autotools pkgconfig distro_features_check
23
24REQUIRED_DISTRO_FEATURES = "opengl"
25
26PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
27 ${@bb.utils.contains("DISTRO_FEATURES", "opengl wayland", "wayland", "", d)}"
28PACKAGECONFIG[x11] = "--enable-x11,--disable-x11"
29PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland wayland-native virtual/egl"
30
31FILES_${PN} += "${libdir}/dri/*.so"
32FILES_${PN}-dev += "${libdir}/dri/*.la"
33FILES_${PN}-dbg += "${libdir}/dri/.debug"