summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
commit0584f638797a816b29b909d4611d5a099df7bbc1 (patch)
tree1ec4bdacf824c304290b5086fd54bba9b84158e2 /recipes-kernel
parent7a5e47b6a594eb29dfe84e47f043a49974bc0402 (diff)
downloadmeta-intel-0584f638797a816b29b909d4611d5a099df7bbc1.tar.gz
Convert to new override syntax
Use the convert-overrides.py to convert to new syntax and manually fix some additional changes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe_5.11.3.bb8
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf_4.11.1.bb8
-rw-r--r--recipes-kernel/iwlwifi/backport-iwlwifi_git.bb8
-rw-r--r--recipes-kernel/linux/linux-intel-dev.bb8
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb2
-rw-r--r--recipes-kernel/linux/linux-intel.inc10
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb8
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb6
-rw-r--r--recipes-kernel/linux/linux-yocto-dev.bbappend22
-rw-r--r--recipes-kernel/linux/linux-yocto_%.bbappend2
11 files changed, 42 insertions, 42 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbe_5.11.3.bb b/recipes-kernel/intel-ethernet/ixgbe_5.11.3.bb
index 8c7fb09c..2845abee 100644
--- a/recipes-kernel/intel-ethernet/ixgbe_5.11.3.bb
+++ b/recipes-kernel/intel-ethernet/ixgbe_5.11.3.bb
@@ -21,12 +21,12 @@ S = "${WORKDIR}/${BP}/src"
21 21
22EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"' 22EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
23 23
24KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbe" 24KERNEL_MODULE_AUTOLOAD:append:intel-core2-32 = " ixgbe"
25KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbe" 25KERNEL_MODULE_AUTOLOAD:append:intel-corei7-64 = " ixgbe"
26 26
27inherit module 27inherit module
28 28
29do_install_append () { 29do_install:append () {
30 # Install scripts/set_irq_affinity 30 # Install scripts/set_irq_affinity
31 install -d ${D}${sysconfdir}/network 31 install -d ${D}${sysconfdir}/network
32 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network 32 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
@@ -36,7 +36,7 @@ do_install_append () {
36 36
37PACKAGES += "${PN}-script" 37PACKAGES += "${PN}-script"
38 38
39FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity" 39FILES:${PN}-script += "${sysconfdir}/network/set_irq_affinity"
40 40
41EXCLUDE_FROM_WORLD = "1" 41EXCLUDE_FROM_WORLD = "1"
42 42
diff --git a/recipes-kernel/intel-ethernet/ixgbevf_4.11.1.bb b/recipes-kernel/intel-ethernet/ixgbevf_4.11.1.bb
index 2867269a..2fa23a68 100644
--- a/recipes-kernel/intel-ethernet/ixgbevf_4.11.1.bb
+++ b/recipes-kernel/intel-ethernet/ixgbevf_4.11.1.bb
@@ -24,12 +24,12 @@ S = "${WORKDIR}/${BP}/src"
24 24
25EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"' 25EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
26 26
27KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf" 27KERNEL_MODULE_AUTOLOAD:append:intel-core2-32 = " ixgbevf"
28KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf" 28KERNEL_MODULE_AUTOLOAD:append:intel-corei7-64 = " ixgbevf"
29 29
30inherit module 30inherit module
31 31
32do_install_append () { 32do_install:append () {
33 # Install scripts/set_irq_affinity 33 # Install scripts/set_irq_affinity
34 install -d ${D}${sysconfdir}/network 34 install -d ${D}${sysconfdir}/network
35 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network 35 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
@@ -39,7 +39,7 @@ do_install_append () {
39 39
40PACKAGES += "${PN}-script" 40PACKAGES += "${PN}-script"
41 41
42FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity" 42FILES:${PN}-script += "${sysconfdir}/network/set_irq_affinity"
43 43
44# This was fixed in kernel v4.4 44# This was fixed in kernel v4.4
45CVE_CHECK_WHITELIST += "CVE-2015-1142857" 45CVE_CHECK_WHITELIST += "CVE-2015-1142857"
diff --git a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
index 9eb0a45d..a06a8e26 100644
--- a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
+++ b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb
@@ -36,16 +36,16 @@ do_configure() {
36 36
37MODULES_INSTALL_TARGET="install" 37MODULES_INSTALL_TARGET="install"
38 38
39do_install_append() { 39do_install:append() {
40 ## install configs and service scripts 40 ## install configs and service scripts
41 install -d ${D}${sysconfdir}/modprobe.d 41 install -d ${D}${sysconfdir}/modprobe.d
42 install -m 0644 ${WORKDIR}/iwlwifi.conf ${D}${sysconfdir}/modprobe.d 42 install -m 0644 ${WORKDIR}/iwlwifi.conf ${D}${sysconfdir}/modprobe.d
43} 43}
44 44
45RDEPENDS_${PN} = "linux-firmware-iwlwifi" 45RDEPENDS:${PN} = "linux-firmware-iwlwifi"
46 46
47KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" 47KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " iwlwifi"
48KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" 48KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " iwlwifi"
49 49
50KERNEL_MODULE_PACKAGE_PREFIX = "backport-iwlwifi" 50KERNEL_MODULE_PACKAGE_PREFIX = "backport-iwlwifi"
51 51
diff --git a/recipes-kernel/linux/linux-intel-dev.bb b/recipes-kernel/linux/linux-intel-dev.bb
index 9cabe7b9..41f327b8 100644
--- a/recipes-kernel/linux/linux-intel-dev.bb
+++ b/recipes-kernel/linux/linux-intel-dev.bb
@@ -1,14 +1,14 @@
1require recipes-kernel/linux/linux-yocto.inc 1require recipes-kernel/linux/linux-yocto.inc
2require recipes-kernel/linux/meta-intel-compat-kernel.inc 2require recipes-kernel/linux/meta-intel-compat-kernel.inc
3 3
4FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:" 4FILESEXTRAPATHS:prepend := "${THISDIR}/linux-intel:"
5 5
6SRC_URI = " \ 6SRC_URI = " \
7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \ 8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
10 " 10 "
11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 11SRC_URI:append:core2-32-intel-common = " file://disable_skylake_sound.cfg"
12 12
13KMETA = "kernel-meta" 13KMETA = "kernel-meta"
14KCONF_BSP_AUDIT_LEVEL = "2" 14KCONF_BSP_AUDIT_LEVEL = "2"
@@ -29,6 +29,6 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
29COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)" 29COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)"
30 30
31# Functionality flags 31# Functionality flags
32KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" 32KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
33KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" 33KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
34KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 34KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
index 361b5dfc..b073abd1 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -10,7 +10,7 @@ python () {
10} 10}
11 11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 " 14 "
15 15
16KBRANCH = "5.10/preempt-rt" 16KBRANCH = "5.10/preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index 43199544..2669ac78 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -10,7 +10,7 @@ python () {
10} 10}
11 11
12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14" 14"
15 15
16KBRANCH = "5.4/preempt-rt" 16KBRANCH = "5.4/preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index c6163973..70a7e7dc 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -1,7 +1,7 @@
1require recipes-kernel/linux/linux-yocto.inc 1require recipes-kernel/linux/linux-yocto.inc
2require recipes-kernel/linux/meta-intel-compat-kernel.inc 2require recipes-kernel/linux/meta-intel-compat-kernel.inc
3 3
4FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:" 4FILESEXTRAPATHS:prepend := "${THISDIR}/linux-intel:"
5 5
6KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA}" 6KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA}"
7 7
@@ -10,8 +10,8 @@ SRC_URI = " \
10 ${KERNEL_CONFIG_URI} \ 10 ${KERNEL_CONFIG_URI} \
11 " 11 "
12 12
13SRC_URI_append = " file://enable_lynxpoint_gpio.cfg" 13SRC_URI:append = " file://enable_lynxpoint_gpio.cfg"
14SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 14SRC_URI:append:core2-32-intel-common = " file://disable_skylake_sound.cfg"
15 15
16LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" 16LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
17 17
@@ -22,5 +22,5 @@ KCONF_BSP_AUDIT_LEVEL = "2"
22 22
23COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)" 23COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)"
24 24
25KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" 25KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
26KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" 26KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
index dae4118a..8ddac046 100644
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -5,7 +5,7 @@ KMETA_BRANCH = "yocto-5.10"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7 7
8SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 " 9 "
10 10
11DEPENDS += "elfutils-native openssl-native util-linux-native" 11DEPENDS += "elfutils-native openssl-native util-linux-native"
@@ -15,8 +15,8 @@ SRCREV_machine ?= "916ac934a98bc8206c1b5e1500c891dbcb43aac7"
15SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc" 15SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc"
16 16
17# For Crystalforest and Romley 17# For Crystalforest and Romley
18KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 18KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
19KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 19KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
20 20
21# Functionality flags 21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
@@ -29,4 +29,4 @@ KCONF_BSP_AUDIT_LEVEL = "0"
29 29
30# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which 30# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
31# causes config warning too. 31# causes config warning too.
32KCONF_AUDIT_LEVEL_core2-32-intel-common = "0" 32KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index 5886d8b9..30d969a3 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -5,7 +5,7 @@ KMETA_BRANCH = "yocto-5.4"
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 6LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
7 7
8SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch" 8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
9 9
10DEPENDS += "elfutils-native openssl-native util-linux-native" 10DEPENDS += "elfutils-native openssl-native util-linux-native"
11 11
@@ -14,8 +14,8 @@ SRCREV_machine ?= "7a821854911e315d3ed3fe2fc626e12906c9ab24"
14SRCREV_meta ?= "656383210d369bbd49a7a278c6c7c7313f0df825" 14SRCREV_meta ?= "656383210d369bbd49a7a278c6c7c7313f0df825"
15 15
16# For Crystalforest and Romley 16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 17KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
18KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 18KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
19 19
20# Functionality flags 20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index 6173148c..deb19940 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,21 +1,21 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend:intel-x86-common := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 3COMPATIBLE_MACHINE:core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32" 4KMACHINE:core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 5KERNEL_FEATURES:append:core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6 6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE:corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64" 8KMACHINE:corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 9KERNEL_FEATURES:append:corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 10
11# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV 11# NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV
12# and setting them here breaks the default mechanism to use AUTOREV if the 12# and setting them here breaks the default mechanism to use AUTOREV if the
13# default SRCREV is set and linux-yocto-dev is the preferred provider. 13# default SRCREV is set and linux-yocto-dev is the preferred provider.
14 14
15# For Crystalforest and Romley 15# For Crystalforest and Romley
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 16KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" 17KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
18 18
19# For FRI2, NUC 19# For FRI2, NUC
20KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" 20KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " iwlwifi"
21KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" 21KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " iwlwifi"
diff --git a/recipes-kernel/linux/linux-yocto_%.bbappend b/recipes-kernel/linux/linux-yocto_%.bbappend
index 7c29be14..7657b02f 100644
--- a/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1,4 +1,4 @@
1# The kernel build is 64-bit regardless, so include both common overrides. 1# The kernel build is 64-bit regardless, so include both common overrides.
2# Without this, the kernel will be missing vars that make it buildable for the 2# Without this, the kernel will be missing vars that make it buildable for the
3# intel-corei7-64 machine. 3# intel-corei7-64 machine.
4MACHINEOVERRIDES_prepend_corei7-64-x32-intel-common = "corei7-64-intel-common:" 4MACHINEOVERRIDES:prepend:corei7-64-x32-intel-common = "corei7-64-intel-common:"