summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_5.15.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-02-20 13:44:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-02-21 11:59:16 +0800
commit03229249889f621577b211de2d5c4d12914c341b (patch)
tree7e204e299a21e30940d6ee1e335ed2f9be34fd88 /recipes-kernel/linux/linux-intel-rt_5.15.bb
parent533b604a322ccf4f3c75cb2d42385102b7cba90b (diff)
downloadmeta-intel-03229249889f621577b211de2d5c4d12914c341b.tar.gz
linux-intel/5.15: remove recipes
We're adding v6.1 as the LTS for this release so remove these recipes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_5.15.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.15.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.15.bb b/recipes-kernel/linux/linux-intel-rt_5.15.bb
deleted file mode 100644
index d25b895a..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.15.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
7# Skip processing of this recipe if it is not explicitly specified as the
8# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
9# to build multiple virtual/kernel providers, e.g. as dependency of
10# core-image-rt-sdk, core-image-rt.
11python () {
12 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
13 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
14}
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18KBRANCH = "5.15/preempt-rt"
19KMETA_BRANCH = "yocto-5.15"
20
21DEPENDS += "elfutils-native openssl-native util-linux-native"
22
23LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
24
25LINUX_VERSION ?= "5.15.85"
26SRCREV_machine ?= "a2fb1a92fb6e734b2253cde6b6ef5f203cf0fefc"
27SRCREV_meta ?= "78c4410c172946903e35ba8cebf1cf90fad09b5a"
28
29LINUX_KERNEL_TYPE = "preempt-rt"
30
31# We've 8b766b0f8eece backported from v5.19 to linux-intel v5.15 kernel
32# https://github.com/torvalds/linux/commit/8b766b0f8eece55155146f7628610ce54a065e0f
33# It drops 'CONFIG_FB_BOOT_VESA_SUPPORT' config option which would result in a warning with 5.15 y-k-c.
34# Suppress the harmless warning for now.
35KCONF_BSP_AUDIT_LEVEL = "0"
36
37UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v5.15.(\d+)-rt(\d+)-preempt-rt-(\d+)T(\d+)Z)$"