summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-02-20 13:44:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-02-21 11:59:16 +0800
commit03229249889f621577b211de2d5c4d12914c341b (patch)
tree7e204e299a21e30940d6ee1e335ed2f9be34fd88 /recipes-kernel/linux
parent533b604a322ccf4f3c75cb2d42385102b7cba90b (diff)
downloadmeta-intel-03229249889f621577b211de2d5c4d12914c341b.tar.gz
linux-intel/5.15: remove recipes
We're adding v6.1 as the LTS for this release so remove these recipes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.15.bb37
-rw-r--r--recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch48
-rw-r--r--recipes-kernel/linux/linux-intel_5.15.bb29
3 files changed, 0 insertions, 114 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.15.bb b/recipes-kernel/linux/linux-intel-rt_5.15.bb
deleted file mode 100644
index d25b895a..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.15.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
7# Skip processing of this recipe if it is not explicitly specified as the
8# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
9# to build multiple virtual/kernel providers, e.g. as dependency of
10# core-image-rt-sdk, core-image-rt.
11python () {
12 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
13 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
14}
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18KBRANCH = "5.15/preempt-rt"
19KMETA_BRANCH = "yocto-5.15"
20
21DEPENDS += "elfutils-native openssl-native util-linux-native"
22
23LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
24
25LINUX_VERSION ?= "5.15.85"
26SRCREV_machine ?= "a2fb1a92fb6e734b2253cde6b6ef5f203cf0fefc"
27SRCREV_meta ?= "78c4410c172946903e35ba8cebf1cf90fad09b5a"
28
29LINUX_KERNEL_TYPE = "preempt-rt"
30
31# We've 8b766b0f8eece backported from v5.19 to linux-intel v5.15 kernel
32# https://github.com/torvalds/linux/commit/8b766b0f8eece55155146f7628610ce54a065e0f
33# It drops 'CONFIG_FB_BOOT_VESA_SUPPORT' config option which would result in a warning with 5.15 y-k-c.
34# Suppress the harmless warning for now.
35KCONF_BSP_AUDIT_LEVEL = "0"
36
37UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v5.15.(\d+)-rt(\d+)-preempt-rt-(\d+)T(\d+)Z)$"
diff --git a/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch b/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
deleted file mode 100644
index 3dc71ff2..00000000
--- a/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From bebd63730a433ba62549a80114a9851328aa8897 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Mon, 2 Jul 2018 23:10:28 -0400
4Subject: [PATCH] menuconfig,mconf-cfg: Allow specification of ncurses location
5
6In some cross build environments such as the Yocto Project build
7environment it provides an ncurses library that is compiled
8differently than the host's version. This causes display corruption
9problems when the host's curses includes are used instead of the
10includes from the provided compiler are overridden. There is a second
11case where there is no curses libraries at all on the host system and
12menuconfig will just fail entirely.
13
14The solution is simply to allow an override variable in
15check-lxdialog.sh for environments such as the Yocto Project. Adding
16a CROSS_CURSES_LIB and CROSS_CURSES_INC solves the issue and allowing
17compiling and linking against the right headers and libraries.
18
19Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
20cc: Michal Marek <mmarek@suse.cz>
21cc: linux-kbuild@vger.kernel.org
22Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
23---
24 scripts/kconfig/mconf-cfg.sh | 8 ++++++++
25 1 file changed, 8 insertions(+)
26
27diff --git a/scripts/kconfig/mconf-cfg.sh b/scripts/kconfig/mconf-cfg.sh
28index c812872d7f9d..42d20819025c 100755
29--- a/scripts/kconfig/mconf-cfg.sh
30+++ b/scripts/kconfig/mconf-cfg.sh
31@@ -4,6 +4,14 @@
32 PKG="ncursesw"
33 PKG2="ncurses"
34
35+if [ "$CROSS_CURSES_LIB" != "" ]; then
36+ echo libs=\'$CROSS_CURSES_LIB\'
37+ if [ x"$CROSS_CURSES_INC" != x ]; then
38+ echo cflags=\'$CROSS_CURSES_INC\'
39+ fi
40+ exit 0
41+fi
42+
43 if [ -n "$(command -v pkg-config)" ]; then
44 if pkg-config --exists $PKG; then
45 echo cflags=\"$(pkg-config --cflags $PKG)\"
46--
472.17.1
48
diff --git a/recipes-kernel/linux/linux-intel_5.15.bb b/recipes-kernel/linux/linux-intel_5.15.bb
deleted file mode 100644
index 71861cb9..00000000
--- a/recipes-kernel/linux/linux-intel_5.15.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1require linux-intel.inc
2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 "
5SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
6
7KBRANCH = "5.15/linux"
8KMETA_BRANCH = "yocto-5.15"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
11
12DEPENDS += "elfutils-native openssl-native util-linux-native"
13
14LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
15
16LINUX_VERSION ?= "5.15.85"
17SRCREV_machine ?= "c256f934aefa78ec001067313a76a4a382ac59a6"
18SRCREV_meta ?= "78c4410c172946903e35ba8cebf1cf90fad09b5a"
19
20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
22
23# We've 8b766b0f8eece backported from v5.19 to linux-intel v5.15 kernel
24# https://github.com/torvalds/linux/commit/8b766b0f8eece55155146f7628610ce54a065e0f
25# It drops 'CONFIG_FB_BOOT_VESA_SUPPORT' config option which would result in a warning with 5.15 y-k-c.
26# Suppress the harmless warning for now.
27KCONF_BSP_AUDIT_LEVEL = "0"
28
29UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v5.15.(\d+)-linux-(\d+)T(\d+)Z)$"