summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_5.10.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-06-14 16:33:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-06-17 16:30:06 +0800
commita499bad106e1d1e6b15c64d44fae6fa7fa111e9e (patch)
tree4d500c14b10ee794242c1b3dcfe021c28c5f414a /recipes-kernel/linux/linux-intel-rt_5.10.bb
parent5184e1d89f3dc4019bdb17bf9fe05e83d7136e49 (diff)
downloadmeta-intel-a499bad106e1d1e6b15c64d44fae6fa7fa111e9e.tar.gz
linux-intel/5.10: remove recipes
5.15 is the only tested and default version now. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_5.10.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
deleted file mode 100644
index 16266d21..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 file://0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch \
15 "
16
17KBRANCH = "5.10/preempt-rt"
18KMETA_BRANCH = "yocto-5.10"
19
20DEPENDS += "elfutils-native openssl-native util-linux-native"
21
22LINUX_VERSION ?= "5.10.115"
23SRCREV_machine ?= "5dd48c946c3d28aa2eeeb04de125bfca1c88527f"
24SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
25
26LINUX_KERNEL_TYPE = "preempt-rt"
27
28# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
29# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
30# In which 'CONFIG_DRM_GMA3600' config option is dropped.
31# This causes warning during config audit. So suppress the harmless warning for now.
32KCONF_BSP_AUDIT_LEVEL = "0"
33
34# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
35# causes config warning too.
36KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"