summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-06-14 16:33:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-06-17 16:30:06 +0800
commita499bad106e1d1e6b15c64d44fae6fa7fa111e9e (patch)
tree4d500c14b10ee794242c1b3dcfe021c28c5f414a /recipes-kernel
parent5184e1d89f3dc4019bdb17bf9fe05e83d7136e49 (diff)
downloadmeta-intel-a499bad106e1d1e6b15c64d44fae6fa7fa111e9e.tar.gz
linux-intel/5.10: remove recipes
5.15 is the only tested and default version now. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb36
-rw-r--r--recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch94
-rw-r--r--recipes-kernel/linux/linux-intel/0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch89
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb34
4 files changed, 0 insertions, 253 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
deleted file mode 100644
index 16266d21..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 file://0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch \
15 "
16
17KBRANCH = "5.10/preempt-rt"
18KMETA_BRANCH = "yocto-5.10"
19
20DEPENDS += "elfutils-native openssl-native util-linux-native"
21
22LINUX_VERSION ?= "5.10.115"
23SRCREV_machine ?= "5dd48c946c3d28aa2eeeb04de125bfca1c88527f"
24SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
25
26LINUX_KERNEL_TYPE = "preempt-rt"
27
28# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
29# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
30# In which 'CONFIG_DRM_GMA3600' config option is dropped.
31# This causes warning during config audit. So suppress the harmless warning for now.
32KCONF_BSP_AUDIT_LEVEL = "0"
33
34# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
35# causes config warning too.
36KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch b/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
deleted file mode 100644
index e3608238..00000000
--- a/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
+++ /dev/null
@@ -1,94 +0,0 @@
1From cc3ff5fe73139251070775308dcaadf474566b4b Mon Sep 17 00:00:00 2001
2From: Thomas Gleixner <tglx@linutronix.de>
3Date: Tue, 3 Nov 2020 10:27:32 +0100
4Subject: [PATCH] io-mapping: Cleanup atomic iomap
5
6Switch the atomic iomap implementation over to kmap_local and stick the
7preempt/pagefault mechanics into the generic code similar to the
8kmap_atomic variants.
9
10Rename the x86 map function in preparation for a non-atomic variant.
11
12Upstream-Status: Backport [https://github.com/torvalds/linux/commit/351191ad55c8a1eccaf23e4187c62056229c0779]
13
14Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
15Cc: Linus Torvalds <torvalds@linuxfoundation.org>
16Cc: Christoph Hellwig <hch@lst.de>
17Cc: Andrew Morton <akpm@linux-foundation.org>
18Link: https://lore.kernel.org/r/20201103095858.625310005@linutronix.de
19---
20 arch/x86/include/asm/iomap.h | 9 +--------
21 arch/x86/mm/iomap_32.c | 6 ++----
22 include/linux/io-mapping.h | 8 ++++++--
23 3 files changed, 9 insertions(+), 14 deletions(-)
24
25diff --git a/arch/x86/include/asm/iomap.h b/arch/x86/include/asm/iomap.h
26index 0be7a30fd6bc..e2de092fc38c 100644
27--- a/arch/x86/include/asm/iomap.h
28+++ b/arch/x86/include/asm/iomap.h
29@@ -13,14 +13,7 @@
30 #include <asm/cacheflush.h>
31 #include <asm/tlbflush.h>
32
33-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot);
34-
35-static inline void iounmap_atomic(void __iomem *vaddr)
36-{
37- kunmap_local_indexed((void __force *)vaddr);
38- pagefault_enable();
39- preempt_enable();
40-}
41+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot);
42
43 int iomap_create_wc(resource_size_t base, unsigned long size, pgprot_t *prot);
44
45diff --git a/arch/x86/mm/iomap_32.c b/arch/x86/mm/iomap_32.c
46index e0a40d7cc66c..9aaa756ddf21 100644
47--- a/arch/x86/mm/iomap_32.c
48+++ b/arch/x86/mm/iomap_32.c
49@@ -44,7 +44,7 @@ void iomap_free(resource_size_t base, unsigned long size)
50 }
51 EXPORT_SYMBOL_GPL(iomap_free);
52
53-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
54+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot)
55 {
56 /*
57 * For non-PAT systems, translate non-WB request to UC- just in
58@@ -60,8 +60,6 @@ void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
59 /* Filter out unsupported __PAGE_KERNEL* bits: */
60 pgprot_val(prot) &= __default_kernel_pte_mask;
61
62- preempt_disable();
63- pagefault_disable();
64 return (void __force __iomem *)__kmap_local_pfn_prot(pfn, prot);
65 }
66-EXPORT_SYMBOL_GPL(iomap_atomic_pfn_prot);
67+EXPORT_SYMBOL_GPL(__iomap_local_pfn_prot);
68diff --git a/include/linux/io-mapping.h b/include/linux/io-mapping.h
69index 0a1a186a43c5..e9743cfd8585 100644
70--- a/include/linux/io-mapping.h
71+++ b/include/linux/io-mapping.h
72@@ -69,13 +69,17 @@ io_mapping_map_atomic_wc(struct io_mapping *mapping,
73
74 BUG_ON(offset >= mapping->size);
75 phys_addr = mapping->base + offset;
76- return iomap_atomic_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
77+ preempt_disable();
78+ pagefault_disable();
79+ return __iomap_local_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
80 }
81
82 static inline void
83 io_mapping_unmap_atomic(void __iomem *vaddr)
84 {
85- iounmap_atomic(vaddr);
86+ kunmap_local_indexed((void __force *)vaddr);
87+ pagefault_enable();
88+ preempt_enable();
89 }
90
91 static inline void __iomem *
92--
932.17.1
94
diff --git a/recipes-kernel/linux/linux-intel/0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch b/recipes-kernel/linux/linux-intel/0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch
deleted file mode 100644
index 2044b3cf..00000000
--- a/recipes-kernel/linux/linux-intel/0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch
+++ /dev/null
@@ -1,89 +0,0 @@
1From 1c80d994d3dbdaefb429305461e95a86be5b3862 Mon Sep 17 00:00:00 2001
2From: Dmitry Osipenko <digetx@gmail.com>
3Date: Tue, 10 May 2022 16:53:06 +0800
4Subject: [PATCH] regulator: consumer: Add missing stubs to
5 regulator/consumer.h
6
7commit 51dfb6ca3728bd0a0a3c23776a12d2a15a1d2457 upstream
8
9Add missing stubs to regulator/consumer.h in order to fix COMPILE_TEST
10of the kernel. In particular this should fix compile-testing of OPP core
11because of a missing stub for regulator_sync_voltage().
12
13Reported-by: kernel test robot <lkp@intel.com>
14Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
15Link: https://lore.kernel.org/r/20210120205844.12658-1-digetx@gmail.com
16Signed-off-by: Mark Brown <broonie@kernel.org>
17
18Backport from mainline to fix build failure when CONFIG_REGULATOR=n which
19is default in linux-yocto.
205.10.114 in mainline stable tree does not handle this case.
21Link: https://lore.kernel.org/all/62796b82.1c69fb81.1bf47.0bcf@mx.google.com/
22
23Upstream-Status: Backported [https://github.com/torvalds/linux/commit/51dfb6ca3728bd0a0a3c23776a12d2a15a1d2457]
24
25Signed-off-by: He Zhe <zhe.he@windriver.com>
26Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
27Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
28---
29 include/linux/regulator/consumer.h | 30 ++++++++++++++++++++++++++++++
30 1 file changed, 30 insertions(+)
31
32diff --git a/include/linux/regulator/consumer.h b/include/linux/regulator/consumer.h
33index 2024944fd2f7..20e84a84fb77 100644
34--- a/include/linux/regulator/consumer.h
35+++ b/include/linux/regulator/consumer.h
36@@ -331,6 +331,12 @@ regulator_get_exclusive(struct device *dev, const char *id)
37 return ERR_PTR(-ENODEV);
38 }
39
40+static inline struct regulator *__must_check
41+devm_regulator_get_exclusive(struct device *dev, const char *id)
42+{
43+ return ERR_PTR(-ENODEV);
44+}
45+
46 static inline struct regulator *__must_check
47 regulator_get_optional(struct device *dev, const char *id)
48 {
49@@ -486,6 +492,11 @@ static inline int regulator_get_voltage(struct regulator *regulator)
50 return -EINVAL;
51 }
52
53+static inline int regulator_sync_voltage(struct regulator *regulator)
54+{
55+ return -EINVAL;
56+}
57+
58 static inline int regulator_is_supported_voltage(struct regulator *regulator,
59 int min_uV, int max_uV)
60 {
61@@ -578,6 +589,25 @@ static inline int devm_regulator_unregister_notifier(struct regulator *regulator
62 return 0;
63 }
64
65+static inline int regulator_suspend_enable(struct regulator_dev *rdev,
66+ suspend_state_t state)
67+{
68+ return -EINVAL;
69+}
70+
71+static inline int regulator_suspend_disable(struct regulator_dev *rdev,
72+ suspend_state_t state)
73+{
74+ return -EINVAL;
75+}
76+
77+static inline int regulator_set_suspend_voltage(struct regulator *regulator,
78+ int min_uV, int max_uV,
79+ suspend_state_t state)
80+{
81+ return -EINVAL;
82+}
83+
84 static inline void *regulator_get_drvdata(struct regulator *regulator)
85 {
86 return NULL;
87--
882.25.1
89
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
deleted file mode 100644
index 3ed2541c..00000000
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1require linux-intel.inc
2
3KBRANCH = "5.10/yocto"
4KMETA_BRANCH = "yocto-5.10"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7
8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 file://0001-io-mapping-Cleanup-atomic-iomap.patch \
10 file://0001-regulator-consumer-Add-missing-stubs-to-regulator-co.patch \
11 "
12
13DEPENDS += "elfutils-native openssl-native util-linux-native"
14
15LINUX_VERSION ?= "5.10.115"
16SRCREV_machine ?= "9d73f92a1109a0f9e916edb861214ce1cea6863a"
17SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
18
19# For Crystalforest and Romley
20KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
21KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
22
23# Functionality flags
24KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
25
26# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
27# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
28# In which 'CONFIG_DRM_GMA3600' config option is dropped.
29# This causes warning during config audit. So suppress the harmless warning for now.
30KCONF_BSP_AUDIT_LEVEL = "0"
31
32# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
33# causes config warning too.
34KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"