summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
commit0584f638797a816b29b909d4611d5a099df7bbc1 (patch)
tree1ec4bdacf824c304290b5086fd54bba9b84158e2 /recipes-graphics
parent7a5e47b6a594eb29dfe84e47f043a49974bc0402 (diff)
downloadmeta-intel-0584f638797a816b29b909d4611d5a099df7bbc1.tar.gz
Convert to new override syntax
Use the convert-overrides.py to convert to new syntax and manually fix some additional changes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gmmlib/gmmlib_21.2.1.bb2
-rw-r--r--recipes-graphics/hdcp/hdcp_21.1.0.bb4
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.12.0.bb2
-rw-r--r--recipes-graphics/libva/libva-intel_2.12.0.bb18
4 files changed, 13 insertions, 13 deletions
diff --git a/recipes-graphics/gmmlib/gmmlib_21.2.1.bb b/recipes-graphics/gmmlib/gmmlib_21.2.1.bb
index 90700bc4..f36e2979 100644
--- a/recipes-graphics/gmmlib/gmmlib_21.2.1.bb
+++ b/recipes-graphics/gmmlib/gmmlib_21.2.1.bb
@@ -14,7 +14,7 @@ SRCREV = "9253eb8b949515d2a5030f99163a35567fe81838"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17COMPATIBLE_HOST_x86-x32 = "null" 17COMPATIBLE_HOST:x86-x32 = "null"
18 18
19UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$" 19UPSTREAM_CHECK_GITTAGREGEX = "^intel-gmmlib-(?P<pver>(\d+(\.\d+)+))$"
20 20
diff --git a/recipes-graphics/hdcp/hdcp_21.1.0.bb b/recipes-graphics/hdcp/hdcp_21.1.0.bb
index 016e8e0a..b336c7ac 100644
--- a/recipes-graphics/hdcp/hdcp_21.1.0.bb
+++ b/recipes-graphics/hdcp/hdcp_21.1.0.bb
@@ -20,7 +20,7 @@ REQUIRED_DISTRO_FEATURES = "systemd"
20DEPENDS = "libdrm virtual/mesa systemd" 20DEPENDS = "libdrm virtual/mesa systemd"
21 21
22USERADD_PACKAGES = "${PN}" 22USERADD_PACKAGES = "${PN}"
23USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media" 23USERADD_PARAM:${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media"
24 24
25SYSTEMD_SERVICE_${PN} = "hdcpd.service" 25SYSTEMD_SERVICE:${PN} = "hdcpd.service"
26SYSTEMD_AUTO_ENABLE = "disable" 26SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-graphics/libva/libva-intel-utils_2.12.0.bb b/recipes-graphics/libva/libva-intel-utils_2.12.0.bb
index f083703a..5eb604dd 100644
--- a/recipes-graphics/libva/libva-intel-utils_2.12.0.bb
+++ b/recipes-graphics/libva/libva-intel-utils_2.12.0.bb
@@ -32,4 +32,4 @@ PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland" 32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"
33 33
34PROVIDES = "libva-utils" 34PROVIDES = "libva-utils"
35RPROVIDES_${PN} += "libva-utils" 35RPROVIDES:${PN} += "libva-utils"
diff --git a/recipes-graphics/libva/libva-intel_2.12.0.bb b/recipes-graphics/libva/libva-intel_2.12.0.bb
index 15a9391a..4e48496a 100644
--- a/recipes-graphics/libva/libva-intel_2.12.0.bb
+++ b/recipes-graphics/libva/libva-intel_2.12.0.bb
@@ -40,15 +40,15 @@ PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wa
40 40
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" 41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42 42
43RDEPENDS_${PN}-x11 =+ "${PN}" 43RDEPENDS:${PN}-x11 =+ "${PN}"
44RDEPENDS_${PN}-glx =+ "${PN}-x11" 44RDEPENDS:${PN}-glx =+ "${PN}-x11"
45 45
46FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" 46FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" 47FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" 48FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49 49
50PROVIDES += "libva" 50PROVIDES += "libva"
51RPROVIDES_${PN} += "libva" 51RPROVIDES:${PN} += "libva"
52RPROVIDES_${PN}-x11 += "libva-x11" 52RPROVIDES:${PN}-x11 += "libva-x11"
53RPROVIDES_${PN}-glx += "libva-glx" 53RPROVIDES:${PN}-glx += "libva-glx"
54RPROVIDES_${PN}-wayland += "libva-wayland" 54RPROVIDES:${PN}-wayland += "libva-wayland"