summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald/thermald_2.2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-06-22 08:47:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-22 13:59:04 +0800
commitd7c8cc9f47a1551836cf9b2e88b998fe22b20a20 (patch)
treecea6601b93ee3409f0a8f03435845b900dfc2e59 /recipes-bsp/thermald/thermald_2.2.bb
parent635e8a6892163cc3334a9b947abaca70697d458f (diff)
downloadmeta-intel-d7c8cc9f47a1551836cf9b2e88b998fe22b20a20.tar.gz
thermald: upgrade 1.9.1 -> 2.2
openmp is not required by thermald so remove the dependency. Also remove the DEPENDS on systemd and pass the systemd unit directory path. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp/thermald/thermald_2.2.bb')
-rw-r--r--recipes-bsp/thermald/thermald_2.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/thermald/thermald_2.2.bb b/recipes-bsp/thermald/thermald_2.2.bb
new file mode 100644
index 00000000..6da1291d
--- /dev/null
+++ b/recipes-bsp/thermald/thermald_2.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
12
13SRC_URI = "git://github.com/intel/thermal_daemon/ \
14 file://0001-configure.ac-disable-werror.patch \
15 "
16SRCREV = "4f0e68974c26749191ac945586b8cc97800d5d02"
17S = "${WORKDIR}/git"
18
19inherit pkgconfig autotools systemd
20
21EXTRA_OECONF = " \
22 --with-systemdsystemunitdir=${systemd_system_unitdir} \
23 "
24
25FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
26
27SYSTEMD_SERVICE_${PN} = "thermald.service"
28
29COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
30
31CONFFILES_${PN} = " \
32 ${sysconfdir}/thermald/thermal-conf.xml \
33 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
34 "
35
36UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"