summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-06-22 08:47:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-22 13:59:04 +0800
commitd7c8cc9f47a1551836cf9b2e88b998fe22b20a20 (patch)
treecea6601b93ee3409f0a8f03435845b900dfc2e59 /recipes-bsp
parent635e8a6892163cc3334a9b947abaca70697d458f (diff)
downloadmeta-intel-d7c8cc9f47a1551836cf9b2e88b998fe22b20a20.tar.gz
thermald: upgrade 1.9.1 -> 2.2
openmp is not required by thermald so remove the dependency. Also remove the DEPENDS on systemd and pass the systemd unit directory path. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch27
-rw-r--r--recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch51
-rw-r--r--recipes-bsp/thermald/thermald_2.2.bb (renamed from recipes-bsp/thermald/thermald_1.9.1.bb)11
3 files changed, 33 insertions, 56 deletions
diff --git a/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch b/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch
new file mode 100644
index 00000000..b8639e0e
--- /dev/null
+++ b/recipes-bsp/thermald/thermald/0001-configure.ac-disable-werror.patch
@@ -0,0 +1,27 @@
1From b20692607ec8b0895c5ac0c23b0393ad3048640d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 22 Jun 2020 09:34:51 +0800
4Subject: [PATCH] configure.ac: disable werror
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 configure.ac | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/configure.ac b/configure.ac
14index 7d6c13c..3e1a8bf 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -84,7 +84,6 @@ for flag in \
18 -Wall \
19 -Wclobbered \
20 -Wempty-body \
21- -Werror \
22 -Wformat \
23 -Wignored-qualifiers \
24 -Wmissing-field-initializers \
25--
262.25.4
27
diff --git a/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch b/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch
deleted file mode 100644
index ee3c5e5e..00000000
--- a/recipes-bsp/thermald/thermald/0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 2145c92fb2ee6d1b03b9ea92e0f910e60b925d70 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 5 Mar 2020 13:45:57 +0800
4Subject: [PATCH] thd_trip_point: fix 32-bit build error with musl v1.2.0
5
6Error log:
7 ../git/src/thd_trip_point.cpp: In member function 'bool cthd_trip_point::thd_trip_point_check(int, unsigned int, int, bool*)':
8| ../git/src/thd_trip_point.cpp:250:19: error: format '%ld' expects argument of type 'long int', but argument 6 has type 'time_t' {aka 'long long int'} [-Werror=format=]
9| 250 | thd_log_info("Too early to act zone:%d index %d tm %ld\n",
10
11musl 1.2.0 have new feature:
12time_t is now 64-bit on all archs (not just 64-bit archs)
13
14Commit id:
15https://git.musl-libc.org/cgit/musl/commit/?id=38143339646a4ccce8afe298c34467767c899f51
16
17Release note link for musl 1.2.0:
18https://git.musl-libc.org/cgit/musl/diff/
19
20Upstream-Status: Submitted [https://github.com/intel/thermal_daemon/pull/217]
21
22Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
23---
24 src/thd_trip_point.cpp | 10 ++--------
25 1 file changed, 2 insertions(+), 8 deletions(-)
26
27diff --git a/src/thd_trip_point.cpp b/src/thd_trip_point.cpp
28index 043be0c..2186ac2 100644
29--- a/src/thd_trip_point.cpp
30+++ b/src/thd_trip_point.cpp
31@@ -242,15 +242,9 @@ bool cthd_trip_point::thd_trip_point_check(int id, unsigned int read_temp,
32 time_t tm;
33 time(&tm);
34 if ((tm - cdevs[i].last_op_time) < cdevs[i].sampling_priod) {
35-#if defined __x86_64__ && defined __ILP32__
36- thd_log_info("Too early to act zone:%d index %d tm %lld\n",
37+ thd_log_info("Too early to act zone:%d index %d tm %jd\n",
38 zone_id, cdev->thd_cdev_get_index(),
39- tm - cdevs[i].last_op_time);
40-#else
41- thd_log_info("Too early to act zone:%d index %d tm %ld\n",
42- zone_id, cdev->thd_cdev_get_index(),
43- tm - cdevs[i].last_op_time);
44-#endif
45+ (intmax_t)tm - cdevs[i].last_op_time);
46 break;
47 }
48 cdevs[i].last_op_time = tm;
49--
502.17.1
51
diff --git a/recipes-bsp/thermald/thermald_1.9.1.bb b/recipes-bsp/thermald/thermald_2.2.bb
index be68aa48..6da1291d 100644
--- a/recipes-bsp/thermald/thermald_1.9.1.bb
+++ b/recipes-bsp/thermald/thermald_2.2.bb
@@ -7,20 +7,21 @@ compensation using available cooling methods."
7HOMEPAGE = "https://github.com/01org/thermal_daemon" 7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8 8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native" 9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2" 10LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848" 11LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15 12
16SRC_URI = "git://github.com/intel/thermal_daemon/ \ 13SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-thd_trip_point-fix-32-bit-build-error-with-musl-v1.2.patch \ 14 file://0001-configure.ac-disable-werror.patch \
18 " 15 "
19SRCREV = "7e23f7cc4611fd7289014c9805749ec75d59bae0" 16SRCREV = "4f0e68974c26749191ac945586b8cc97800d5d02"
20S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
21 18
22inherit pkgconfig autotools systemd 19inherit pkgconfig autotools systemd
23 20
21EXTRA_OECONF = " \
22 --with-systemdsystemunitdir=${systemd_system_unitdir} \
23 "
24
24FILES_${PN} += "${datadir}/dbus-1/system-services/*.service" 25FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
25 26
26SYSTEMD_SERVICE_${PN} = "thermald.service" 27SYSTEMD_SERVICE_${PN} = "thermald.service"