summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
commit0584f638797a816b29b909d4611d5a099df7bbc1 (patch)
tree1ec4bdacf824c304290b5086fd54bba9b84158e2 /dynamic-layers/openembedded-layer/recipes-support/opencv
parent7a5e47b6a594eb29dfe84e47f043a49974bc0402 (diff)
downloadmeta-intel-0584f638797a816b29b909d4611d5a099df7bbc1.tar.gz
Convert to new override syntax
Use the convert-overrides.py to convert to new syntax and manually fix some additional changes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb6
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb18
2 files changed, 12 insertions, 12 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb
index 700f78c2..1461afe1 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb
@@ -21,7 +21,7 @@ OECMAKE_SOURCEPATH = "${S}/demos"
21 21
22DEPENDS += "openvino-inference-engine opencv gflags" 22DEPENDS += "openvino-inference-engine opencv gflags"
23 23
24RDEPENDS_${PN} += " \ 24RDEPENDS:${PN} += " \
25 python3-decorator \ 25 python3-decorator \
26 python3-defusedxml \ 26 python3-defusedxml \
27 python3-networkx \ 27 python3-networkx \
@@ -46,7 +46,7 @@ EXTRA_OECMAKE += " \
46 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \ 46 -DIE_ROOT_DIR=${WORKDIR}/InferenceEngine \
47" 47"
48 48
49do_configure_prepend(){ 49do_configure:prepend(){
50 mkdir -p ${WORKDIR}/InferenceEngine/share 50 mkdir -p ${WORKDIR}/InferenceEngine/share
51 cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/ 51 cp ${STAGING_LIBDIR}/cmake/InferenceEngine/* ${WORKDIR}/InferenceEngine/share/
52} 52}
@@ -63,4 +63,4 @@ do_install(){
63 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools 63 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
64} 64}
65 65
66FILES_${PN} += "${datadir}/openvino" 66FILES:${PN} += "${datadir}/openvino"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
index 19da3e1b..654cac13 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2021.3.bb
@@ -30,7 +30,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
30 file://thirdparty/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa \ 30 file://thirdparty/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa \
31 file://inference-engine/thirdparty/clDNN/common/include/OpenCL_CLHPP_License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 31 file://inference-engine/thirdparty/clDNN/common/include/OpenCL_CLHPP_License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
32" 32"
33LICENSE_${PN}-vpu-firmware = "ISSL" 33LICENSE:${PN}-vpu-firmware = "ISSL"
34 34
35inherit cmake python3native 35inherit cmake python3native
36 36
@@ -64,7 +64,7 @@ DEPENDS += "libusb1 \
64 " 64 "
65 65
66COMPATIBLE_HOST = '(x86_64).*-linux' 66COMPATIBLE_HOST = '(x86_64).*-linux'
67COMPATIBLE_HOST_libc-musl = "null" 67COMPATIBLE_HOST:libc-musl = "null"
68 68
69#Disable opencl temporarily. intel-compute-runtime depends on 69#Disable opencl temporarily. intel-compute-runtime depends on
70#intel-graphics-compiler and vc-intrinsics and these two recipes fail to 70#intel-graphics-compiler and vc-intrinsics and these two recipes fail to
@@ -76,7 +76,7 @@ PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY}
76PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../mvnc/pcie-ma2x8x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware" 76PACKAGECONFIG[vpu] = "-DENABLE_VPU=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../mvnc/usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../mvnc/pcie-ma2x8x.mvcmd,-DENABLE_VPU=OFF,,${PN}-vpu-firmware"
77PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" 77PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
78 78
79do_install_append() { 79do_install:append() {
80 if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then 80 if ${@bb.utils.contains('PACKAGECONFIG', 'vpu', 'true', 'false', d)}; then
81 install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/ 81 install -m0644 ${WORKDIR}/mvnc/usb-ma2x8x.mvcmd ${D}${libdir}/
82 install -m0644 ${WORKDIR}/mvnc/pcie-ma2x8x.mvcmd ${D}${libdir}/ 82 install -m0644 ${WORKDIR}/mvnc/pcie-ma2x8x.mvcmd ${D}${libdir}/
@@ -102,13 +102,13 @@ do_install_append() {
102 102
103# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR 103# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR
104# instead of RSS 104# instead of RSS
105SSTATE_SCAN_FILES_append = " *.cmake" 105SSTATE_SCAN_FILES:append = " *.cmake"
106 106
107FILES_${PN}-dev = "${includedir} \ 107FILES:${PN}-dev = "${includedir} \
108 ${libdir}/cmake \ 108 ${libdir}/cmake \
109 " 109 "
110 110
111FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \ 111FILES:${PN} += "${libdir}/lib*${SOLIBSDEV} \
112 ${datadir}/openvino \ 112 ${datadir}/openvino \
113 ${libdir}/custom_kernels \ 113 ${libdir}/custom_kernels \
114 ${libdir}/plugins.xml \ 114 ${libdir}/plugins.xml \
@@ -118,12 +118,12 @@ FILES_${PN} += "${libdir}/lib*${SOLIBSDEV} \
118# Move inference engine samples into a separate package 118# Move inference engine samples into a separate package
119PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware" 119PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
120 120
121FILES_${PN}-samples = "${datadir}/inference_engine \ 121FILES:${PN}-samples = "${datadir}/inference_engine \
122 ${bindir} \ 122 ${bindir} \
123 " 123 "
124FILES_${PN}-vpu-firmware += "${libdir}/*.mvcmd" 124FILES:${PN}-vpu-firmware += "${libdir}/*.mvcmd"
125 125
126# Package for inference engine python API 126# Package for inference engine python API
127PACKAGES =+ "${PN}-${PYTHON_PN}" 127PACKAGES =+ "${PN}-${PYTHON_PN}"
128 128
129FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino" 129FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}/openvino"