summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-06-08 12:28:23 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-06-09 10:52:17 +0800
commit348511101c7095fef20aa46e21104e98bdaf44ba (patch)
tree29d72d9e924c310db1338ee6f0d2815de2fb48f9 /dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
parenteb696e99ff8c5be4f9b181da9f134499d96760e4 (diff)
downloadmeta-intel-348511101c7095fef20aa46e21104e98bdaf44ba.tar.gz
openvino-inference-engine: upgrade 2022.3.0 -> 2023.0.0
* OpenVINO no longer supports vpu so remove the vpu PACKAGECONFIG and references. * Now allows snappy compression to be used for TF frontend so allow system installed snappy. * Flatbuffers is now needed for TF Lite frontend. * Refresh patches. Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb123
1 files changed, 0 insertions, 123 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
deleted file mode 100644
index 87af47ee..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
+++ /dev/null
@@ -1,123 +0,0 @@
1SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit"
2HOMEPAGE = "https://github.com/opencv/dldt"
3DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic."
6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/3;lfs=0 \
8 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_usb-ma2x8x_20230121_38.zip;name=usb_ma2x8x \
9 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_pcie-ma2x8x_20230121_38.zip;name=pcie_ma2x8x \
10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
11 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
12 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
13 git://github.com/nlohmann/json.git;protocol=https;destsuffix=git/thirdparty/json/nlohmann_json;name=json;branch=develop \
14 git://github.com/opencv/ade.git;protocol=https;destsuffix=git/thirdparty/ade;name=ade;nobranch=1 \
15 file://fix-build.patch \
16 file://cython-cmake.patch \
17 file://7cecc9138b89e1946e3e515727bb69b2ab119806.patch;patchdir=thirdparty/ade \
18 file://fix-build-with-gcc13.patch \
19 file://onednn-fix-build-with-gcc13.patch;patchdir=src/plugins/intel_gpu/thirdparty/onednn_gpu \
20 "
21
22SRCREV = "0a5ca5375265f0f12cdaee68574030408dd1c352"
23SRCREV_mkl = "44de3c3698b687c26e487fc8f0213fa487e8fe2c"
24SRCREV_onednn = "fbec3e25a559ee252022ae066817b204e106a6ba"
25SRCREV_xbyak = "f8ea5c28dfcdc98585881d0ca9e499580ca077ae"
26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
27SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"
28
29SRC_URI[usb_ma2x8x.sha256sum] = "f7351b2e26f25d652a0539f6ace5797d7700735d52479c3e6ef354c236abbd3a"
30SRC_URI[pcie_ma2x8x.sha256sum] = "439219aeac010f8b85f19838420e9a247f2cdf23a6d00e7727cf92d96dbdaeeb"
31
32LICENSE = "Apache-2.0 & MIT & BSD-3-Clause"
33LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
34 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \
35 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \
36 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \
37 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
38 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \
39 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \
40"
41
42inherit cmake python3native pkgconfig
43
44S = "${WORKDIR}/git"
45EXTRA_OECMAKE += " \
46 -DENABLE_OPENCV=OFF \
47 -DENABLE_INTEL_GNA=OFF \
48 -DENABLE_SYSTEM_TBB=ON \
49 -DPYTHON_EXECUTABLE=${PYTHON} \
50 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
51 -DTHREADING=TBB -DTBB_DIR="${STAGING_LIBDIR}/cmake/TBB" \
52 -DTREAT_WARNING_AS_ERROR=FALSE \
53 -DENABLE_DATA=FALSE \
54 -DENABLE_SYSTEM_PUGIXML=TRUE \
55 -DENABLE_SYSTEM_PROTOBUF=TRUE \
56 -DENABLE_OV_ONNX_FRONTEND=FALSE \
57 -DUSE_BUILD_TYPE_SUBFOLDER=OFF \
58 -DENABLE_FUZZING=OFF \
59 -DENABLE_TBBBIND_2_5=OFF \
60 -DCPACK_GENERATOR=RPM \
61 "
62
63
64DEPENDS += "\
65 gflags \
66 libusb1 \
67 protobuf \
68 protobuf-native \
69 protobuf-c \
70 pugixml \
71 python3-pybind11 \
72 tbb \
73 zlib \
74 "
75
76COMPATIBLE_HOST = '(x86_64).*-linux'
77COMPATIBLE_HOST:libc-musl = "null"
78
79PACKAGECONFIG ?= "vpu opencl samples"
80PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp,"
81PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython"
82PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv"
83PACKAGECONFIG[vpu] = "-DENABLE_INTEL_MYRIAD=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../pcie-ma2x8x.mvcmd,-DENABLE_INTEL_MYRIAD=OFF,,${PN}-vpu-firmware"
84PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
85
86do_configure:prepend() {
87 # Dont set PROJECT_ROOT_DIR
88 sed -i -e 's:\${OpenVINO_SOURCE_DIR}::;' ${S}/src/CMakeLists.txt
89}
90
91do_install:append() {
92 rm -rf ${D}${prefix}/install_dependencies
93 rm -rf ${D}${prefix}/setupvars.sh
94
95 sed -i -e 's:^#include.*imp.hpp"$:#include "/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/git/src/plugins/intel_cpu/src/nodes/proposal_imp.hpp":g;' ${B}/src/plugins/intel_cpu/cross-compiled/proposal_imp_disp.cpp
96}
97
98# Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR
99# instead of RSS
100SSTATE_SCAN_FILES:append = " *.cmake"
101
102FILES:${PN} += "\
103 ${libdir}/openvino-${PV}/lib*${SOLIBSDEV} \
104 ${libdir}/openvino-${PV}/plugins.xml \
105 ${libdir}/openvino-${PV}/cache.json \
106 "
107
108# Move inference engine samples into a separate package
109PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware"
110
111FILES:${PN}-samples = "${datadir}/openvino \
112 ${bindir} \
113 ${libdir}/libformat_reader.so \
114 ${libdir}/libopencv_c_wrapper.so \
115 "
116FILES:${PN}-vpu-firmware += "${libdir}/openvino-${PV}/*.mvcmd"
117
118# Package for inference engine python API
119PACKAGES =+ "${PN}-${PYTHON_PN}"
120
121FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
122
123UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+\.\d+\.\d+))$"