summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-09-21 13:57:40 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-09-29 10:05:11 +0800
commitf9cb1d9aa9ded127236f7d072e0af2403e4ab4fc (patch)
tree361ec65fe471e3af9f87b7f2068efd9509186ab4 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parentcc04677a2717be485bf9cecf4a3d48f8a1e601cc (diff)
downloadmeta-intel-f9cb1d9aa9ded127236f7d072e0af2403e4ab4fc.tar.gz
openvino-inference-engine: upgrade 2023.0.2 -> 2023.1.0
* Release notes: https://github.com/openvinotoolkit/openvino/releases/tag/2023.1.0 * samples package includes scripts that need Python to be present. Specify that dependency explicitly. License-Update: Updated copyright information. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch84
1 files changed, 59 insertions, 25 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 8481dadc..9e71e689 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -1,19 +1,40 @@
1Yocto specific tweaks to the build process: 1From 7deabff3d51df783c3e24bcc190c3ddebca7d9a8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 21 Sep 2023 14:07:28 +0800
4Subject: [PATCH] cmake: yocto specific tweaks to the build process
2 5
3* Dont try to detect glibc version as that doesn't work when cross compiling. 6* Dont try to detect glibc version as that doesn't work when cross compiling.
4* Use shared protobuf and gflags libs. 7* Use shared gflags libs.
5* Install sample binaries as well. 8* Install sample binaries as well.
9* Dont strip binaries.
10* Dont try to write triggers for CPack. We package ourselves.
6 11
7Upstream-Status: Inappropriate 12Upstream-Status: Inappropriate
13
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9--- 15---
10 cmake/developer_package/target_flags.cmake | 2 +- 16 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +-
11 samples/cpp/CMakeLists.txt | 6 +++--- 17 cmake/developer_package/target_flags.cmake | 2 +-
12 thirdparty/CMakeLists.txt | 8 ++++---- 18 samples/cpp/CMakeLists.txt | 6 +++---
13 3 files changed, 8 insertions(+), 8 deletions(-) 19 src/bindings/python/wheel/setup.py | 1 -
20 thirdparty/dependencies.cmake | 10 +++++-----
21 5 files changed, 10 insertions(+), 11 deletions(-)
14 22
23diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake
24index 0609750054f..0f5c7765197 100644
25--- a/cmake/developer_package/packaging/rpm/rpm.cmake
26+++ b/cmake/developer_package/packaging/rpm/rpm.cmake
27@@ -161,7 +161,7 @@ ov_rpm_specific_settings()
28 # needed to add triggers for packages with libraries
29 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers")
30 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n")
31-file(WRITE "${def_triggers}" "${triggers_content}")
32+#file(WRITE "${def_triggers}" "${triggers_content}")
33
34 #
35 # Functions helpful for packaging your modules with RPM cpack
15diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 36diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
16index ced8d519da3..505c1fa5b14 100644 37index 29f23e713e1..942dd445b19 100644
17--- a/cmake/developer_package/target_flags.cmake 38--- a/cmake/developer_package/target_flags.cmake
18+++ b/cmake/developer_package/target_flags.cmake 39+++ b/cmake/developer_package/target_flags.cmake
19@@ -145,4 +145,4 @@ function(ov_glibc_version) 40@@ -145,4 +145,4 @@ function(ov_glibc_version)
@@ -23,10 +44,10 @@ index ced8d519da3..505c1fa5b14 100644
23-ov_glibc_version() 44-ov_glibc_version()
24+#ov_glibc_version() 45+#ov_glibc_version()
25diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 46diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
26index 37eb0250112..35ec6a3368a 100644 47index 8849aaf47d1..450b57c18d6 100644
27--- a/samples/cpp/CMakeLists.txt 48--- a/samples/cpp/CMakeLists.txt
28+++ b/samples/cpp/CMakeLists.txt 49+++ b/samples/cpp/CMakeLists.txt
29@@ -219,9 +219,9 @@ macro(ie_add_sample) 50@@ -223,9 +223,9 @@ macro(ie_add_sample)
30 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 51 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
31 52
32 install(TARGETS ${IE_SAMPLE_NAME} 53 install(TARGETS ${IE_SAMPLE_NAME}
@@ -39,26 +60,39 @@ index 37eb0250112..35ec6a3368a 100644
39 60
40 # create global target with all samples / demo apps 61 # create global target with all samples / demo apps
41 if(NOT TARGET ie_samples) 62 if(NOT TARGET ie_samples)
42diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 63diff --git a/src/bindings/python/wheel/setup.py b/src/bindings/python/wheel/setup.py
43index 95d80a6fbd4..963c9a5d60a 100644 64index 04323a8ba49..0498dcdc126 100644
44--- a/thirdparty/CMakeLists.txt 65--- a/src/bindings/python/wheel/setup.py
45+++ b/thirdparty/CMakeLists.txt 66+++ b/src/bindings/python/wheel/setup.py
46@@ -353,11 +353,11 @@ endif() 67@@ -270,7 +270,6 @@ class CustomBuild(build):
47 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 68 self.spawn(["cmake", "--install", binary_dir,
48 # on Windows and macOS we don't use gflags, because will be dynamically linked 69 "--prefix", prefix,
49 if(CMAKE_HOST_LINUX AND LINUX) 70 "--config", "Release",
71- "--strip",
72 "--component", cpack_comp_name])
73
74 def run(self):
75diff --git a/thirdparty/dependencies.cmake b/thirdparty/dependencies.cmake
76index 43e0ed671a9..b39479fdd6b 100644
77--- a/thirdparty/dependencies.cmake
78+++ b/thirdparty/dependencies.cmake
79@@ -338,11 +338,11 @@ if(ENABLE_SAMPLES OR ENABLE_TESTS)
80 elseif(APPLE OR WIN32)
81 # on Windows and macOS we don't use gflags, because will be dynamically linked
82 elseif(CMAKE_HOST_LINUX AND LINUX)
50- if(OV_OS_RHEL) 83- if(OV_OS_RHEL)
51+ #if(OV_OS_RHEL) 84- set(gflag_component nothreads_shared)
52 set(gflag_component nothreads_shared)
53- elseif(OV_OS_DEBIAN) 85- elseif(OV_OS_DEBIAN)
54- set(gflag_component nothreads_static) 86- set(gflag_component nothreads_static)
55- endif() 87- endif()
56+ #elseif(OV_OS_DEBIAN) 88+ #if(OV_OS_RHEL)
57+ #set(gflag_component nothreads_static) 89+ set(gflag_component nothreads_shared)
58+ #endif() 90+ #elseif(OV_OS_DEBIAN)
91+ # set(gflag_component nothreads_static)
92+ #endif()
59 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 93 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
60 else() 94 endif()
61 # conan case 95
62-- 96--
632.34.1 972.37.3
64 98