summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2023-09-21 13:57:40 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2023-09-29 10:05:11 +0800
commitf9cb1d9aa9ded127236f7d072e0af2403e4ab4fc (patch)
tree361ec65fe471e3af9f87b7f2068efd9509186ab4 /dynamic-layers/openembedded-layer/recipes-support/opencv
parentcc04677a2717be485bf9cecf4a3d48f8a1e601cc (diff)
downloadmeta-intel-f9cb1d9aa9ded127236f7d072e0af2403e4ab4fc.tar.gz
openvino-inference-engine: upgrade 2023.0.2 -> 2023.1.0
* Release notes: https://github.com/openvinotoolkit/openvino/releases/tag/2023.1.0 * samples package includes scripts that need Python to be present. Specify that dependency explicitly. License-Update: Updated copyright information. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch84
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.2.bb)17
2 files changed, 69 insertions, 32 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 8481dadc..9e71e689 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -1,19 +1,40 @@
1Yocto specific tweaks to the build process: 1From 7deabff3d51df783c3e24bcc190c3ddebca7d9a8 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 21 Sep 2023 14:07:28 +0800
4Subject: [PATCH] cmake: yocto specific tweaks to the build process
2 5
3* Dont try to detect glibc version as that doesn't work when cross compiling. 6* Dont try to detect glibc version as that doesn't work when cross compiling.
4* Use shared protobuf and gflags libs. 7* Use shared gflags libs.
5* Install sample binaries as well. 8* Install sample binaries as well.
9* Dont strip binaries.
10* Dont try to write triggers for CPack. We package ourselves.
6 11
7Upstream-Status: Inappropriate 12Upstream-Status: Inappropriate
13
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9--- 15---
10 cmake/developer_package/target_flags.cmake | 2 +- 16 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +-
11 samples/cpp/CMakeLists.txt | 6 +++--- 17 cmake/developer_package/target_flags.cmake | 2 +-
12 thirdparty/CMakeLists.txt | 8 ++++---- 18 samples/cpp/CMakeLists.txt | 6 +++---
13 3 files changed, 8 insertions(+), 8 deletions(-) 19 src/bindings/python/wheel/setup.py | 1 -
20 thirdparty/dependencies.cmake | 10 +++++-----
21 5 files changed, 10 insertions(+), 11 deletions(-)
14 22
23diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake
24index 0609750054f..0f5c7765197 100644
25--- a/cmake/developer_package/packaging/rpm/rpm.cmake
26+++ b/cmake/developer_package/packaging/rpm/rpm.cmake
27@@ -161,7 +161,7 @@ ov_rpm_specific_settings()
28 # needed to add triggers for packages with libraries
29 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers")
30 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n")
31-file(WRITE "${def_triggers}" "${triggers_content}")
32+#file(WRITE "${def_triggers}" "${triggers_content}")
33
34 #
35 # Functions helpful for packaging your modules with RPM cpack
15diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 36diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
16index ced8d519da3..505c1fa5b14 100644 37index 29f23e713e1..942dd445b19 100644
17--- a/cmake/developer_package/target_flags.cmake 38--- a/cmake/developer_package/target_flags.cmake
18+++ b/cmake/developer_package/target_flags.cmake 39+++ b/cmake/developer_package/target_flags.cmake
19@@ -145,4 +145,4 @@ function(ov_glibc_version) 40@@ -145,4 +145,4 @@ function(ov_glibc_version)
@@ -23,10 +44,10 @@ index ced8d519da3..505c1fa5b14 100644
23-ov_glibc_version() 44-ov_glibc_version()
24+#ov_glibc_version() 45+#ov_glibc_version()
25diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 46diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
26index 37eb0250112..35ec6a3368a 100644 47index 8849aaf47d1..450b57c18d6 100644
27--- a/samples/cpp/CMakeLists.txt 48--- a/samples/cpp/CMakeLists.txt
28+++ b/samples/cpp/CMakeLists.txt 49+++ b/samples/cpp/CMakeLists.txt
29@@ -219,9 +219,9 @@ macro(ie_add_sample) 50@@ -223,9 +223,9 @@ macro(ie_add_sample)
30 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 51 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
31 52
32 install(TARGETS ${IE_SAMPLE_NAME} 53 install(TARGETS ${IE_SAMPLE_NAME}
@@ -39,26 +60,39 @@ index 37eb0250112..35ec6a3368a 100644
39 60
40 # create global target with all samples / demo apps 61 # create global target with all samples / demo apps
41 if(NOT TARGET ie_samples) 62 if(NOT TARGET ie_samples)
42diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 63diff --git a/src/bindings/python/wheel/setup.py b/src/bindings/python/wheel/setup.py
43index 95d80a6fbd4..963c9a5d60a 100644 64index 04323a8ba49..0498dcdc126 100644
44--- a/thirdparty/CMakeLists.txt 65--- a/src/bindings/python/wheel/setup.py
45+++ b/thirdparty/CMakeLists.txt 66+++ b/src/bindings/python/wheel/setup.py
46@@ -353,11 +353,11 @@ endif() 67@@ -270,7 +270,6 @@ class CustomBuild(build):
47 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 68 self.spawn(["cmake", "--install", binary_dir,
48 # on Windows and macOS we don't use gflags, because will be dynamically linked 69 "--prefix", prefix,
49 if(CMAKE_HOST_LINUX AND LINUX) 70 "--config", "Release",
71- "--strip",
72 "--component", cpack_comp_name])
73
74 def run(self):
75diff --git a/thirdparty/dependencies.cmake b/thirdparty/dependencies.cmake
76index 43e0ed671a9..b39479fdd6b 100644
77--- a/thirdparty/dependencies.cmake
78+++ b/thirdparty/dependencies.cmake
79@@ -338,11 +338,11 @@ if(ENABLE_SAMPLES OR ENABLE_TESTS)
80 elseif(APPLE OR WIN32)
81 # on Windows and macOS we don't use gflags, because will be dynamically linked
82 elseif(CMAKE_HOST_LINUX AND LINUX)
50- if(OV_OS_RHEL) 83- if(OV_OS_RHEL)
51+ #if(OV_OS_RHEL) 84- set(gflag_component nothreads_shared)
52 set(gflag_component nothreads_shared)
53- elseif(OV_OS_DEBIAN) 85- elseif(OV_OS_DEBIAN)
54- set(gflag_component nothreads_static) 86- set(gflag_component nothreads_static)
55- endif() 87- endif()
56+ #elseif(OV_OS_DEBIAN) 88+ #if(OV_OS_RHEL)
57+ #set(gflag_component nothreads_static) 89+ set(gflag_component nothreads_shared)
58+ #endif() 90+ #elseif(OV_OS_DEBIAN)
91+ # set(gflag_component nothreads_static)
92+ #endif()
59 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 93 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
60 else() 94 endif()
61 # conan case 95
62-- 96--
632.34.1 972.37.3
64 98
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb
index e2119131..1b93b0ce 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.1.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \ 4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2023/0;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2023/1;lfs=0 \
8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ 8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ 9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ 10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
@@ -19,9 +19,9 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=ope
19 file://0001-protobuf-allow-target-protoc-to-be-built.patch \ 19 file://0001-protobuf-allow-target-protoc-to-be-built.patch \
20 " 20 "
21 21
22SRCREV_openvino = "e662b1a330126daed2d8de724b9e14690bec8bfd" 22SRCREV_openvino = "47b736f63edda256d66e2bbb572f42a9d6549f6e"
23SRCREV_mkl = "1c7bfabf1b26e6fb95fea1613e1d3d2bef1f6b54" 23SRCREV_mkl = "ae825539bd850d1ad5c83d4bb0d56c65d46d5842"
24SRCREV_onednn = "f27dedbfc093f51032a4580198bb80579440dc15" 24SRCREV_onednn = "4b82a66ed38ecaa993352e5cc6ed7753656b8a26"
25SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2" 25SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2"
26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d" 26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
27SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9" 27SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"
@@ -34,8 +34,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
34 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \ 34 file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \
35 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \ 35 file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \
36 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 36 file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
37 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \ 37 file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
38 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=b48e3de3bfd47c27882a0d85b20823f5 \ 38 file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \
39" 39"
40 40
41inherit cmake python3native pkgconfig qemu 41inherit cmake python3native pkgconfig qemu
@@ -59,6 +59,7 @@ EXTRA_OECMAKE += " \
59 -DCPACK_GENERATOR=RPM \ 59 -DCPACK_GENERATOR=RPM \
60 -DENABLE_SYSTEM_FLATBUFFERS=ON \ 60 -DENABLE_SYSTEM_FLATBUFFERS=ON \
61 -DENABLE_SYSTEM_SNAPPY=ON \ 61 -DENABLE_SYSTEM_SNAPPY=ON \
62 -DENABLE_MLAS_FOR_CPU=OFF \
62 " 63 "
63 64
64DEPENDS += "\ 65DEPENDS += "\
@@ -66,6 +67,7 @@ DEPENDS += "\
66 gflags \ 67 gflags \
67 pugixml \ 68 pugixml \
68 python3-pybind11 \ 69 python3-pybind11 \
70 python3-pybind11-native \
69 qemu-native \ 71 qemu-native \
70 snappy \ 72 snappy \
71 tbb \ 73 tbb \
@@ -77,7 +79,7 @@ COMPATIBLE_HOST:libc-musl = "null"
77 79
78PACKAGECONFIG ?= "opencl samples" 80PACKAGECONFIG ?= "opencl samples"
79PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp," 81PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp,"
80PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython" 82PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR} -DENABLE_PYTHON_PACKAGING=ON, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython"
81PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv" 83PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv"
82PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" 84PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
83 85
@@ -119,6 +121,7 @@ FILES:${PN}-samples = "${datadir}/openvino \
119 ${libdir}/libformat_reader.a \ 121 ${libdir}/libformat_reader.a \
120 ${libdir}/libopencv_c_wrapper.a \ 122 ${libdir}/libopencv_c_wrapper.a \
121 " 123 "
124RDEPENDS:${PN}-samples += "python3-core"
122 125
123# Package for inference engine python API 126# Package for inference engine python API
124PACKAGES =+ "${PN}-${PYTHON_PN}" 127PACKAGES =+ "${PN}-${PYTHON_PN}"