summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2022-10-21 17:03:54 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-10-25 14:35:32 +0800
commit023266fcbf67e4c8fc7c4f6b951948384ba8282b (patch)
treef80881999d03fa3376dd03a25ef084e6ed287f23 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parent5963592b7370ee63d621ab9653c838168a6e2fc5 (diff)
downloadmeta-intel-023266fcbf67e4c8fc7c4f6b951948384ba8282b.tar.gz
openvino-inference-engine : upgrade 2022.1.1 -> 2022.2.0
- Change gflag to shared as we are not building with static library. - We are using zlib from yocto recipe, so don't add zlib as third party package - Third party package mkl-dnn name changed to onednn upstream in openvino repo so changed the name accordingly in openvino-inference-engine recipe - Refresh patches Release Notes: https://github.com/openvinotoolkit/openvino/releases/tag/2022.2.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch)52
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch)80
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch40
3 files changed, 105 insertions, 67 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch
index 60285eec..2dde9880 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Use-system-installed-dependencies.patch
@@ -1,7 +1,7 @@
1From d997ee70a49cee8a577a81968c1d603a97bc614f Mon Sep 17 00:00:00 2001 1From 86fc5a725883cf59086c319fca29ddb3e47fa7de Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 7 Apr 2022 21:39:26 +0800 3Date: Thu, 7 Apr 2022 21:39:26 +0800
4Subject: [PATCH] Use system installed dependencies 4Subject: [PATCH 1/2] Use system installed dependencies
5 5
6Use the system versions of libva, ade and zlib. 6Use the system versions of libva, ade and zlib.
7 7
@@ -12,13 +12,13 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12 cmake/extra_modules.cmake | 4 ++-- 12 cmake/extra_modules.cmake | 4 ++--
13 src/plugins/intel_gpu/include/va/va.h | 6 ------ 13 src/plugins/intel_gpu/include/va/va.h | 6 ------
14 tests/fuzz/src/CMakeLists.txt | 3 +-- 14 tests/fuzz/src/CMakeLists.txt | 3 +--
15 thirdparty/CMakeLists.txt | 26 ++++++++++---------------- 15 thirdparty/CMakeLists.txt | 25 +++++++++++--------------
16 thirdparty/cnpy/CMakeLists.txt | 2 +- 16 thirdparty/cnpy/CMakeLists.txt | 2 +-
17 6 files changed, 14 insertions(+), 47 deletions(-) 17 6 files changed, 15 insertions(+), 45 deletions(-)
18 delete mode 100644 src/plugins/intel_gpu/include/va/va.h 18 delete mode 100644 src/plugins/intel_gpu/include/va/va.h
19 19
20diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake 20diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
21index 106af36c7d..45a3214100 100644 21index 8d66a012b8..75db89b915 100644
22--- a/cmake/dependencies.cmake 22--- a/cmake/dependencies.cmake
23+++ b/cmake/dependencies.cmake 23+++ b/cmake/dependencies.cmake
24@@ -27,26 +27,6 @@ get_linux_name(LINUX_OS_NAME) 24@@ -27,26 +27,6 @@ get_linux_name(LINUX_OS_NAME)
@@ -49,10 +49,10 @@ index 106af36c7d..45a3214100 100644
49 49
50 if(ENABLE_INTEL_MYRIAD) 50 if(ENABLE_INTEL_MYRIAD)
51diff --git a/cmake/extra_modules.cmake b/cmake/extra_modules.cmake 51diff --git a/cmake/extra_modules.cmake b/cmake/extra_modules.cmake
52index e33e4378f1..f0cacdf6ff 100644 52index 72eed6ad3a..39e9674a11 100644
53--- a/cmake/extra_modules.cmake 53--- a/cmake/extra_modules.cmake
54+++ b/cmake/extra_modules.cmake 54+++ b/cmake/extra_modules.cmake
55@@ -18,7 +18,7 @@ function(ie_generate_dev_package_config) 55@@ -22,7 +22,7 @@ function(ie_generate_dev_package_config)
56 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineDeveloperPackageConfig.cmake.in" 56 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineDeveloperPackageConfig.cmake.in"
57 "${CMAKE_BINARY_DIR}/InferenceEngineDeveloperPackageConfig.cmake" 57 "${CMAKE_BINARY_DIR}/InferenceEngineDeveloperPackageConfig.cmake"
58 INSTALL_DESTINATION share # not used 58 INSTALL_DESTINATION share # not used
@@ -61,7 +61,7 @@ index e33e4378f1..f0cacdf6ff 100644
61 NO_CHECK_REQUIRED_COMPONENTS_MACRO) 61 NO_CHECK_REQUIRED_COMPONENTS_MACRO)
62 62
63 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineConfig-version.cmake.in" 63 configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/InferenceEngineConfig-version.cmake.in"
64@@ -45,7 +45,7 @@ function(ov_generate_dev_package_config) 64@@ -53,7 +53,7 @@ function(ov_generate_dev_package_config)
65 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINODeveloperPackageConfig.cmake.in" 65 configure_package_config_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINODeveloperPackageConfig.cmake.in"
66 "${CMAKE_BINARY_DIR}/OpenVINODeveloperPackageConfig.cmake" 66 "${CMAKE_BINARY_DIR}/OpenVINODeveloperPackageConfig.cmake"
67 INSTALL_DESTINATION share # not used 67 INSTALL_DESTINATION share # not used
@@ -103,14 +103,11 @@ index 5e6b7b168e..a81c51bb77 100644
103 add_dependencies(fuzz ${test_name}) 103 add_dependencies(fuzz ${test_name})
104 104
105diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 105diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
106index 2d61c5fd7a..97b372998a 100644 106index 38b0a5439d..4cba1588fe 100644
107--- a/thirdparty/CMakeLists.txt 107--- a/thirdparty/CMakeLists.txt
108+++ b/thirdparty/CMakeLists.txt 108+++ b/thirdparty/CMakeLists.txt
109@@ -12,10 +12,9 @@ endif() 109@@ -14,7 +14,7 @@ add_subdirectory(ittapi)
110
111 add_subdirectory(ittapi)
112 add_subdirectory(itt_collector EXCLUDE_FROM_ALL) 110 add_subdirectory(itt_collector EXCLUDE_FROM_ALL)
113-add_subdirectory(zlib EXCLUDE_FROM_ALL)
114 add_subdirectory(cnpy EXCLUDE_FROM_ALL) 111 add_subdirectory(cnpy EXCLUDE_FROM_ALL)
115 if(ENABLE_INTEL_GPU) 112 if(ENABLE_INTEL_GPU)
116- add_subdirectory(ocl) 113- add_subdirectory(ocl)
@@ -118,7 +115,7 @@ index 2d61c5fd7a..97b372998a 100644
118 endif() 115 endif()
119 116
120 add_subdirectory(xbyak EXCLUDE_FROM_ALL) 117 add_subdirectory(xbyak EXCLUDE_FROM_ALL)
121@@ -52,21 +51,16 @@ endif() 118@@ -72,12 +72,11 @@ endif()
122 add_library(ocv_hal INTERFACE) 119 add_library(ocv_hal INTERFACE)
123 target_include_directories(ocv_hal INTERFACE "${CMAKE_CURRENT_SOURCE_DIR}/ocv") 120 target_include_directories(ocv_hal INTERFACE "${CMAKE_CURRENT_SOURCE_DIR}/ocv")
124 121
@@ -128,21 +125,22 @@ index 2d61c5fd7a..97b372998a 100644
128-openvino_developer_export_targets(COMPONENT openvino_common TARGETS ade fluid) 125-openvino_developer_export_targets(COMPONENT openvino_common TARGETS ade fluid)
129+set_target_properties(fluid PROPERTIES FOLDER thirdparty) 126+set_target_properties(fluid PROPERTIES FOLDER thirdparty)
130+openvino_developer_export_targets(COMPONENT openvino_common TARGETS fluid) 127+openvino_developer_export_targets(COMPONENT openvino_common TARGETS fluid)
128+
131 129
132-ov_install_static_lib(ade openvino_common) 130-ov_install_static_lib(ade openvino_common)
133 ov_install_static_lib(fluid openvino_common) 131 ov_install_static_lib(fluid openvino_common)
134 132
135 # 133 #
136 # Gflags 134@@ -93,8 +92,6 @@ if(gflags_FOUND)
137 # 135 set_target_properties(gflags PROPERTIES IMPORTED_GLOBAL ON)
136 message(STATUS "gflags (${gflags_VERSION}) is found at ${gflags_DIR}")
137 else()
138- add_subdirectory(gflags EXCLUDE_FROM_ALL)
139- openvino_developer_export_targets(COMPONENT openvino_common TARGETS gflags)
140 endif()
138 141
139-add_subdirectory(gflags EXCLUDE_FROM_ALL)
140-openvino_developer_export_targets(COMPONENT openvino_common TARGETS gflags)
141-
142 #
143 # Google Tests framework
144 # 142 #
145@@ -89,13 +83,13 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND 143@@ -119,13 +116,13 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
146 set(Protobuf_DEBUG ON) 144 set(Protobuf_DEBUG ON)
147 endif() 145 endif()
148 find_package(Protobuf 3.18.2 REQUIRED) 146 find_package(Protobuf 3.18.2 REQUIRED)
@@ -160,7 +158,7 @@ index 2d61c5fd7a..97b372998a 100644
160 endforeach() 158 endforeach()
161 else() 159 else()
162 add_subdirectory(protobuf EXCLUDE_FROM_ALL) 160 add_subdirectory(protobuf EXCLUDE_FROM_ALL)
163@@ -104,8 +98,8 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND 161@@ -134,8 +131,8 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
164 # forward variables used in the other places 162 # forward variables used in the other places
165 set(SYSTEM_PROTOC ${SYSTEM_PROTOC} PARENT_SCOPE) 163 set(SYSTEM_PROTOC ${SYSTEM_PROTOC} PARENT_SCOPE)
166 set(PROTOC_EXECUTABLE ${PROTOC_EXECUTABLE} PARENT_SCOPE) 164 set(PROTOC_EXECUTABLE ${PROTOC_EXECUTABLE} PARENT_SCOPE)
@@ -171,7 +169,7 @@ index 2d61c5fd7a..97b372998a 100644
171 set(Protobuf_INCLUDE_DIRS ${Protobuf_INCLUDE_DIRS} PARENT_SCOPE) 169 set(Protobuf_INCLUDE_DIRS ${Protobuf_INCLUDE_DIRS} PARENT_SCOPE)
172 set(Protobuf_IN_FRONTEND ON PARENT_SCOPE) 170 set(Protobuf_IN_FRONTEND ON PARENT_SCOPE)
173 171
174@@ -116,7 +110,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND 172@@ -146,7 +143,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
175 set(link_type INTERFACE) 173 set(link_type INTERFACE)
176 endif() 174 endif()
177 if(CMAKE_COMPILER_IS_GNUCXX OR OV_COMPILER_IS_CLANG) 175 if(CMAKE_COMPILER_IS_GNUCXX OR OV_COMPILER_IS_CLANG)
@@ -181,18 +179,18 @@ index 2d61c5fd7a..97b372998a 100644
181 endforeach() 179 endforeach()
182 endif() 180 endif()
183diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt 181diff --git a/thirdparty/cnpy/CMakeLists.txt b/thirdparty/cnpy/CMakeLists.txt
184index 041031e923..793de9845c 100644 182index 556adb03c4..793de9845c 100644
185--- a/thirdparty/cnpy/CMakeLists.txt 183--- a/thirdparty/cnpy/CMakeLists.txt
186+++ b/thirdparty/cnpy/CMakeLists.txt 184+++ b/thirdparty/cnpy/CMakeLists.txt
187@@ -13,7 +13,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$") 185@@ -13,7 +13,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$")
188 PRIVATE -Wno-all) 186 PRIVATE -Wno-all)
189 endif() 187 endif()
190 188
191-target_link_libraries(${TARGET_NAME} PUBLIC zlib) 189-target_link_libraries(${TARGET_NAME} PUBLIC zlib::zlib)
192+target_link_libraries(${TARGET_NAME} PUBLIC z) 190+target_link_libraries(${TARGET_NAME} PUBLIC z)
193 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}") 191 target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
194 192
195 set_target_properties(${TARGET_NAME} PROPERTIES FOLDER thirdparty) 193 set_target_properties(${TARGET_NAME} PROPERTIES FOLDER thirdparty)
196-- 194--
1972.36.1 1952.37.3
198 196
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
index f80e45f8..12c8054e 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-inference-engine-installation-fixes.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
@@ -1,7 +1,7 @@
1From 5b6c285b5398fd29cc541ccf92e13440537bb5e8 Mon Sep 17 00:00:00 2001 1From 3d55027cd86db299faeed0a4a97ddcec1baedd61 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 11 Apr 2022 11:11:23 +0800 3Date: Mon, 11 Apr 2022 11:11:23 +0800
4Subject: [PATCH] Fix installation of binaries and libraries 4Subject: [PATCH 2/2] Fix installation of binaries and libraries
5 5
6Make sure binaries are installed correctly. 6Make sure binaries are installed correctly.
7 7
@@ -31,10 +31,10 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31 19 files changed, 37 insertions(+), 32 deletions(-) 31 19 files changed, 37 insertions(+), 32 deletions(-)
32 32
33diff --git a/CMakeLists.txt b/CMakeLists.txt 33diff --git a/CMakeLists.txt b/CMakeLists.txt
34index beb0214284..c9ffa7fcae 100644 34index f570d4246c..d20ac60749 100644
35--- a/CMakeLists.txt 35--- a/CMakeLists.txt
36+++ b/CMakeLists.txt 36+++ b/CMakeLists.txt
37@@ -106,7 +106,7 @@ include(cmake/extra_modules.cmake) 37@@ -111,7 +111,7 @@ include(cmake/extra_modules.cmake)
38 add_subdirectory(docs) 38 add_subdirectory(docs)
39 add_subdirectory(tools) 39 add_subdirectory(tools)
40 add_subdirectory(scripts) 40 add_subdirectory(scripts)
@@ -44,7 +44,7 @@ index beb0214284..c9ffa7fcae 100644
44 # 44 #
45 # CPack 45 # CPack
46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake 46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
47index 39b23fe655..aa638c0778 100644 47index 0779ed286d..f80cb9bb79 100644
48--- a/cmake/developer_package/frontends/frontends.cmake 48--- a/cmake/developer_package/frontends/frontends.cmake
49+++ b/cmake/developer_package/frontends/frontends.cmake 49+++ b/cmake/developer_package/frontends/frontends.cmake
50@@ -2,7 +2,7 @@ 50@@ -2,7 +2,7 @@
@@ -57,7 +57,7 @@ index 39b23fe655..aa638c0778 100644
57 set(FRONTEND_NAME_SUFFIX "_frontend") 57 set(FRONTEND_NAME_SUFFIX "_frontend")
58 58
59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake 59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake
60index cc287ff1f3..2daee6611e 100644 60index 458ddade93..626eb6548a 100644
61--- a/cmake/developer_package/packaging.cmake 61--- a/cmake/developer_package/packaging.cmake
62+++ b/cmake/developer_package/packaging.cmake 62+++ b/cmake/developer_package/packaging.cmake
63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir) 63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir)
@@ -72,10 +72,10 @@ index cc287ff1f3..2daee6611e 100644
72 endif() 72 endif()
73 endfunction() 73 endfunction()
74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake 74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake
75index a630d6c354..779c43631a 100644 75index b748ebddef..fe670e88bc 100644
76--- a/cmake/developer_package/plugins/plugins.cmake 76--- a/cmake/developer_package/plugins/plugins.cmake
77+++ b/cmake/developer_package/plugins/plugins.cmake 77+++ b/cmake/developer_package/plugins/plugins.cmake
78@@ -138,7 +138,7 @@ function(ie_add_plugin) 78@@ -139,7 +139,7 @@ function(ie_add_plugin)
79 79
80 if(BUILD_SHARED_LIBS) 80 if(BUILD_SHARED_LIBS)
81 install(TARGETS ${IE_PLUGIN_NAME} 81 install(TARGETS ${IE_PLUGIN_NAME}
@@ -124,12 +124,12 @@ index 2755579a0f..4a5f5b424f 100644
124+ 124+
125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR}) 125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
127index 9a73582a73..70c4147f3f 100644 127index 3628c8283a..186540940f 100644
128--- a/samples/cpp/CMakeLists.txt 128--- a/samples/cpp/CMakeLists.txt
129+++ b/samples/cpp/CMakeLists.txt 129+++ b/samples/cpp/CMakeLists.txt
130@@ -222,6 +222,8 @@ macro(ie_add_sample) 130@@ -258,6 +258,8 @@ macro(ie_add_sample)
131 EXCLUDE_FROM_ALL 131 COMPONENT samples_bin
132 ) 132 EXCLUDE_FROM_ALL)
133 133
134+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin) 134+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
135+ 135+
@@ -137,10 +137,10 @@ index 9a73582a73..70c4147f3f 100644
137 if(NOT TARGET ie_samples) 137 if(NOT TARGET ie_samples)
138 add_custom_target(ie_samples ALL) 138 add_custom_target(ie_samples ALL)
139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt 139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
140index 9ad26ba952..0853e23706 100644 140index 4e9f76638f..6d8df5f0a1 100644
141--- a/scripts/CMakeLists.txt 141--- a/scripts/CMakeLists.txt
142+++ b/scripts/CMakeLists.txt 142+++ b/scripts/CMakeLists.txt
143@@ -28,7 +28,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}" 143@@ -37,7 +37,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}"
144 144
145 # install setupvars 145 # install setupvars
146 146
@@ -149,7 +149,7 @@ index 9ad26ba952..0853e23706 100644
149 149
150 if(UNIX) 150 if(UNIX)
151 set(_setupvars_file setupvars/setupvars.sh) 151 set(_setupvars_file setupvars/setupvars.sh)
152@@ -43,13 +43,13 @@ elseif(WIN32) 152@@ -54,13 +54,13 @@ elseif(WIN32)
153 file(WRITE "${_setupvars_file}" "${_setupvars_content}") 153 file(WRITE "${_setupvars_file}" "${_setupvars_content}")
154 endif() 154 endif()
155 endif() 155 endif()
@@ -183,10 +183,10 @@ index 9200d0bda1..b3636e0716 100644
183+ DESTINATION include/ie 183+ DESTINATION include/ie
184 COMPONENT core_c_dev) 184 COMPONENT core_c_dev)
185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake 185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake
186index ddd016d14e..76db0f9927 100644 186index 340896e3a8..9bda84fe51 100644
187--- a/src/cmake/openvino.cmake 187--- a/src/cmake/openvino.cmake
188+++ b/src/cmake/openvino.cmake 188+++ b/src/cmake/openvino.cmake
189@@ -59,8 +59,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets 189@@ -62,8 +62,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
190 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core 190 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core
191 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core 191 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core
192 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core 192 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core
@@ -195,9 +195,9 @@ index ddd016d14e..76db0f9927 100644
195+ INCLUDES DESTINATION include 195+ INCLUDES DESTINATION include
196+ include/ie) 196+ include/ie)
197 197
198 # --------------- OpenVINO runtime library dev ------------------------------ 198 #
199 add_library(${TARGET_NAME}_dev INTERFACE) 199 # Add openvin::dev target
200@@ -95,7 +95,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components}) 200@@ -107,7 +107,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components})
201 201
202 if(BUILD_SHARED_LIBS) 202 if(BUILD_SHARED_LIBS)
203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml 203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
@@ -206,7 +206,7 @@ index ddd016d14e..76db0f9927 100644
206 COMPONENT core) 206 COMPONENT core)
207 207
208 # for InferenceEngineUnitTest 208 # for InferenceEngineUnitTest
209@@ -114,7 +114,7 @@ endif() 209@@ -126,7 +126,7 @@ endif()
210 install(EXPORT OpenVINOTargets 210 install(EXPORT OpenVINOTargets
211 FILE OpenVINOTargets.cmake 211 FILE OpenVINOTargets.cmake
212 NAMESPACE openvino:: 212 NAMESPACE openvino::
@@ -214,19 +214,19 @@ index ddd016d14e..76db0f9927 100644
214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
215 COMPONENT core_dev) 215 COMPONENT core_dev)
216 216
217 # Build tree 217 set(PUBLIC_HEADERS_DIR "${OpenVINO_SOURCE_DIR}/src/inference/include")
218@@ -160,10 +160,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm 218@@ -167,10 +167,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm
219
219 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake" 220 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake"
220 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake" 221 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake"
221 "${OpenVINO_SOURCE_DIR}/src/cmake/ie_parallel.cmake"
222- DESTINATION runtime/cmake 222- DESTINATION runtime/cmake
223+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine 223+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
224 COMPONENT core_dev) 224 COMPONENT core_dev)
225 225
226 install(FILES "${CMAKE_BINARY_DIR}/share/OpenVINOConfig.cmake" 226 install(FILES "${CMAKE_BINARY_DIR}/share/OpenVINOConfig.cmake"
227 "${CMAKE_BINARY_DIR}/OpenVINOConfig-version.cmake" 227 "${CMAKE_BINARY_DIR}/OpenVINOConfig-version.cmake"
228- DESTINATION runtime/cmake 228- DESTINATION runtime/cmake
229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO 229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
230 COMPONENT core_dev) 230 COMPONENT core_dev)
231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt 231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt
232index e41e286c95..11aaffca6a 100644 232index e41e286c95..11aaffca6a 100644
@@ -242,10 +242,10 @@ index e41e286c95..11aaffca6a 100644
242 ov_install_static_lib(${TARGET_NAME} core) 242 ov_install_static_lib(${TARGET_NAME} core)
243 endif() 243 endif()
244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt 244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
245index cc64b94ca3..5f0dcf20cf 100644 245index 86b195ee1c..867121ee50 100644
246--- a/src/core/CMakeLists.txt 246--- a/src/core/CMakeLists.txt
247+++ b/src/core/CMakeLists.txt 247+++ b/src/core/CMakeLists.txt
248@@ -114,7 +114,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_ 248@@ -127,7 +127,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_
249 #----------------------------------------------------------------------------------------------- 249 #-----------------------------------------------------------------------------------------------
250 250
251 install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include/ 251 install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include/
@@ -254,7 +254,7 @@ index cc64b94ca3..5f0dcf20cf 100644
254 COMPONENT core_dev 254 COMPONENT core_dev
255 FILES_MATCHING 255 FILES_MATCHING
256 PATTERN "*.hpp" 256 PATTERN "*.hpp"
257@@ -130,5 +130,5 @@ write_basic_package_version_file(${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake 257@@ -143,5 +143,5 @@ write_basic_package_version_file(${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
258 258
259 install(FILES ${CMAKE_BINARY_DIR}/ngraphConfig.cmake 259 install(FILES ${CMAKE_BINARY_DIR}/ngraphConfig.cmake
260 ${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake 260 ${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
@@ -262,7 +262,7 @@ index cc64b94ca3..5f0dcf20cf 100644
262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph 262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
263 COMPONENT core_dev) 263 COMPONENT core_dev)
264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt 264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt
265index 767fbc1b81..f279a2ef7d 100644 265index 737e7e0027..259d5e141d 100644
266--- a/src/inference/CMakeLists.txt 266--- a/src/inference/CMakeLists.txt
267+++ b/src/inference/CMakeLists.txt 267+++ b/src/inference/CMakeLists.txt
268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj 268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj
@@ -288,7 +288,7 @@ index 3993bd9731..99287bad51 100644
288 288
289 ov_install_static_lib(${TARGET_NAME} gpu) 289 ov_install_static_lib(${TARGET_NAME} gpu)
290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake 290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake
291index 5bba4235ff..69c1470a71 100644 291index 480acc05d1..5849f55878 100644
292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake 292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake
293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake 293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake
294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES) 294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES)
@@ -301,19 +301,19 @@ index 5bba4235ff..69c1470a71 100644
301 301
302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS) 302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS)
303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
304index 12a2f15e4a..893146294c 100644 304index d8ebea0bfc..66b5a3d462 100644
305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt 306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL 307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
308 # install 308
309 if (LINUX) 309 if(LINUX)
310 install(FILES ${OpenVINO_SOURCE_DIR}/src/plugins/intel_myriad/third_party/mvnc/src/97-myriad-usbboot.rules 310 install(FILES ${mvnc_SOURCE_DIR}/src/97-myriad-usbboot.rules
311- DESTINATION runtime/3rdparty 311- DESTINATION install_dependencies
312+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d 312+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
313 COMPONENT myriad) 313 COMPONENT myriad)
314 endif() 314 endif()
315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt 315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
316index c8638f7fd3..ba30641c5a 100644 316index 2fe0fd9742..234110b7d4 100644
317--- a/tools/CMakeLists.txt 317--- a/tools/CMakeLists.txt
318+++ b/tools/CMakeLists.txt 318+++ b/tools/CMakeLists.txt
319@@ -20,7 +20,7 @@ endif() 319@@ -20,7 +20,7 @@ endif()
@@ -344,5 +344,5 @@ index d19eb5cc14..9fc929cbb0 100644
344+# DESTINATION tools/compile_tool 344+# DESTINATION tools/compile_tool
345+# COMPONENT core_tools) 345+# COMPONENT core_tools)
346-- 346--
3472.36.1 3472.37.3
348 348
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
new file mode 100644
index 00000000..ffb0f95d
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
@@ -0,0 +1,40 @@
1From a817386f1d0539a040fbdc02853a73bbcdddf1f1 Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Fri, 30 Sep 2022 20:26:04 +0800
4Subject: [PATCH] Fix build issues due to gflag and zlib
5
6Change gflag to shared as we are not building with static library.
7We are using zlib from host, so don't add zlib as third party package
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
12---
13 thirdparty/CMakeLists.txt | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
17index 4cba1588fe..f82bf3148b 100644
18--- a/thirdparty/CMakeLists.txt
19+++ b/thirdparty/CMakeLists.txt
20@@ -39,7 +39,7 @@ if(NOT CMAKE_CROSSCOMPILING)
21 endif()
22
23 if(NOT zlib_FOUND)
24- add_subdirectory(zlib EXCLUDE_FROM_ALL)
25+ #add_subdirectory(zlib EXCLUDE_FROM_ALL)
26 endif()
27
28 #
29@@ -85,7 +85,7 @@ ov_install_static_lib(fluid openvino_common)
30
31 if(NOT APPLE)
32 # on Apple only dynamic libraries are available
33- find_package(gflags QUIET COMPONENTS nothreads_static)
34+ find_package(gflags QUIET COMPONENTS nothreads_shared)
35 endif()
36
37 if(gflags_FOUND)
38--
392.37.3
40