summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch348
1 files changed, 348 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
new file mode 100644
index 00000000..12c8054e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-Fix-installation-of-binaries-and-libraries.patch
@@ -0,0 +1,348 @@
1From 3d55027cd86db299faeed0a4a97ddcec1baedd61 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 11 Apr 2022 11:11:23 +0800
4Subject: [PATCH 2/2] Fix installation of binaries and libraries
5
6Make sure binaries are installed correctly.
7
8Upstream-Status: Inappropriate
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 CMakeLists.txt | 2 +-
13 cmake/developer_package/frontends/frontends.cmake | 2 +-
14 cmake/developer_package/packaging.cmake | 4 ++--
15 cmake/developer_package/plugins/plugins.cmake | 2 +-
16 docs/CMakeLists.txt | 3 ++-
17 samples/CMakeLists.txt | 2 +-
18 samples/c/common/opencv_c_wrapper/CMakeLists.txt | 2 ++
19 samples/cpp/CMakeLists.txt | 2 ++
20 scripts/CMakeLists.txt | 10 +++++-----
21 src/bindings/c/src/CMakeLists.txt | 4 ++--
22 src/cmake/openvino.cmake | 12 ++++++------
23 src/common/preprocessing/CMakeLists.txt | 2 +-
24 src/core/CMakeLists.txt | 4 ++--
25 src/inference/CMakeLists.txt | 2 +-
26 .../intel_gpu/src/kernel_selector/CMakeLists.txt | 2 +-
27 src/plugins/intel_myriad/myriad_dependencies.cmake | 2 +-
28 .../intel_myriad/myriad_plugin/CMakeLists.txt | 2 +-
29 tools/CMakeLists.txt | 2 +-
30 tools/compile_tool/CMakeLists.txt | 8 ++++----
31 19 files changed, 37 insertions(+), 32 deletions(-)
32
33diff --git a/CMakeLists.txt b/CMakeLists.txt
34index f570d4246c..d20ac60749 100644
35--- a/CMakeLists.txt
36+++ b/CMakeLists.txt
37@@ -111,7 +111,7 @@ include(cmake/extra_modules.cmake)
38 add_subdirectory(docs)
39 add_subdirectory(tools)
40 add_subdirectory(scripts)
41-add_subdirectory(licensing)
42+#add_subdirectory(licensing)
43
44 #
45 # CPack
46diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
47index 0779ed286d..f80cb9bb79 100644
48--- a/cmake/developer_package/frontends/frontends.cmake
49+++ b/cmake/developer_package/frontends/frontends.cmake
50@@ -2,7 +2,7 @@
51 # SPDX-License-Identifier: Apache-2.0
52 #
53
54-set(FRONTEND_INSTALL_INCLUDE "runtime/include/")
55+set(FRONTEND_INSTALL_INCLUDE "include/")
56 set(FRONTEND_NAME_PREFIX "openvino_")
57 set(FRONTEND_NAME_SUFFIX "_frontend")
58
59diff --git a/cmake/developer_package/packaging.cmake b/cmake/developer_package/packaging.cmake
60index 458ddade93..626eb6548a 100644
61--- a/cmake/developer_package/packaging.cmake
62+++ b/cmake/developer_package/packaging.cmake
63@@ -20,8 +20,8 @@ function(ie_cpack_set_library_dir)
64 set(IE_CPACK_RUNTIME_PATH runtime/lib/${ARCH_FOLDER}/$<CONFIG> PARENT_SCOPE)
65 set(IE_CPACK_ARCHIVE_PATH runtime/lib/${ARCH_FOLDER}/$<CONFIG> PARENT_SCOPE)
66 else()
67- set(IE_CPACK_LIBRARY_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
68- set(IE_CPACK_RUNTIME_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
69+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
70+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
71 set(IE_CPACK_ARCHIVE_PATH runtime/lib/${ARCH_FOLDER} PARENT_SCOPE)
72 endif()
73 endfunction()
74diff --git a/cmake/developer_package/plugins/plugins.cmake b/cmake/developer_package/plugins/plugins.cmake
75index b748ebddef..fe670e88bc 100644
76--- a/cmake/developer_package/plugins/plugins.cmake
77+++ b/cmake/developer_package/plugins/plugins.cmake
78@@ -139,7 +139,7 @@ function(ie_add_plugin)
79
80 if(BUILD_SHARED_LIBS)
81 install(TARGETS ${IE_PLUGIN_NAME}
82- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
83+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH}
84 COMPONENT ${install_component})
85 else()
86 ov_install_static_lib(${IE_PLUGIN_NAME} ${install_component})
87diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
88index 86b0e8652b..4f31d3cc4b 100644
89--- a/docs/CMakeLists.txt
90+++ b/docs/CMakeLists.txt
91@@ -36,9 +36,10 @@ if(NOT ENABLE_DOCKER)
92 foreach(target openvino_template_plugin template_extension openvino_template_extension)
93 if(TARGET ${target})
94 install(TARGETS ${target}
95- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
96+ LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH}
97 COMPONENT tests
98 EXCLUDE_FROM_ALL)
99+ install(TARGETS ${target} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
100 endif()
101 endforeach()
102 endif()
103diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
104index 8101b5e328..6abe8c20ce 100644
105--- a/samples/CMakeLists.txt
106+++ b/samples/CMakeLists.txt
107@@ -9,7 +9,7 @@ add_subdirectory(c)
108 if(TARGET format_reader)
109 install(TARGETS format_reader
110 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT tests EXCLUDE_FROM_ALL
111- LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT tests EXCLUDE_FROM_ALL)
112+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT tests)
113 endif()
114
115 openvino_developer_export_targets(COMPONENT openvino_common TARGETS format_reader ie_samples_utils)
116diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
117index 2755579a0f..4a5f5b424f 100644
118--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
119+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
120@@ -34,3 +34,5 @@ install(
121 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
122 LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
123 )
124+
125+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
126diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
127index 3628c8283a..186540940f 100644
128--- a/samples/cpp/CMakeLists.txt
129+++ b/samples/cpp/CMakeLists.txt
130@@ -258,6 +258,8 @@ macro(ie_add_sample)
131 COMPONENT samples_bin
132 EXCLUDE_FROM_ALL)
133
134+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
135+
136 # create global target with all samples / demo apps
137 if(NOT TARGET ie_samples)
138 add_custom_target(ie_samples ALL)
139diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
140index 4e9f76638f..6d8df5f0a1 100644
141--- a/scripts/CMakeLists.txt
142+++ b/scripts/CMakeLists.txt
143@@ -37,7 +37,7 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_SOURCE_DIR}"
144
145 # install setupvars
146
147-ie_cpack_add_component(setupvars REQUIRED)
148+#ie_cpack_add_component(setupvars REQUIRED)
149
150 if(UNIX)
151 set(_setupvars_file setupvars/setupvars.sh)
152@@ -54,13 +54,13 @@ elseif(WIN32)
153 file(WRITE "${_setupvars_file}" "${_setupvars_content}")
154 endif()
155 endif()
156-install(PROGRAMS "${_setupvars_file}"
157- DESTINATION .
158- COMPONENT setupvars)
159+#install(PROGRAMS "${_setupvars_file}"
160+# DESTINATION .
161+# COMPONENT setupvars)
162
163 # install install_dependencies
164
165-if(LINUX)
166+if (FALSE)
167 ie_cpack_add_component(install_dependencies REQUIRED)
168 install(DIRECTORY install_dependencies/
169 DESTINATION install_dependencies
170diff --git a/src/bindings/c/src/CMakeLists.txt b/src/bindings/c/src/CMakeLists.txt
171index 9200d0bda1..b3636e0716 100644
172--- a/src/bindings/c/src/CMakeLists.txt
173+++ b/src/bindings/c/src/CMakeLists.txt
174@@ -43,8 +43,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
175 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core_c
176 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core_c
177 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core_c
178- INCLUDES DESTINATION runtime/include/ie)
179+ INCLUDES DESTINATION include/ie)
180
181 install(DIRECTORY ${InferenceEngine_C_API_SOURCE_DIR}/include/
182- DESTINATION runtime/include/ie
183+ DESTINATION include/ie
184 COMPONENT core_c_dev)
185diff --git a/src/cmake/openvino.cmake b/src/cmake/openvino.cmake
186index 340896e3a8..9bda84fe51 100644
187--- a/src/cmake/openvino.cmake
188+++ b/src/cmake/openvino.cmake
189@@ -62,8 +62,8 @@ install(TARGETS ${TARGET_NAME} EXPORT OpenVINOTargets
190 RUNTIME DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core
191 ARCHIVE DESTINATION ${IE_CPACK_ARCHIVE_PATH} COMPONENT core
192 LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core
193- INCLUDES DESTINATION runtime/include
194- runtime/include/ie)
195+ INCLUDES DESTINATION include
196+ include/ie)
197
198 #
199 # Add openvin::dev target
200@@ -107,7 +107,7 @@ ie_cpack_add_component(core_dev REQUIRED DEPENDS core ${core_dev_components})
201
202 if(BUILD_SHARED_LIBS)
203 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
204- DESTINATION ${IE_CPACK_RUNTIME_PATH}
205+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
206 COMPONENT core)
207
208 # for InferenceEngineUnitTest
209@@ -126,7 +126,7 @@ endif()
210 install(EXPORT OpenVINOTargets
211 FILE OpenVINOTargets.cmake
212 NAMESPACE openvino::
213- DESTINATION runtime/cmake
214+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
215 COMPONENT core_dev)
216
217 set(PUBLIC_HEADERS_DIR "${OpenVINO_SOURCE_DIR}/src/inference/include")
218@@ -167,10 +167,10 @@ configure_file("${OpenVINO_SOURCE_DIR}/cmake/templates/OpenVINOConfig-version.cm
219
220 install(FILES "${CMAKE_BINARY_DIR}/share/InferenceEngineConfig.cmake"
221 "${CMAKE_BINARY_DIR}/InferenceEngineConfig-version.cmake"
222- DESTINATION runtime/cmake
223+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
224 COMPONENT core_dev)
225
226 install(FILES "${CMAKE_BINARY_DIR}/share/OpenVINOConfig.cmake"
227 "${CMAKE_BINARY_DIR}/OpenVINOConfig-version.cmake"
228- DESTINATION runtime/cmake
229+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenVINO
230 COMPONENT core_dev)
231diff --git a/src/common/preprocessing/CMakeLists.txt b/src/common/preprocessing/CMakeLists.txt
232index e41e286c95..11aaffca6a 100644
233--- a/src/common/preprocessing/CMakeLists.txt
234+++ b/src/common/preprocessing/CMakeLists.txt
235@@ -202,7 +202,7 @@ openvino_developer_export_targets(COMPONENT core TARGETS ${TARGET_NAME})
236
237 if(BUILD_SHARED_LIBS)
238 install(TARGETS ${TARGET_NAME}
239- LIBRARY DESTINATION ${IE_CPACK_RUNTIME_PATH} COMPONENT core)
240+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT core)
241 else()
242 ov_install_static_lib(${TARGET_NAME} core)
243 endif()
244diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
245index 86b195ee1c..867121ee50 100644
246--- a/src/core/CMakeLists.txt
247+++ b/src/core/CMakeLists.txt
248@@ -127,7 +127,7 @@ target_include_directories(ngraph INTERFACE $<BUILD_INTERFACE:${OV_CORE_INCLUDE_
249 #-----------------------------------------------------------------------------------------------
250
251 install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/include/
252- DESTINATION "runtime/include"
253+ DESTINATION "include"
254 COMPONENT core_dev
255 FILES_MATCHING
256 PATTERN "*.hpp"
257@@ -143,5 +143,5 @@ write_basic_package_version_file(${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
258
259 install(FILES ${CMAKE_BINARY_DIR}/ngraphConfig.cmake
260 ${CMAKE_BINARY_DIR}/ngraphConfigVersion.cmake
261- DESTINATION "runtime/cmake"
262+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
263 COMPONENT core_dev)
264diff --git a/src/inference/CMakeLists.txt b/src/inference/CMakeLists.txt
265index 737e7e0027..259d5e141d 100644
266--- a/src/inference/CMakeLists.txt
267+++ b/src/inference/CMakeLists.txt
268@@ -209,7 +209,7 @@ set_target_properties(${TARGET_NAME}_obj
269
270 openvino_developer_export_targets(COMPONENT core_legacy TARGETS ${TARGET_NAME}_plugin_api)
271
272-install(DIRECTORY "${PUBLIC_HEADERS_DIR}/" DESTINATION runtime/include
273+install(DIRECTORY "${PUBLIC_HEADERS_DIR}/" DESTINATION include
274 COMPONENT core_dev)
275
276 # Install static libraries for case BUILD_SHARED_LIBS=OFF
277diff --git a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
278index 3993bd9731..99287bad51 100644
279--- a/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
280+++ b/src/plugins/intel_gpu/src/kernel_selector/CMakeLists.txt
281@@ -94,7 +94,7 @@ add_custom_command(
282 COMMAND "${CMAKE_COMMAND}" -E copy_if_different ${CMAKE_CURRENT_SOURCE_DIR}/core/cache/cache.json ${TUNING_CACHE_PATH}/cache.json)
283
284 install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/core/cache/cache.json
285- DESTINATION ${IE_CPACK_RUNTIME_PATH}
286+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
287 COMPONENT gpu)
288
289 ov_install_static_lib(${TARGET_NAME} gpu)
290diff --git a/src/plugins/intel_myriad/myriad_dependencies.cmake b/src/plugins/intel_myriad/myriad_dependencies.cmake
291index 480acc05d1..5849f55878 100644
292--- a/src/plugins/intel_myriad/myriad_dependencies.cmake
293+++ b/src/plugins/intel_myriad/myriad_dependencies.cmake
294@@ -80,7 +80,7 @@ foreach(firmware_name IN LISTS VPU_SUPPORTED_FIRMWARES)
295 VERBATIM)
296
297 install(FILES ${${var_name}}
298- DESTINATION ${IE_CPACK_RUNTIME_PATH}
299+ DESTINATION ${IE_CPACK_LIBRARY_PATH}
300 COMPONENT myriad)
301
302 if(ENABLE_INTEL_MYRIAD AND ENABLE_BEH_TESTS)
303diff --git a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
304index d8ebea0bfc..66b5a3d462 100644
305--- a/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
306+++ b/src/plugins/intel_myriad/myriad_plugin/CMakeLists.txt
307@@ -56,6 +56,6 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
308
309 if(LINUX)
310 install(FILES ${mvnc_SOURCE_DIR}/src/97-myriad-usbboot.rules
311- DESTINATION install_dependencies
312+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
313 COMPONENT myriad)
314 endif()
315diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
316index 2fe0fd9742..234110b7d4 100644
317--- a/tools/CMakeLists.txt
318+++ b/tools/CMakeLists.txt
319@@ -20,7 +20,7 @@ endif()
320 ie_cpack_add_component(deployment_manager REQUIRED)
321
322 install(DIRECTORY deployment_manager
323- DESTINATION tools
324+ DESTINATION share/openvino/tools
325 COMPONENT deployment_manager
326 USE_SOURCE_PERMISSIONS)
327
328diff --git a/tools/compile_tool/CMakeLists.txt b/tools/compile_tool/CMakeLists.txt
329index d19eb5cc14..9fc929cbb0 100644
330--- a/tools/compile_tool/CMakeLists.txt
331+++ b/tools/compile_tool/CMakeLists.txt
332@@ -38,9 +38,9 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
333 ie_cpack_add_component(core_tools DEPENDS core)
334
335 install(TARGETS compile_tool
336- RUNTIME DESTINATION tools/compile_tool
337+ RUNTIME DESTINATION bin
338 COMPONENT core_tools)
339
340-install(FILES README.md
341- DESTINATION tools/compile_tool
342- COMPONENT core_tools)
343+#install(FILES README.md
344+# DESTINATION tools/compile_tool
345+# COMPONENT core_tools)
346--
3472.37.3
348