summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2022-10-21 17:03:54 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-10-25 14:35:32 +0800
commit023266fcbf67e4c8fc7c4f6b951948384ba8282b (patch)
treef80881999d03fa3376dd03a25ef084e6ed287f23 /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
parent5963592b7370ee63d621ab9653c838168a6e2fc5 (diff)
downloadmeta-intel-023266fcbf67e4c8fc7c4f6b951948384ba8282b.tar.gz
openvino-inference-engine : upgrade 2022.1.1 -> 2022.2.0
- Change gflag to shared as we are not building with static library. - We are using zlib from yocto recipe, so don't add zlib as third party package - Third party package mkl-dnn name changed to onednn upstream in openvino repo so changed the name accordingly in openvino-inference-engine recipe - Refresh patches Release Notes: https://github.com/openvinotoolkit/openvino/releases/tag/2022.2.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
new file mode 100644
index 00000000..ffb0f95d
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-Fix-build-issues-due-to-gflag-and-zlib.patch
@@ -0,0 +1,40 @@
1From a817386f1d0539a040fbdc02853a73bbcdddf1f1 Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Fri, 30 Sep 2022 20:26:04 +0800
4Subject: [PATCH] Fix build issues due to gflag and zlib
5
6Change gflag to shared as we are not building with static library.
7We are using zlib from host, so don't add zlib as third party package
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
12---
13 thirdparty/CMakeLists.txt | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
17index 4cba1588fe..f82bf3148b 100644
18--- a/thirdparty/CMakeLists.txt
19+++ b/thirdparty/CMakeLists.txt
20@@ -39,7 +39,7 @@ if(NOT CMAKE_CROSSCOMPILING)
21 endif()
22
23 if(NOT zlib_FOUND)
24- add_subdirectory(zlib EXCLUDE_FROM_ALL)
25+ #add_subdirectory(zlib EXCLUDE_FROM_ALL)
26 endif()
27
28 #
29@@ -85,7 +85,7 @@ ov_install_static_lib(fluid openvino_common)
30
31 if(NOT APPLE)
32 # on Apple only dynamic libraries are available
33- find_package(gflags QUIET COMPONENTS nothreads_static)
34+ find_package(gflags QUIET COMPONENTS nothreads_shared)
35 endif()
36
37 if(gflags_FOUND)
38--
392.37.3
40