summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-09-27 06:11:51 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-28 17:18:30 +0800
commit096598691de246c23902d49d228c7562ba2c9cc5 (patch)
tree8df7c03aaf84bd38374ae049ba0f31031c20c6d0 /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
parent7aef51c962c023f27e3fcda4c2419f1ced9942b9 (diff)
downloadmeta-intel-096598691de246c23902d49d228c7562ba2c9cc5.tar.gz
dldt-inference-engine: add recipe
This recipe builds the inference engine from opencv/dldt 2019 R1.1 release. OpenVINO™ toolkit, short for Open Visual Inference and Neural network Optimization toolkit, provides developers with improved neural network performance on a variety of Intel® processors and helps further unlock cost-effective, real-time vision applications. The toolkit enables deep learning inference and easy heterogeneous execution across multiple Intel® platforms (CPU, Intel® Processor Graphics)—providing implementations across cloud architectures to edge device. For more details, see: https://01.org/openvinotoolkit The recipe needs components from meta-oe so move it to dynamic-layers/openembedded-layer. GPU plugin support needs intel-compute-runtime which can be built by including clang layer in the mix as well. CPU and GPU plugins have been sanity tested to work using classification_sample. Further fine-tuning is still needed to improve the performance. Original patch by Anuj Mittal. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
new file mode 100644
index 00000000..af6febde
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
@@ -0,0 +1,40 @@
1From 888db5ced39bba933753c7f8b0b0ef4f900578a9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 27 Aug 2019 08:06:46 +0800
4Subject: [PATCH] disable tests
5
6Disable tests for now since they build a local copy of gflags etc.
7
8Upstream-Status: Inappropriate [Configuration]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11
12---
13 inference-engine/CMakeLists.txt | 1 -
14 inference-engine/samples/CMakeLists.txt | 1 -
15 2 files changed, 2 deletions(-)
16
17diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
18index 9e15382..bdf874e 100644
19--- a/inference-engine/CMakeLists.txt
20+++ b/inference-engine/CMakeLists.txt
21@@ -131,7 +131,6 @@ include(CheckCXXCompilerFlag)
22 include(cpplint)
23
24 add_subdirectory(src)
25-add_subdirectory(tests)
26 add_subdirectory(thirdparty)
27 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
28
29diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
30index 4e13c11..a8a9946 100644
31--- a/inference-engine/samples/CMakeLists.txt
32+++ b/inference-engine/samples/CMakeLists.txt
33@@ -93,7 +93,6 @@ set (GFLAGS_IS_SUBPROJECT TRUE)
34 set (HAVE_SYS_STAT_H 1)
35 set (HAVE_INTTYPES_H 1)
36
37-add_subdirectory(thirdparty/gflags)
38
39 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
40 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")