summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorChin Huat Ang <chin.huat.ang@intel.com>2019-09-27 06:11:51 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-28 17:18:30 +0800
commit096598691de246c23902d49d228c7562ba2c9cc5 (patch)
tree8df7c03aaf84bd38374ae049ba0f31031c20c6d0 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parent7aef51c962c023f27e3fcda4c2419f1ced9942b9 (diff)
downloadmeta-intel-096598691de246c23902d49d228c7562ba2c9cc5.tar.gz
dldt-inference-engine: add recipe
This recipe builds the inference engine from opencv/dldt 2019 R1.1 release. OpenVINO™ toolkit, short for Open Visual Inference and Neural network Optimization toolkit, provides developers with improved neural network performance on a variety of Intel® processors and helps further unlock cost-effective, real-time vision applications. The toolkit enables deep learning inference and easy heterogeneous execution across multiple Intel® platforms (CPU, Intel® Processor Graphics)—providing implementations across cloud architectures to edge device. For more details, see: https://01.org/openvinotoolkit The recipe needs components from meta-oe so move it to dynamic-layers/openembedded-layer. GPU plugin support needs intel-compute-runtime which can be built by including clang layer in the mix as well. CPU and GPU plugins have been sanity tested to work using classification_sample. Further fine-tuning is still needed to improve the performance. Original patch by Anuj Mittal. Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Supply-firmware-at-build-time.patch45
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch40
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch82
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-fix-openmp-checking.patch61
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch32
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch130
7 files changed, 423 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Supply-firmware-at-build-time.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Supply-firmware-at-build-time.patch
new file mode 100644
index 00000000..dcc65ed6
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-Supply-firmware-at-build-time.patch
@@ -0,0 +1,45 @@
1From e58226a399be7cf2cc6d91b66facb65d7dfb5018 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 15:40:18 +0800
4Subject: [PATCH] Supply firmware at build time
5
6We'd like to supply firmware when fetching the sources. Disable runtime
7fetching and point to fetched firmware instead.
8
9Upstream-Status: Submitted
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12
13---
14 inference-engine/cmake/dependencies.cmake | 18 ------------------
15 1 file changed, 18 deletions(-)
16
17diff --git a/inference-engine/cmake/dependencies.cmake b/inference-engine/cmake/dependencies.cmake
18index 64435ca..217fbc9 100644
19--- a/inference-engine/cmake/dependencies.cmake
20+++ b/inference-engine/cmake/dependencies.cmake
21@@ -37,24 +37,6 @@ else()
22 set(MODELS_BRANCH "master")
23 endif()
24
25-if (ENABLE_MYRIAD)
26- RESOLVE_DEPENDENCY(VPU_FIRMWARE_MA2450
27- ARCHIVE_UNIFIED firmware_ma2450_491.zip
28- TARGET_PATH "${TEMP}/vpu/firmware/ma2450"
29- ENVIRONMENT "VPU_FIRMWARE_MA2450"
30- FOLDER)
31- debug_message(STATUS "ma2450=" ${VPU_FIRMWARE_MA2450})
32-endif ()
33-
34-if (ENABLE_MYRIAD)
35- RESOLVE_DEPENDENCY(VPU_FIRMWARE_MA2480
36- ARCHIVE_UNIFIED firmware_ma2480_mdk_R7_9.zip
37- TARGET_PATH "${TEMP}/vpu/firmware/ma2480"
38- ENVIRONMENT "VPU_FIRMWARE_MA2480"
39- FOLDER)
40- debug_message(STATUS "ma2480=" ${VPU_FIRMWARE_MA2480})
41-endif ()
42-
43 ## enable cblas_gemm from OpenBLAS package
44 if (GEMM STREQUAL "OPENBLAS")
45 if(NOT BLAS_LIBRARIES OR NOT BLAS_INCLUDE_DIRS)
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
new file mode 100644
index 00000000..af6febde
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-tests.patch
@@ -0,0 +1,40 @@
1From 888db5ced39bba933753c7f8b0b0ef4f900578a9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 27 Aug 2019 08:06:46 +0800
4Subject: [PATCH] disable tests
5
6Disable tests for now since they build a local copy of gflags etc.
7
8Upstream-Status: Inappropriate [Configuration]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11
12---
13 inference-engine/CMakeLists.txt | 1 -
14 inference-engine/samples/CMakeLists.txt | 1 -
15 2 files changed, 2 deletions(-)
16
17diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
18index 9e15382..bdf874e 100644
19--- a/inference-engine/CMakeLists.txt
20+++ b/inference-engine/CMakeLists.txt
21@@ -131,7 +131,6 @@ include(CheckCXXCompilerFlag)
22 include(cpplint)
23
24 add_subdirectory(src)
25-add_subdirectory(tests)
26 add_subdirectory(thirdparty)
27 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
28
29diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
30index 4e13c11..a8a9946 100644
31--- a/inference-engine/samples/CMakeLists.txt
32+++ b/inference-engine/samples/CMakeLists.txt
33@@ -93,7 +93,6 @@ set (GFLAGS_IS_SUBPROJECT TRUE)
34 set (HAVE_SYS_STAT_H 1)
35 set (HAVE_INTTYPES_H 1)
36
37-add_subdirectory(thirdparty/gflags)
38
39 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
40 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch
new file mode 100644
index 00000000..5ba1e763
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-disable-werror.patch
@@ -0,0 +1,82 @@
1From 434cf332e8c368b626d230b79e8dccecf2b0525b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 19:39:37 +0800
4Subject: [PATCH] disable werror
5
6This shouldn't be enabled and leads to multiple errors when compiling cldnn.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11
12---
13 inference-engine/cmake/os_flags.cmake | 2 +-
14 inference-engine/samples/CMakeLists.txt | 1 -
15 inference-engine/thirdparty/clDNN/CMakeLists.txt | 2 --
16 inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake | 1 -
17 inference-engine/tools/CMakeLists.txt | 2 --
18 5 files changed, 1 insertion(+), 7 deletions(-)
19
20diff --git a/inference-engine/cmake/os_flags.cmake b/inference-engine/cmake/os_flags.cmake
21index 29608ea..2c189d8 100644
22--- a/inference-engine/cmake/os_flags.cmake
23+++ b/inference-engine/cmake/os_flags.cmake
24@@ -28,7 +28,7 @@ if (WIN32)
25 endif()
26
27 else()
28- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=return-type ")
29+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=return-type ")
30 if (APPLE)
31 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
32 elseif(UNIX)
33diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
34index a8a9946..8ac5454 100644
35--- a/inference-engine/samples/CMakeLists.txt
36+++ b/inference-engine/samples/CMakeLists.txt
37@@ -68,7 +68,6 @@ if (WIN32)
38 set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4251 /wd4275 /wd4267") #disable some warnings
39 endif()
40 else()
41- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror") #treating warnings as errors
42 if (APPLE)
43 set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=unused-command-line-argument")
44 elseif(UNIX)
45diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
46index 624d95c..5646ff1 100644
47--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
48+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
49@@ -757,8 +757,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
50 MultiProcessorCompilation
51 DeadCodeEliminate
52 ExtensionsEnabled
53- TreatWarnAsErrorEnabled
54- WarnLevel4
55 NoFastMath
56 StackProtector
57 )
58diff --git a/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake b/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
59index a541215..bed8a59 100644
60--- a/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
61+++ b/inference-engine/thirdparty/mkl-dnn/cmake/platform.cmake
62@@ -63,7 +63,6 @@ if(MSVC)
63 endif()
64 elseif(UNIX OR MINGW)
65 append(CMAKE_CCXX_FLAGS "-Wall -Wno-unknown-pragmas")
66- append_if_product(CMAKE_CCXX_FLAGS "-Werror")
67 append(CMAKE_CCXX_FLAGS "-fvisibility=internal")
68 append(CMAKE_C_FLAGS "-std=c99")
69 append(CMAKE_CXX_FLAGS "-std=c++11 -fvisibility-inlines-hidden")
70diff --git a/inference-engine/tools/CMakeLists.txt b/inference-engine/tools/CMakeLists.txt
71index 13ab365..feacf33 100644
72--- a/inference-engine/tools/CMakeLists.txt
73+++ b/inference-engine/tools/CMakeLists.txt
74@@ -23,8 +23,6 @@ endif()
75
76 if (WIN32)
77 # add_compile_options("/WX")
78-else()
79- add_compile_options("-Werror")
80 endif()
81
82 add_subdirectory(vpu)
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-fix-openmp-checking.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-fix-openmp-checking.patch
new file mode 100644
index 00000000..6053a315
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-fix-openmp-checking.patch
@@ -0,0 +1,61 @@
1From 46520b6fa766aabcb8c8bc0ead485d30bae965ea Mon Sep 17 00:00:00 2001
2From: Chin Huat Ang <chin.huat.ang@intel.com>
3Date: Tue, 20 Aug 2019 12:20:33 +0800
4Subject: [PATCH] fix openmp checking
5
6Make sure that we supply -fopenmp when using OpenMP supplied by compiler
7and dont look for it locally.
8
9Upstream-Status: Submitted
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
12---
13 inference-engine/cmake/dependencies.cmake | 6 +-----
14 inference-engine/cmake/ie_parallel.cmake | 4 ++--
15 inference-engine/src/mkldnn_plugin/CMakeLists.txt | 1 +
16 3 files changed, 4 insertions(+), 7 deletions(-)
17
18diff --git a/inference-engine/cmake/dependencies.cmake b/inference-engine/cmake/dependencies.cmake
19index d3cdf95..64435ca 100644
20--- a/inference-engine/cmake/dependencies.cmake
21+++ b/inference-engine/cmake/dependencies.cmake
22@@ -86,11 +86,7 @@ if (WIN32)
23 ENVIRONMENT "OMP"
24 VERSION_REGEX ".*_([a-z]*_([a-z0-9]+\\.)*[0-9]+).*")
25 elseif(LINUX)
26- RESOLVE_DEPENDENCY(OMP
27- ARCHIVE_LIN "iomp.tgz"
28- TARGET_PATH "${TEMP}/omp"
29- ENVIRONMENT "OMP"
30- VERSION_REGEX ".*_([a-z]*_([a-z0-9]+\\.)*[0-9]+).*")
31+ set(OMP "-fopenmp")
32 else(APPLE)
33 RESOLVE_DEPENDENCY(OMP
34 ARCHIVE_MAC "iomp_20190130_mac.tgz"
35diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
36index 18ccdf0..2738ee5 100644
37--- a/inference-engine/cmake/ie_parallel.cmake
38+++ b/inference-engine/cmake/ie_parallel.cmake
39@@ -68,8 +68,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
40 endif ()
41
42 if (NOT OMP_LIBRARIES_RELEASE OR NOT OMP_LIBRARIES_DEBUG)
43- find_library(OMP_LIBRARIES_RELEASE ${omp_lib_name} ${lib_rel_path} NO_DEFAULT_PATH)
44- find_library(OMP_LIBRARIES_DEBUG ${omp_lib_name} ${lib_dbg_path} NO_DEFAULT_PATH)
45+ find_library(OMP_LIBRARIES_RELEASE ${omp_lib_name})
46+ find_library(OMP_LIBRARIES_DEBUG ${omp_lib_name})
47 ext_message(STATUS "OMP Release lib: ${OMP_LIBRARIES_RELEASE}")
48 ext_message(STATUS "OMP Debug lib: ${OMP_LIBRARIES_DEBUG}")
49 endif ()
50diff --git a/inference-engine/src/mkldnn_plugin/CMakeLists.txt b/inference-engine/src/mkldnn_plugin/CMakeLists.txt
51index df81a5a..96c7f1c 100644
52--- a/inference-engine/src/mkldnn_plugin/CMakeLists.txt
53+++ b/inference-engine/src/mkldnn_plugin/CMakeLists.txt
54@@ -50,6 +50,7 @@ if (THREADING STREQUAL "TBB")
55 set(MKLDNN_THR MKLDNN_THR_TBB)
56 elseif (THREADING STREQUAL "OMP")
57 set(MKLDNN_THR MKLDNN_THR_OMP)
58+ target_link_options(${TARGET_NAME} PRIVATE -fopenmp)
59 else()
60 set(MKLDNN_THR MKLDNN_THR_SEQ)
61 endif()
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
new file mode 100644
index 00000000..d20ea111
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-use-provided-paths.patch
@@ -0,0 +1,33 @@
1From 3700b244d0906f339f33bcdbfc198f3ba97bf1a0 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 15:58:04 +0800
4Subject: [PATCH] use provided paths
5
6Use the CMake paths provided by environment instead of hardcoding them here.
7
8Upstream-Status: Pending
9Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
10
11---
12 inference-engine/CMakeLists.txt | 8 --------
13 1 file changed, 8 deletions(-)
14
15diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
16index 1c3d6ea..9e15382 100644
17--- a/inference-engine/CMakeLists.txt
18+++ b/inference-engine/CMakeLists.txt
19@@ -99,14 +99,6 @@ if(NOT(UNIX))
20 set (CMAKE_RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER})
21 set (LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER})
22 set (LIBRARY_OUTPUT_PATH ${LIBRARY_OUTPUT_DIRECTORY}) # compatibility issue: linux uses LIBRARY_OUTPUT_PATH, windows uses LIBRARY_OUTPUT_DIRECTORY
23-else ()
24- set (CMAKE_LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
25- set (CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
26- set (CMAKE_COMPILE_PDB_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
27- set (CMAKE_PDB_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
28- set (CMAKE_RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION})
29- set (LIBRARY_OUTPUT_DIRECTORY ${OUTPUT_ROOT}/${BIN_FOLDER}/${IE_BUILD_CONFIGURATION}/lib)
30- set (LIBRARY_OUTPUT_PATH ${LIBRARY_OUTPUT_DIRECTORY}/lib)
31 endif()
32
33 if (APPLE)
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
new file mode 100644
index 00000000..8af9527e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-use-ade-and-pugixml-from-system.patch
@@ -0,0 +1,32 @@
1From 6e225e85d5763e883128ee7b8a97ac247c46b465 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 20 Aug 2019 12:40:09 +0800
4Subject: [PATCH] use ade and pugixml from system
5
6Don't build a local copy and use the one from sysroot.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 inference-engine/thirdparty/CMakeLists.txt | 5 ++---
13 1 file changed, 2 insertions(+), 3 deletions(-)
14
15diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
16index f65f38c..7f23e8f 100644
17--- a/inference-engine/thirdparty/CMakeLists.txt
18+++ b/inference-engine/thirdparty/CMakeLists.txt
19@@ -7,11 +7,10 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
20 set(CMAKE_CC_FLAGS "${CMAKE_CC_FLAGS} -Wno-unknown-warning-option -Wno-inconsistent-missing-override -Wno-pass-failed")
21 endif()
22
23-add_subdirectory(pugixml)
24-export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
25+# add_subdirectory(pugixml)
26+# export(TARGETS pugixml NAMESPACE IE:: APPEND FILE "${CMAKE_BINARY_DIR}/targets.cmake")
27
28 add_subdirectory(stb_lib)
29-add_subdirectory(ade)
30
31 if (ENABLE_CLDNN)
32 set(CLDNN__OUTPUT_BIN_DIR ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch
new file mode 100644
index 00000000..6f0eb517
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0007-Install-sample-apps-and-format_reader-library.patch
@@ -0,0 +1,130 @@
1From d96a9413face4e8540400848d9a25a5458bad74a Mon Sep 17 00:00:00 2001
2From: "Brett T. Warden" <brett.t.warden@intel.com>
3Date: Mon, 28 Jan 2019 13:58:03 -0800
4Subject: [PATCH] Install sample apps and format_reader library
5
6Make sure that we install format_reader library as well.
7
8Upstream-Status: Submitted
9
10Signed-off-by: Chin Huat Ang <chin.huat.ang@intel.com>
11---
12 inference-engine/samples/classification_sample/CMakeLists.txt | 1 +
13 inference-engine/samples/classification_sample_async/CMakeLists.txt | 1 +
14 inference-engine/samples/common/format_reader/CMakeLists.txt | 1 +
15 inference-engine/samples/hello_autoresize_classification/CMakeLists.txt | 1 +
16 inference-engine/samples/hello_classification/CMakeLists.txt | 1 +
17 inference-engine/samples/hello_request_classification/CMakeLists.txt | 1 +
18 inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt | 1 +
19 inference-engine/samples/style_transfer_sample/CMakeLists.txt | 1 +
20 inference-engine/samples/validation_app/CMakeLists.txt | 1 +
21 9 files changed, 9 insertions(+)
22
23diff --git a/inference-engine/samples/classification_sample/CMakeLists.txt b/inference-engine/samples/classification_sample/CMakeLists.txt
24index 1dab0c9..b2c67ea 100644
25--- a/inference-engine/samples/classification_sample/CMakeLists.txt
26+++ b/inference-engine/samples/classification_sample/CMakeLists.txt
27@@ -16,6 +16,7 @@ link_directories(${LIB_FOLDER})
28
29 # Create library file from sources.
30 add_executable(${TARGET_NAME} ${SRC})
31+install(TARGETS ${TARGET_NAME} DESTINATION bin)
32
33 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
34 COMPILE_PDB_NAME ${TARGET_NAME})
35diff --git a/inference-engine/samples/classification_sample_async/CMakeLists.txt b/inference-engine/samples/classification_sample_async/CMakeLists.txt
36index 9e37440..3fc0082 100644
37--- a/inference-engine/samples/classification_sample_async/CMakeLists.txt
38+++ b/inference-engine/samples/classification_sample_async/CMakeLists.txt
39@@ -16,6 +16,7 @@ link_directories(${LIB_FOLDER})
40
41 # Create library file from sources.
42 add_executable(${TARGET_NAME} ${SRC})
43+install(TARGETS ${TARGET_NAME} DESTINATION bin)
44
45 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
46 COMPILE_PDB_NAME ${TARGET_NAME})
47diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
48index e3ecd58..cc30fec 100644
49--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
50+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
51@@ -35,6 +35,7 @@ source_group("include" FILES ${LIBRARY_HEADERS})
52
53 # Create library file from sources.
54 add_library(${TARGET_NAME} SHARED ${MAIN_SRC} ${LIBRARY_HEADERS})
55+install(TARGETS ${TARGET_NAME} DESTINATION lib)
56 target_link_libraries(${TARGET_NAME} ${OpenCV_LIBRARIES})
57
58 if(CMAKE_VERSION VERSION_LESS "2.8.11")
59diff --git a/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt b/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
60index 01deda6..5ef2900 100644
61--- a/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
62+++ b/inference-engine/samples/hello_autoresize_classification/CMakeLists.txt
63@@ -21,6 +21,7 @@ link_directories(${LIB_FOLDER})
64
65 # Create library file from sources.
66 add_executable(${TARGET_NAME} ${SRC})
67+install(TARGETS ${TARGET_NAME} DESTINATION bin)
68
69 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
70 COMPILE_PDB_NAME ${TARGET_NAME})
71diff --git a/inference-engine/samples/hello_classification/CMakeLists.txt b/inference-engine/samples/hello_classification/CMakeLists.txt
72index 845f7e9..276be87 100644
73--- a/inference-engine/samples/hello_classification/CMakeLists.txt
74+++ b/inference-engine/samples/hello_classification/CMakeLists.txt
75@@ -23,6 +23,7 @@ link_directories(${LIB_FOLDER})
76
77 # Create library file from sources.
78 add_executable(${TARGET_NAME} ${SRC})
79+install(TARGETS ${TARGET_NAME} DESTINATION bin)
80
81 if(WIN32)
82 # This target supports UNICODE on Windows
83diff --git a/inference-engine/samples/hello_request_classification/CMakeLists.txt b/inference-engine/samples/hello_request_classification/CMakeLists.txt
84index c7dbb1e..3e5ab8f 100644
85--- a/inference-engine/samples/hello_request_classification/CMakeLists.txt
86+++ b/inference-engine/samples/hello_request_classification/CMakeLists.txt
87@@ -23,6 +23,7 @@ link_directories(${LIB_FOLDER})
88
89 # Create library file from sources.
90 add_executable(${TARGET_NAME} ${SRC})
91+install(TARGETS ${TARGET_NAME} DESTINATION bin)
92
93 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
94 COMPILE_PDB_NAME ${TARGET_NAME})
95diff --git a/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt b/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
96index 436edc2..adba758 100644
97--- a/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
98+++ b/inference-engine/samples/object_detection_sample_ssd/CMakeLists.txt
99@@ -21,6 +21,7 @@ link_directories(${LIB_FOLDER})
100
101 # Create library file from sources.
102 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
103+install(TARGETS ${TARGET_NAME} DESTINATION bin)
104
105 add_dependencies(${TARGET_NAME} gflags)
106
107diff --git a/inference-engine/samples/style_transfer_sample/CMakeLists.txt b/inference-engine/samples/style_transfer_sample/CMakeLists.txt
108index ac2a170..d8e624b 100644
109--- a/inference-engine/samples/style_transfer_sample/CMakeLists.txt
110+++ b/inference-engine/samples/style_transfer_sample/CMakeLists.txt
111@@ -22,6 +22,7 @@ link_directories(${LIB_FOLDER})
112
113 # Create library file from sources.
114 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
115+install(TARGETS ${TARGET_NAME} DESTINATION bin)
116
117 add_dependencies(${TARGET_NAME} gflags)
118
119diff --git a/inference-engine/samples/validation_app/CMakeLists.txt b/inference-engine/samples/validation_app/CMakeLists.txt
120index 87b337c..07f48b7 100644
121--- a/inference-engine/samples/validation_app/CMakeLists.txt
122+++ b/inference-engine/samples/validation_app/CMakeLists.txt
123@@ -36,6 +36,7 @@ link_directories(${LIB_FOLDER})
124
125 # Create library file from sources.
126 add_executable(${TARGET_NAME} ${MAIN_SRC} ${MAIN_HEADERS})
127+install(TARGETS ${TARGET_NAME} DESTINATION bin)
128
129 set_target_properties(${TARGET_NAME} PROPERTIES "CMAKE_CXX_FLAGS" "${CMAKE_CXX_FLAGS} -fPIE"
130 COMPILE_PDB_NAME ${TARGET_NAME})