summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-16 22:21:15 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-08-21 12:27:06 +0800
commite0486da74816f053a775862a57508bfa16bbd453 (patch)
treee5df1856489764dfee23a32ac77bdcfda6430523 /dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
parent9c62233238a72a913090c175662f4b2550a2e3dd (diff)
downloadmeta-intel-e0486da74816f053a775862a57508bfa16bbd453.tar.gz
opencl-clang: upgrade 8.0.0 -> 8.0.1
Switch to using latest on ocl-release-80 branch and to using using lld for native builds to remain in sync with clang layer. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
new file mode 100644
index 00000000..c45c36d8
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https \
9 file://point-to-correct-llvm-tblgen.patch \
10 "
11
12SRCREV = "94af090661d7c953c516c97a25ed053c744a0737"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17DEPENDS += "clang"
18
19DEPENDS_append_class-target = " opencl-clang-native"
20LDFLAGS_append_class-native = " -fuse-ld=lld"
21
22COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null"
24
25EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \
28 "
29
30do_install_append_class-native() {
31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33}
34
35BBCLASSEXTEND = "native nativesdk"
36
37TOOLCHAIN_class-native = "clang"