summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-16 22:21:15 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-08-21 12:27:06 +0800
commite0486da74816f053a775862a57508bfa16bbd453 (patch)
treee5df1856489764dfee23a32ac77bdcfda6430523 /dynamic-layers
parent9c62233238a72a913090c175662f4b2550a2e3dd (diff)
downloadmeta-intel-e0486da74816f053a775862a57508bfa16bbd453.tar.gz
opencl-clang: upgrade 8.0.0 -> 8.0.1
Switch to using latest on ocl-release-80 branch and to using using lld for native builds to remain in sync with clang layer. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
index 6599c9b6..c45c36d8 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_8.0.1.bb
@@ -9,12 +9,12 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=h
9 file://point-to-correct-llvm-tblgen.patch \ 9 file://point-to-correct-llvm-tblgen.patch \
10 " 10 "
11 11
12SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15" 12SRCREV = "94af090661d7c953c516c97a25ed053c744a0737"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit cmake 16inherit cmake
17DEPENDS += "clang clang-native" 17DEPENDS += "clang"
18 18
19DEPENDS_append_class-target = " opencl-clang-native" 19DEPENDS_append_class-target = " opencl-clang-native"
20LDFLAGS_append_class-native = " -fuse-ld=lld" 20LDFLAGS_append_class-native = " -fuse-ld=lld"
@@ -33,3 +33,5 @@ do_install_append_class-native() {
33} 33}
34 34
35BBCLASSEXTEND = "native nativesdk" 35BBCLASSEXTEND = "native nativesdk"
36
37TOOLCHAIN_class-native = "clang"