summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gstreamer-vaapi
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-18 16:15:45 +0100
committerTom Zanussi <tom.zanussi@intel.com>2013-11-14 15:56:45 -0600
commitccc27afc38d0190e25d7c19ebb49d5c33fba3194 (patch)
treeb52378fd15bae0d9616bb583e6c6aab31b819fa7 /common/recipes-multimedia/gstreamer/gstreamer-vaapi
parent678e42bdcc31b6f416c9885fc90498a4700276cd (diff)
downloadmeta-intel-ccc27afc38d0190e25d7c19ebb49d5c33fba3194.tar.gz
gstreamer-vaapi: add 0.5.6
gstreamer-vaapi 0.5.x supports GStreamer 0.10/1.0/1.2, so add seperate recipes for 0.10 and 1.0 builds. This adds a new recipe name so keep the old gstreamer-vaapi_0.4.3 for now until all users of that have migrated away. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gstreamer-vaapi')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch31
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch17
2 files changed, 48 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
new file mode 100644
index 00000000..9281b048
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
@@ -0,0 +1,31 @@
1Install tests.
2
3Upstream-Status: Inappropriate
4Signed-off-by: Ross Burton <ross.burton@intel.com>
5
6---
7 tests/Makefile.am | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/tests/Makefile.am b/tests/Makefile.am
11index 2e7f191..8f65446 100644
12--- a/tests/Makefile.am
13+++ b/tests/Makefile.am
14@@ -1,4 +1,4 @@
15-noinst_PROGRAMS = \
16+bin_PROGRAMS = \
17 simple-decoder \
18 test-decode \
19 test-display \
20@@ -9,7 +9,7 @@ noinst_PROGRAMS = \
21 $(NULL)
22
23 if USE_GLX
24-noinst_PROGRAMS += \
25+bin_PROGRAMS += \
26 test-textures \
27 $(NULL)
28 endif
29--
301.7.10.4
31
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch
new file mode 100644
index 00000000..c42e01fe
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch
@@ -0,0 +1,17 @@
1Fix compilation of the Wayland backend when using GStreamer 0.10.
2
3Upstream-Status: Submitted (https://bugzilla.gnome.org/show_bug.cgi?id=712282)
4Signed-off-by: Ross Burton <ross.burton@intel.com>
5
6diff --git a/gst-libs/gst/vaapi/Makefile.am b/gst-libs/gst/vaapi/Makefile.am
7index ab605e1..0a3fa38 100644
8--- a/gst-libs/gst/vaapi/Makefile.am
9+++ b/gst-libs/gst/vaapi/Makefile.am
10@@ -364,6 +364,7 @@ libgstvaapi_wayland_@GST_API_VERSION@_la_CFLAGS = \
11 -I$(top_srcdir)/gst-libs \
12 $(GLIB_CFLAGS) \
13 $(GST_BASE_CFLAGS) \
14+ $(top_builddir)/gst-libs/gst/video/libgstvaapi-videoutils.la \
15 $(WAYLAND_CFLAGS) \
16 $(LIBVA_WAYLAND_CFLAGS) \
17 $(NULL)