summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-18 16:15:45 +0100
committerTom Zanussi <tom.zanussi@intel.com>2013-11-14 15:56:45 -0600
commitccc27afc38d0190e25d7c19ebb49d5c33fba3194 (patch)
treeb52378fd15bae0d9616bb583e6c6aab31b819fa7 /common/recipes-multimedia
parent678e42bdcc31b6f416c9885fc90498a4700276cd (diff)
downloadmeta-intel-ccc27afc38d0190e25d7c19ebb49d5c33fba3194.tar.gz
gstreamer-vaapi: add 0.5.6
gstreamer-vaapi 0.5.x supports GStreamer 0.10/1.0/1.2, so add seperate recipes for 0.10 and 1.0 builds. This adds a new recipe name so keep the old gstreamer-vaapi_0.4.3 for now until all users of that have migrated away. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb7
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb5
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc41
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch31
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch17
5 files changed, 101 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb
new file mode 100644
index 00000000..784e0c55
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-0.10_0.5.6.bb
@@ -0,0 +1,7 @@
1require gstreamer-vaapi.inc
2
3DEPENDS += "gstreamer gst-plugins-base gst-plugins-bad"
4
5SRC_URI += "file://wayland-compile.patch"
6
7GST_API_VERSION = "0.10"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb
new file mode 100644
index 00000000..b8ad2a57
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.5.6.bb
@@ -0,0 +1,5 @@
1require gstreamer-vaapi.inc
2
3DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
4
5GST_API_VERSION = "1.0"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc b/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc
new file mode 100644
index 00000000..9fc32481
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc
@@ -0,0 +1,41 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7FILESPATH = "${@base_set_filespath(["${FILE_DIRNAME}/${REALPN}", "${FILE_DIRNAME}/${REALPN}"], d)}"
8
9LICENSE = "LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12DEPENDS = "libva"
13
14SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/${REALPN}/${REALPN}-${PV}.tar.bz2 \
15 file://install-tests.patch"
16
17SRC_URI[md5sum] = "7b1ede7193bc5a0aca921c490684f7b5"
18SRC_URI[sha256sum] = "68e0598456fe17085f6b8b1ce3da066322cc02c363955fb319776a5404d2b0da"
19
20S = "${WORKDIR}/${REALPN}-${PV}"
21
22inherit autotools pkgconfig gtk-doc
23
24PACKAGES =+ "${PN}-tests"
25
26EXTRA_OECONF += "--with-gstreamer-api=${GST_API_VERSION}"
27
28PACKAGECONFIG ??= "drm \
29 ${@base_contains("DISTRO_FEATURES", "opengl x11", "glx", "", d)} \
30 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)} \
31 ${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
32
33PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
34PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/mesa"
35PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
36PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
37
38FILES_${PN} += "${libdir}/gstreamer-*/*.so"
39FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
40FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
41FILES_${PN}-tests = "${bindir}/*"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
new file mode 100644
index 00000000..9281b048
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
@@ -0,0 +1,31 @@
1Install tests.
2
3Upstream-Status: Inappropriate
4Signed-off-by: Ross Burton <ross.burton@intel.com>
5
6---
7 tests/Makefile.am | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/tests/Makefile.am b/tests/Makefile.am
11index 2e7f191..8f65446 100644
12--- a/tests/Makefile.am
13+++ b/tests/Makefile.am
14@@ -1,4 +1,4 @@
15-noinst_PROGRAMS = \
16+bin_PROGRAMS = \
17 simple-decoder \
18 test-decode \
19 test-display \
20@@ -9,7 +9,7 @@ noinst_PROGRAMS = \
21 $(NULL)
22
23 if USE_GLX
24-noinst_PROGRAMS += \
25+bin_PROGRAMS += \
26 test-textures \
27 $(NULL)
28 endif
29--
301.7.10.4
31
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch
new file mode 100644
index 00000000..c42e01fe
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/wayland-compile.patch
@@ -0,0 +1,17 @@
1Fix compilation of the Wayland backend when using GStreamer 0.10.
2
3Upstream-Status: Submitted (https://bugzilla.gnome.org/show_bug.cgi?id=712282)
4Signed-off-by: Ross Burton <ross.burton@intel.com>
5
6diff --git a/gst-libs/gst/vaapi/Makefile.am b/gst-libs/gst/vaapi/Makefile.am
7index ab605e1..0a3fa38 100644
8--- a/gst-libs/gst/vaapi/Makefile.am
9+++ b/gst-libs/gst/vaapi/Makefile.am
10@@ -364,6 +364,7 @@ libgstvaapi_wayland_@GST_API_VERSION@_la_CFLAGS = \
11 -I$(top_srcdir)/gst-libs \
12 $(GLIB_CFLAGS) \
13 $(GST_BASE_CFLAGS) \
14+ $(top_builddir)/gst-libs/gst/video/libgstvaapi-videoutils.la \
15 $(WAYLAND_CFLAGS) \
16 $(LIBVA_WAYLAND_CFLAGS) \
17 $(NULL)