summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/rmc/rmc-efi.bb
diff options
context:
space:
mode:
authorTodor Minchev <todor.minchev@linux.intel.com>2017-07-06 15:41:21 -0700
committerSaul Wold <sgw@linux.intel.com>2017-07-06 16:03:29 -0700
commitb767b5cb2f374630136b1903dba7d86dddff362d (patch)
tree0713fb62d22244396648b5ec460e31f5b926d72e /common/recipes-bsp/rmc/rmc-efi.bb
parent0f395e9fe94bf150ba050bd9d7ccf60ee20f8c04 (diff)
downloadmeta-intel-b767b5cb2f374630136b1903dba7d86dddff362d.tar.gz
rmc: split rmc.bb and rmc-efi.bb into separate recipes
X32 builds require that the bootloader is built as x86_64 binary. This patch splits the build definitions of the RMC userspace application and the RMC EFI library into separate recipes and builds an x86_64 EFI library when DEFAULTTUNE is x32. Signed-off-by: Todor Minchev <todor.minchev@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp/rmc/rmc-efi.bb')
-rw-r--r--common/recipes-bsp/rmc/rmc-efi.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/common/recipes-bsp/rmc/rmc-efi.bb b/common/recipes-bsp/rmc/rmc-efi.bb
new file mode 100644
index 00000000..ea096197
--- /dev/null
+++ b/common/recipes-bsp/rmc/rmc-efi.bb
@@ -0,0 +1,39 @@
1SUMMARY = "RMC (Runtime Machine Configuration) EFI library"
2
3DESCRIPTION = "The RMC EFI library adds RMC support to existing EFI bootloaders"
4
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=ade413c694d3aaefc9554b24a8814ee8"
8
9SRC_URI = "git://git.yoctoproject.org/rmc"
10
11SRCREV = "027ac76f642dcab1a9f237a00f03a3a714bd04b9"
12
13S = "${WORKDIR}/git"
14
15COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux*"
16
17TARGET_CFLAGS +="-Wl,--hash-style=both"
18
19EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
20 RMC_INSTALL_LIB_PATH=${D}${libdir} \
21 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
22
23SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
24
25python () {
26 ccargs = d.getVar('TUNE_CCARGS').split()
27 if '-mx32' in ccargs:
28 ccargs.remove('-mx32')
29 ccargs.append('-m64')
30 d.setVar('TUNE_CCARGS', ' '.join(ccargs))
31}
32
33do_compile() {
34 oe_runmake -f Makefile.efi
35}
36
37do_install() {
38 oe_runmake -f Makefile.efi install
39}