summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-03-12 13:53:08 +0200
committerTom Zanussi <tom.zanussi@intel.com>2014-03-13 10:07:12 -0500
commiteb9240d44d52e7dacbbf162b6e7c395d2ad20be0 (patch)
treedd2627a0d1a0ec46de821b9e0858f922edaab7bf
parente295a2bed9f5f043de3321c1124bd5849b7d4434 (diff)
downloadmeta-intel-eb9240d44d52e7dacbbf162b6e7c395d2ad20be0.tar.gz
common/recipes-bsp: remove gnu-efi and gummiboot recipes
Nothing in meta-intel requires these and now they are in OE-core anyway. Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch48
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi/parallel-make.patch22
-rw-r--r--common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb35
-rw-r--r--common/recipes-bsp/gummiboot/gummiboot_git.bb26
4 files changed, 0 insertions, 131 deletions
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch b/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch
deleted file mode 100644
index e5b47c19..00000000
--- a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make-archives.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1Fix parallel make failure for archives
2
3Upstream-Status: Pending
4
5The lib and gnuefi makefiles were using the lib.a() form which compiles
6and ar's as a pair instead of compiling all and then ar'ing which can
7parallelize better. This was resulting in build failures on larger values
8of -j.
9
10See http://www.chemie.fu-berlin.de/chemnet/use/info/make/make_toc.html#TOC105
11for details.
12
13Signed-off-by: Saul Wold <sgw@linux.intel.com>
14Signed-off-by: Darren Hart <dvhart@linux.intel.com>
15---
16---
17 gnuefi/Makefile | 3 ++-
18 lib/Makefile | 3 ++-
19 2 files changed, 4 insertions(+), 2 deletions(-)
20
21Index: gnu-efi-3.0/lib/Makefile
22===================================================================
23--- gnu-efi-3.0.orig/lib/Makefile
24+++ gnu-efi-3.0/lib/Makefile
25@@ -66,7 +66,8 @@ all: libsubdirs libefi.a
26 libsubdirs:
27 for sdir in $(SUBDIRS); do mkdir -p $$sdir; done
28
29-libefi.a: $(patsubst %,libefi.a(%),$(OBJS))
30+libefi.a: $(OBJS)
31+ $(AR) rv $@ $(OBJS)
32
33 clean:
34 rm -f libefi.a *~ $(OBJS) */*.o
35Index: gnu-efi-3.0/gnuefi/Makefile
36===================================================================
37--- gnu-efi-3.0.orig/gnuefi/Makefile
38+++ gnu-efi-3.0/gnuefi/Makefile
39@@ -51,7 +51,8 @@ TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
40
41 all: $(TARGETS)
42
43-libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
44+libgnuefi.a: $(OBJS)
45+ $(AR) rv $@ $(OBJS)
46
47 clean:
48 rm -f $(TARGETS) *~ *.o $(OBJS)
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make.patch b/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make.patch
deleted file mode 100644
index 27c94e8a..00000000
--- a/common/recipes-bsp/gnu-efi/gnu-efi/parallel-make.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1Fix parallel make failure
2
3Upstream-Status: Submitted [Maintainer directly]
4
5Add a missing dependency which resulted in a race leading to failure
6on larger values of -j.
7
8Signed-off-by: Darren Hart <dvhart@linux.intel.com>
9
10Index: gnu-efi-3.0/Makefile
11===================================================================
12--- gnu-efi-3.0.orig/Makefile
13+++ gnu-efi-3.0/Makefile
14@@ -42,6 +42,8 @@ include $(SRCDIR)/Make.defaults
15
16 SUBDIRS = lib gnuefi inc apps
17
18+gnuefi: lib
19+
20 all: check_gcc $(SUBDIRS)
21
22 $(SUBDIRS):
diff --git a/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb b/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
deleted file mode 100644
index 505c4887..00000000
--- a/common/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Libraries for producing EFI binaries"
2HOMEPAGE = "http://sourceforge.net/projects/gnu-efi/"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=5fb358a180f484b285b0d99acdc29666"
6
7PR = "r0"
8
9SRC_URI = "http://downloads.sourceforge.net/gnu-efi/gnu-efi_3.0u.orig.tar.gz \
10 file://parallel-make.patch \
11 file://parallel-make-archives.patch \
12 "
13SRC_URI[md5sum] = "d15d3c700e79a1e2938544d73edc572d"
14SRC_URI[sha256sum] = "3c0d450d5829204ca05dcb3b2aae772e52c379b7c7e09146759c6315606f934e"
15
16COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
17
18S = "${WORKDIR}/gnu-efi-3.0"
19
20def gnu_efi_arch(d):
21 import re
22 tarch = d.getVar("TARGET_ARCH", True)
23 if re.match("i[3456789]86", tarch):
24 return "ia32"
25 return tarch
26
27EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
28 'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}'\
29 "
30
31do_install() {
32 oe_runmake install INSTALLROOT="${D}"
33}
34
35FILES_${PN} += "${libdir}/*.lds"
diff --git a/common/recipes-bsp/gummiboot/gummiboot_git.bb b/common/recipes-bsp/gummiboot/gummiboot_git.bb
deleted file mode 100644
index ff088a8c..00000000
--- a/common/recipes-bsp/gummiboot/gummiboot_git.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools
10inherit deploy
11
12PV = "35+git${SRCPV}"
13PR = "r0"
14SRCREV = "6feb7d971f79e88ed395637390d58404fba5f3c3"
15SRC_URI = "git://anongit.freedesktop.org/gummiboot"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OECONF = "--disable-biostest --with-efi-includedir=${STAGING_INCDIR} \
20 --with-efi-ldsdir=${STAGING_LIBDIR} \
21 --with-efi-libdir=${STAGING_LIBDIR}"
22
23do_deploy () {
24 install ${S}/gummiboot*.efi ${DEPLOYDIR}/
25}
26addtask deploy before do_build after do_compile