summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/gummiboot/gummiboot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-bsp/gummiboot/gummiboot_git.bb')
-rw-r--r--common/recipes-bsp/gummiboot/gummiboot_git.bb26
1 files changed, 0 insertions, 26 deletions
diff --git a/common/recipes-bsp/gummiboot/gummiboot_git.bb b/common/recipes-bsp/gummiboot/gummiboot_git.bb
deleted file mode 100644
index ff088a8c..00000000
--- a/common/recipes-bsp/gummiboot/gummiboot_git.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images."
2HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "gnu-efi util-linux"
8
9inherit autotools
10inherit deploy
11
12PV = "35+git${SRCPV}"
13PR = "r0"
14SRCREV = "6feb7d971f79e88ed395637390d58404fba5f3c3"
15SRC_URI = "git://anongit.freedesktop.org/gummiboot"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OECONF = "--disable-biostest --with-efi-includedir=${STAGING_INCDIR} \
20 --with-efi-ldsdir=${STAGING_LIBDIR} \
21 --with-efi-libdir=${STAGING_LIBDIR}"
22
23do_deploy () {
24 install ${S}/gummiboot*.efi ${DEPLOYDIR}/
25}
26addtask deploy before do_build after do_compile