summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2022-07-27 15:27:33 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-07-27 19:02:59 +0800
commit2914c71cc8abd253db712fb2c55a5c777e6925ed (patch)
treeb4662c7cd4dcb4378b071135628e614f338e5b32
parentb783f9e933ee07b118a550953e7cbf4db51d61d1 (diff)
downloadmeta-intel-2914c71cc8abd253db712fb2c55a5c777e6925ed.tar.gz
ispc : upgrade 1.17.0 -> 1.18.0
* Don't build with clang specifically and let user decide. * Drop already merged patch: 0001-Enable-LLVM-15.0-support.patch * ispc generated headers include a comment will full path to the header. Patch the code to drop this comment. * Tweak bison and flex invocation to make sure they don't include #line directives. * Add flex-native to DEPENDS. * Release notes: https://github.com/ispc/ispc/releases/tag/v1.18.0 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch52
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch37
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb (renamed from dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb)14
3 files changed, 47 insertions, 56 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch
deleted file mode 100644
index fe82ff25..00000000
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Enable-LLVM-15.0-support.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From 9b722217a2818bc4335bf2c7d3293d30aa5977b1 Mon Sep 17 00:00:00 2001
2From: Dmitry Babokin <dmitry.y.babokin@intel.com>
3Date: Fri, 4 Feb 2022 16:45:34 -0800
4Subject: [PATCH 01/24] Enable LLVM 15.0 support
5
6Upstream-Status: Backport [https://github.com/ispc/ispc/commit/9b722217a2818bc4335bf2c7d3293d30aa5977b1]
7
8Signed-off-by: Dmitry Babokin <dmitry.y.babokin@intel.com>
9---
10 src/ispc.h | 4 ++--
11 src/ispc_version.h | 3 ++-
12 2 files changed, 4 insertions(+), 3 deletions(-)
13
14diff --git a/src/ispc.h b/src/ispc.h
15index 362c2b93..581d5de6 100644
16--- a/src/ispc.h
17+++ b/src/ispc.h
18@@ -1,5 +1,5 @@
19 /*
20- Copyright (c) 2010-2021, Intel Corporation
21+ Copyright (c) 2010-2022, Intel Corporation
22 All rights reserved.
23
24 Redistribution and use in source and binary forms, with or without
25@@ -42,7 +42,7 @@
26 #include "target_registry.h"
27
28 #if ISPC_LLVM_VERSION < OLDEST_SUPPORTED_LLVM || ISPC_LLVM_VERSION > LATEST_SUPPORTED_LLVM
29-#error "Only LLVM 11.0 - 13.0 and 14.0 development branch are supported"
30+#error "Only LLVM 11.0 - 14.0 and 15.0 development branch are supported"
31 #endif
32
33 #if defined(_WIN32) || defined(_WIN64)
34diff --git a/src/ispc_version.h b/src/ispc_version.h
35index e8487e5b..04a3cf64 100644
36--- a/src/ispc_version.h
37+++ b/src/ispc_version.h
38@@ -50,9 +50,10 @@
39 #define ISPC_LLVM_12_0 120000
40 #define ISPC_LLVM_13_0 130000
41 #define ISPC_LLVM_14_0 140000
42+#define ISPC_LLVM_15_0 150000
43
44 #define OLDEST_SUPPORTED_LLVM ISPC_LLVM_10_0
45-#define LATEST_SUPPORTED_LLVM ISPC_LLVM_14_0
46+#define LATEST_SUPPORTED_LLVM ISPC_LLVM_15_0
47
48 #ifdef __ispc__xstr
49 #undef __ispc__xstr
50--
512.17.1
52
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
new file mode 100644
index 00000000..e7bb599e
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc/0001-Fix-QA-Issues.patch
@@ -0,0 +1,37 @@
1From 139b94a7fb72114c31a2a6ab3f7e6024b4a738ec Mon Sep 17 00:00:00 2001
2From: Yogesh Tyagi <yogesh.tyagi@intel.com>
3Date: Tue, 26 Jul 2022 15:25:10 +0800
4Subject: [PATCH] Fix QA Issues
5
6Stop ispc from inserting host file path in generated headers which leads to reproducibility problems.
7
8Upstream-Status: Inappropriate [OE build specific]
9
10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11
12---
13 src/module.cpp | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/module.cpp b/src/module.cpp
17index 58a2ae83..82673052 100644
18--- a/src/module.cpp
19+++ b/src/module.cpp
20@@ -2105,7 +2105,7 @@ bool Module::writeHeader(const char *fn) {
21 perror("fopen");
22 return false;
23 }
24- fprintf(f, "//\n// %s\n// (Header automatically generated by the ispc compiler.)\n", fn);
25+ fprintf(f, "//\n// \n// (Header automatically generated by the ispc compiler.)\n");
26 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n");
27
28 // Create a nice guard string from the filename, turning any
29@@ -2219,7 +2219,7 @@ bool Module::writeDispatchHeader(DispatchHeaderInfo *DHI) {
30 FILE *f = DHI->file;
31
32 if (DHI->EmitFrontMatter) {
33- fprintf(f, "//\n// %s\n// (Header automatically generated by the ispc compiler.)\n", DHI->fn);
34+ fprintf(f, "//\n// \n// (Header automatically generated by the ispc compiler.)\n");
35 fprintf(f, "// DO NOT EDIT THIS FILE.\n//\n\n");
36 }
37 // Create a nice guard string from the filename, turning any
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
index cfd8e5bc..db674178 100644
--- a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.17.0.bb
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
@@ -14,15 +14,22 @@ S = "${WORKDIR}/git"
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ 14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \ 15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \ 16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Enable-LLVM-15.0-support.patch \ 17 file://0001-Fix-QA-Issues.patch \
18 " 18 "
19SRCREV = "7ad8429369a4d5ced6b524fdfffe623939d8fe9a" 19SRCREV = "f7ec3aa173c816377c215d83196b5c7c3a88db1c"
20 20
21COMPATIBLE_HOST = '(x86_64).*-linux' 21COMPATIBLE_HOST = '(x86_64).*-linux'
22 22
23DEPENDS += " clang-native bison-native " 23DEPENDS += " clang-native bison-native flex-native"
24RDEPENDS:${PN} += " clang-libllvm clang" 24RDEPENDS:${PN} += " clang-libllvm clang"
25 25
26YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
27
28do_configure:prepend() {
29 sed -i -e 's#\${BISON_EXECUTABLE}.*#\${BISON_EXECUTABLE} ${YFLAGS} #g' ${S}/CMakeLists.txt
30 sed -i -e 's#\${FLEX_EXECUTABLE}.*#\${FLEX_EXECUTABLE} \-L #g' ${S}/CMakeLists.txt
31}
32
26EXTRA_OECMAKE += " \ 33EXTRA_OECMAKE += " \
27 -DISPC_INCLUDE_TESTS=OFF \ 34 -DISPC_INCLUDE_TESTS=OFF \
28 -DISPC_INCLUDE_EXAMPLES=OFF \ 35 -DISPC_INCLUDE_EXAMPLES=OFF \
@@ -37,5 +44,4 @@ EXTRA_OECMAKE += " \
37 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \ 44 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \
38 " 45 "
39 46
40TOOLCHAIN = "clang"
41BBCLASSEXTEND = "native nativesdk" 47BBCLASSEXTEND = "native nativesdk"