summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
new file mode 100644
index 00000000..db674178
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-core/ispc/ispc_1.18.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Intel(R) Implicit SPMD Program Compiler"
2DESCRIPTION = "ispc is a compiler for a variant of the C programming language, \
3with extensions for single program, multiple data programming."
4HOMEPAGE = "https://github.com/ispc/ispc"
5
6LICENSE = "BSD-3-Clause & Apache-2.0-with-LLVM-exception"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=da5ecffdd210b3cf776b32b41c182e87 \
8 file://third-party-programs.txt;md5=3cd6f8a7c3bd9d2bb898fcb27c75221a"
9
10inherit cmake python3native
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \
15 file://0001-CMakeLists.txt-link-with-libclang-cpp-library-instea.patch \
16 file://0002-cmake-don-t-build-for-32-bit-targets.patch \
17 file://0001-Fix-QA-Issues.patch \
18 "
19SRCREV = "f7ec3aa173c816377c215d83196b5c7c3a88db1c"
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22
23DEPENDS += " clang-native bison-native flex-native"
24RDEPENDS:${PN} += " clang-libllvm clang"
25
26YFLAGS='-d -t -v -y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}'
27
28do_configure:prepend() {
29 sed -i -e 's#\${BISON_EXECUTABLE}.*#\${BISON_EXECUTABLE} ${YFLAGS} #g' ${S}/CMakeLists.txt
30 sed -i -e 's#\${FLEX_EXECUTABLE}.*#\${FLEX_EXECUTABLE} \-L #g' ${S}/CMakeLists.txt
31}
32
33EXTRA_OECMAKE += " \
34 -DISPC_INCLUDE_TESTS=OFF \
35 -DISPC_INCLUDE_EXAMPLES=OFF \
36 -DISPC_NO_DUMPS=ON \
37 -DARM_ENABLED=OFF \
38 -DISPC_CROSS=ON \
39 -DISPC_ANDROID_TARGET=OFF \
40 -DISPC_FREEBSD_TARGET=OFF \
41 -DISPC_WINDOWS_TARGET=OFF \
42 -DISPC_IOS_TARGET=OFF \
43 -DISPC_PS4_TARGET=OFF \
44 -DSYSROOT_DIR=${STAGING_DIR_NATIVE} \
45 "
46
47BBCLASSEXTEND = "native nativesdk"