summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2020-07-24 10:02:18 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-07-24 10:43:29 +0800
commit50c96ab9d5685726d9fc918315aa49182d609a4d (patch)
tree35587a2726aabed546eec6e594ee24f31b05b2f6
parentb4bc0e45877632d07aaae5c4c26090da52082386 (diff)
downloadmeta-intel-qat-50c96ab9d5685726d9fc918315aa49182d609a4d.tar.gz
qat17: fix the wrong header file when building with kernel v5.8
In kernel v5.8-rc1, commit 228c4f265c6e ("crypto: lib/sha1 - fold linux/cryptohash.h into crypto/sha.h"), cryptohash.h was moved and renamed to sha.h. Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/qat/files/qat17_4.7.0-00006-qat-replace-linux-cryptohash.h-with-crypto-sha.h-for.patch35
-rw-r--r--recipes-extended/qat/qat17_4.7.0-00006.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-extended/qat/files/qat17_4.7.0-00006-qat-replace-linux-cryptohash.h-with-crypto-sha.h-for.patch b/recipes-extended/qat/files/qat17_4.7.0-00006-qat-replace-linux-cryptohash.h-with-crypto-sha.h-for.patch
new file mode 100644
index 0000000..27055ed
--- /dev/null
+++ b/recipes-extended/qat/files/qat17_4.7.0-00006-qat-replace-linux-cryptohash.h-with-crypto-sha.h-for.patch
@@ -0,0 +1,35 @@
1From fcc9a80e47f1a9945987e398626074bddfc705c0 Mon Sep 17 00:00:00 2001
2From: Yongxin Liu <yongxin.liu@windriver.com>
3Date: Fri, 24 Jul 2020 09:27:48 +0800
4Subject: [PATCH] qat: replace linux/cryptohash.h with crypto/sha.h for kernel
5 v5.8
6
7This is to accommodate kernel commit 228c4f265c6e ("crypto:
8lib/sha1 - fold linux/cryptohash.h into crypto/sha.h").
9
10Upstream-Status: Inappropriate [Code released in tarball form only]
11
12Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com>
13---
14 .../utilities/osal/src/linux/kernel_space/OsalCryptoInterface.c | 4 ++++
15 1 file changed, 4 insertions(+)
16
17diff --git a/quickassist/utilities/osal/src/linux/kernel_space/OsalCryptoInterface.c b/quickassist/utilities/osal/src/linux/kernel_space/OsalCryptoInterface.c
18index 2d5b233..92ee35b 100644
19--- a/quickassist/utilities/osal/src/linux/kernel_space/OsalCryptoInterface.c
20+++ b/quickassist/utilities/osal/src/linux/kernel_space/OsalCryptoInterface.c
21@@ -66,7 +66,11 @@
22
23 #include "Osal.h"
24 #include <linux/crypto.h>
25+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5,8,0))
26+#include <crypto/sha.h>
27+#else
28 #include <linux/cryptohash.h>
29+#endif
30 #include <linux/version.h>
31 #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,29))
32 #include <crypto/internal/hash.h>
33--
342.14.4
35
diff --git a/recipes-extended/qat/qat17_4.7.0-00006.bb b/recipes-extended/qat/qat17_4.7.0-00006.bb
index 640525b..047c184 100644
--- a/recipes-extended/qat/qat17_4.7.0-00006.bb
+++ b/recipes-extended/qat/qat17_4.7.0-00006.bb
@@ -24,6 +24,7 @@ SRC_URI = "https://01.org/sites/default/files/downloads/qat1.7.l.4.7.0-00006.tar
24 file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch;apply=0 \ 24 file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch;apply=0 \
25 file://qat17_4.7.0-00006-make-it-compatible-with-kernel-5.6.patch;apply=0 \ 25 file://qat17_4.7.0-00006-make-it-compatible-with-kernel-5.6.patch;apply=0 \
26 file://qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch \ 26 file://qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch \
27 file://qat17_4.7.0-00006-qat-replace-linux-cryptohash.h-with-crypto-sha.h-for.patch \
27 " 28 "
28 29
29do_fetch[depends] += "virtual/kernel:do_shared_workdir" 30do_fetch[depends] += "virtual/kernel:do_shared_workdir"