summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2020-05-31 22:07:56 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-06-01 08:31:55 +0800
commitb4bc0e45877632d07aaae5c4c26090da52082386 (patch)
treec7ac27c71876b11a6e98ff26c4da749683281b7b
parentd5f6e317acbe3d6b0541c2c628568aa36748c064 (diff)
downloadmeta-intel-qat-b4bc0e45877632d07aaae5c4c26090da52082386.tar.gz
qat17: Remove pci_cleanup_aer_uncorrect_error_status() call
AER errors are always cleared by the PCI core and drivers don't need to do it themselves. Reference: Linux kernel commit 62b36c3ea664 ("PCI/AER: Remove pci_cleanup_aer_uncorrect_error_status() calls") Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-extended/qat/files/qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch32
-rw-r--r--recipes-extended/qat/qat17_4.7.0-00006.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-extended/qat/files/qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch b/recipes-extended/qat/files/qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch
new file mode 100644
index 0000000..dc8a53d
--- /dev/null
+++ b/recipes-extended/qat/files/qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch
@@ -0,0 +1,32 @@
1From db44bce60b322754e6a8b96d93218135db00b46a Mon Sep 17 00:00:00 2001
2From: Yongxin Liu <yongxin.liu@windriver.com>
3Date: Sun, 31 May 2020 10:56:27 +0800
4Subject: [PATCH] crypto: qat/adf_aer - Remove
5 pci_cleanup_aer_uncorrect_error_status()
6
7In kernel upstream commit 62b36c3ea664 ("PCI/AER: Remove
8pci_cleanup_aer_uncorrect_error_status() calls"), AER interfaces
9to clear error status registers were removed from device dirver.
10
11Upstream-Status: Inappropriate [Code released in tarball form only]
12
13Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com>
14---
15 quickassist/qat/drivers/crypto/qat/qat_common/adf_aer.c | 1 -
16 1 file changed, 1 deletion(-)
17
18diff --git a/quickassist/qat/drivers/crypto/qat/qat_common/adf_aer.c b/quickassist/qat/drivers/crypto/qat/qat_common/adf_aer.c
19index 5e98b70..3935d77 100644
20--- a/quickassist/qat/drivers/crypto/qat/qat_common/adf_aer.c
21+++ b/quickassist/qat/drivers/crypto/qat/qat_common/adf_aer.c
22@@ -281,7 +281,6 @@ static pci_ers_result_t adf_slot_reset(struct pci_dev *pdev)
23 pr_err("QAT: Can't find acceleration device\n");
24 return PCI_ERS_RESULT_DISCONNECT;
25 }
26- pci_cleanup_aer_uncorrect_error_status(pdev);
27 if (adf_dev_aer_schedule_reset(accel_dev, ADF_DEV_RESET_SYNC))
28 return PCI_ERS_RESULT_DISCONNECT;
29
30--
312.14.4
32
diff --git a/recipes-extended/qat/qat17_4.7.0-00006.bb b/recipes-extended/qat/qat17_4.7.0-00006.bb
index 1d34ce2..640525b 100644
--- a/recipes-extended/qat/qat17_4.7.0-00006.bb
+++ b/recipes-extended/qat/qat17_4.7.0-00006.bb
@@ -23,6 +23,7 @@ SRC_URI = "https://01.org/sites/default/files/downloads/qat1.7.l.4.7.0-00006.tar
23 file://qat17_4.7.0-00006-Drop-pr_warning-definition.patch \ 23 file://qat17_4.7.0-00006-Drop-pr_warning-definition.patch \
24 file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch;apply=0 \ 24 file://qat17_4.7.0-00006-Switch-to-skcipher-API.patch;apply=0 \
25 file://qat17_4.7.0-00006-make-it-compatible-with-kernel-5.6.patch;apply=0 \ 25 file://qat17_4.7.0-00006-make-it-compatible-with-kernel-5.6.patch;apply=0 \
26 file://qat17_4.7.0-00006-crypto-qat-adf_aer-Remove-pci_cleanup_aer_uncorrect_.patch \
26 " 27 "
27 28
28do_fetch[depends] += "virtual/kernel:do_shared_workdir" 29do_fetch[depends] += "virtual/kernel:do_shared_workdir"