summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-29 23:59:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-30 00:02:10 +0100
commit80747190ccce6628ce8815cf856f6ab867a00b5d (patch)
tree07be151fe85a5cf4207b8606fbe566e339e105e5 /recipes-extended
parent27eafbb395fd4f607249b2e57085012e40283926 (diff)
downloadmeta-gplv2-80747190ccce6628ce8815cf856f6ab867a00b5d.tar.gz
meta-gplv2: Convert to new override syntax
This converts the layer to the new override syntax. This was done using <oe-core>/scripts/contrib/convert-overrides.py <this-layer> with no manual fixes. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/bash/bash.inc22
-rw-r--r--recipes-extended/bc/bc_1.06.bb2
-rw-r--r--recipes-extended/cpio/cpio_v2.inc6
-rw-r--r--recipes-extended/diffutils/diffutils.inc2
-rw-r--r--recipes-extended/diffutils/diffutils_2.8.1.bb2
-rw-r--r--recipes-extended/ed/ed_0.5.bb6
-rw-r--r--recipes-extended/findutils/findutils.inc2
-rw-r--r--recipes-extended/gawk/gawk_3.1.5.bb14
-rw-r--r--recipes-extended/gperf/gperf.inc2
-rw-r--r--recipes-extended/grep/grep_2.5.1a.bb6
-rw-r--r--recipes-extended/groff/groff_1.18.1.4.bb4
-rw-r--r--recipes-extended/gzip/gzip.inc8
-rw-r--r--recipes-extended/libidn/libidn_0.6.14.bb4
-rw-r--r--recipes-extended/mc/mc_4.7.5.2.bb18
-rw-r--r--recipes-extended/msmtp/msmtp_1.4.12.bb4
-rw-r--r--recipes-extended/sed/sed_4.1.2.bb4
-rw-r--r--recipes-extended/tar/tar.inc14
-rw-r--r--recipes-extended/texinfo/texinfo_4.8.bb18
-rw-r--r--recipes-extended/time/time_1.7.bb2
-rw-r--r--recipes-extended/which/which_2.18.bb4
20 files changed, 72 insertions, 72 deletions
diff --git a/recipes-extended/bash/bash.inc b/recipes-extended/bash/bash.inc
index 0f0d679..4767618 100644
--- a/recipes-extended/bash/bash.inc
+++ b/recipes-extended/bash/bash.inc
@@ -14,21 +14,21 @@ EXTRA_OECONF = "--enable-job-control --without-bash-malloc"
14# This is what other major distros do. And this is what we wanted. See bug#5359 and bug#7137. 14# This is what other major distros do. And this is what we wanted. See bug#5359 and bug#7137.
15CFLAGS += "-DNON_INTERACTIVE_LOGIN_SHELLS" 15CFLAGS += "-DNON_INTERACTIVE_LOGIN_SHELLS"
16 16
17ALTERNATIVE_${PN} = "bash sh" 17ALTERNATIVE:${PN} = "bash sh"
18ALTERNATIVE_LINK_NAME[bash] = "${base_bindir}/bash" 18ALTERNATIVE_LINK_NAME[bash] = "${base_bindir}/bash"
19ALTERNATIVE_TARGET[bash] = "${base_bindir}/bash" 19ALTERNATIVE_TARGET[bash] = "${base_bindir}/bash"
20ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh" 20ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
21ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash.${BPN}" 21ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash.${BPN}"
22ALTERNATIVE_PRIORITY = "100" 22ALTERNATIVE_PRIORITY = "100"
23 23
24RDEPENDS_${PN} += "base-files" 24RDEPENDS:${PN} += "base-files"
25RDEPENDS_${PN}_class-nativesdk = "" 25RDEPENDS:${PN}:class-nativesdk = ""
26RDEPENDS_${PN}-ptest += "make" 26RDEPENDS:${PN}-ptest += "make"
27 27
28USERADD_PACKAGES = "${PN}-ptest" 28USERADD_PACKAGES = "${PN}-ptest"
29USERADD_PARAM_${PN}-ptest = "--create-home --user-group test" 29USERADD_PARAM:${PN}-ptest = "--create-home --user-group test"
30 30
31do_configure_prepend () { 31do_configure:prepend () {
32 if [ ! -e ${S}/acinclude.m4 ]; then 32 if [ ! -e ${S}/acinclude.m4 ]; then
33 cat ${S}/aclocal.m4 > ${S}/acinclude.m4 33 cat ${S}/aclocal.m4 > ${S}/acinclude.m4
34 fi 34 fi
@@ -38,14 +38,14 @@ do_compile_ptest () {
38 oe_runmake buildtest 38 oe_runmake buildtest
39} 39}
40 40
41do_install_append () { 41do_install:append () {
42 # Move /usr/bin/bash to /bin/bash, if need 42 # Move /usr/bin/bash to /bin/bash, if need
43 if [ "${base_bindir}" != "${bindir}" ]; then 43 if [ "${base_bindir}" != "${bindir}" ]; then
44 mkdir -p ${D}${base_bindir} 44 mkdir -p ${D}${base_bindir}
45 mv ${D}${bindir}/bash ${D}${base_bindir} 45 mv ${D}${bindir}/bash ${D}${base_bindir}
46 fi 46 fi
47} 47}
48do_install_append_class-target () { 48do_install:append:class-target () {
49 # Clean host path in bashbug 49 # Clean host path in bashbug
50 sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \ 50 sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
51 -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug 51 -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
@@ -58,12 +58,12 @@ do_install_ptest () {
58 -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile 58 -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
59} 59}
60 60
61pkg_postinst_${PN} () { 61pkg_postinst:${PN} () {
62 grep -q "^${base_bindir}/bash$" $D${sysconfdir}/shells || echo ${base_bindir}/bash >> $D${sysconfdir}/shells 62 grep -q "^${base_bindir}/bash$" $D${sysconfdir}/shells || echo ${base_bindir}/bash >> $D${sysconfdir}/shells
63} 63}
64 64
65pkg_postrm_${PN} () { 65pkg_postrm:${PN} () {
66 printf "$(grep -v "^${base_bindir}/bash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells 66 printf "$(grep -v "^${base_bindir}/bash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
67} 67}
68 68
69RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}" 69RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}"
diff --git a/recipes-extended/bc/bc_1.06.bb b/recipes-extended/bc/bc_1.06.bb
index 3de1b24..82143a4 100644
--- a/recipes-extended/bc/bc_1.06.bb
+++ b/recipes-extended/bc/bc_1.06.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea7
20 20
21inherit autotools texinfo update-alternatives 21inherit autotools texinfo update-alternatives
22 22
23ALTERNATIVE_${PN} = "bc dc" 23ALTERNATIVE:${PN} = "bc dc"
24ALTERNATIVE_PRIORITY = "100" 24ALTERNATIVE_PRIORITY = "100"
25 25
26BBCLASSEXTEND = "native" 26BBCLASSEXTEND = "native"
diff --git a/recipes-extended/cpio/cpio_v2.inc b/recipes-extended/cpio/cpio_v2.inc
index 31adb71..f202d5f 100644
--- a/recipes-extended/cpio/cpio_v2.inc
+++ b/recipes-extended/cpio/cpio_v2.inc
@@ -26,14 +26,14 @@ do_install () {
26 26
27PACKAGES =+ "${PN}-rmt" 27PACKAGES =+ "${PN}-rmt"
28 28
29FILES_${PN}-rmt = "${base_sbindir}/rmt*" 29FILES:${PN}-rmt = "${base_sbindir}/rmt*"
30 30
31inherit update-alternatives 31inherit update-alternatives
32 32
33ALTERNATIVE_PRIORITY = "100" 33ALTERNATIVE_PRIORITY = "100"
34 34
35ALTERNATIVE_${PN} = "cpio" 35ALTERNATIVE:${PN} = "cpio"
36ALTERNATIVE_${PN}-rmt = "rmt" 36ALTERNATIVE:${PN}-rmt = "rmt"
37 37
38ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" 38ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
39 39
diff --git a/recipes-extended/diffutils/diffutils.inc b/recipes-extended/diffutils/diffutils.inc
index c81348b..08ebaa9 100644
--- a/recipes-extended/diffutils/diffutils.inc
+++ b/recipes-extended/diffutils/diffutils.inc
@@ -6,6 +6,6 @@ SECTION = "base"
6 6
7inherit autotools texinfo update-alternatives gettext 7inherit autotools texinfo update-alternatives gettext
8 8
9ALTERNATIVE_${PN} = "diff cmp" 9ALTERNATIVE:${PN} = "diff cmp"
10ALTERNATIVE_PRIORITY = "100" 10ALTERNATIVE_PRIORITY = "100"
11 11
diff --git a/recipes-extended/diffutils/diffutils_2.8.1.bb b/recipes-extended/diffutils/diffutils_2.8.1.bb
index 7c43c4b..6e48dc6 100644
--- a/recipes-extended/diffutils/diffutils_2.8.1.bb
+++ b/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -21,6 +21,6 @@ CACHED_CONFIGUREVARS = "\
21 jm_cv_func_working_realloc=yes \ 21 jm_cv_func_working_realloc=yes \
22" 22"
23 23
24do_configure_prepend () { 24do_configure:prepend () {
25 chmod u+w ${S}/po/Makefile.in.in 25 chmod u+w ${S}/po/Makefile.in.in
26} 26}
diff --git a/recipes-extended/ed/ed_0.5.bb b/recipes-extended/ed/ed_0.5.bb
index e2df13f..8305e6b 100644
--- a/recipes-extended/ed/ed_0.5.bb
+++ b/recipes-extended/ed/ed_0.5.bb
@@ -15,6 +15,6 @@ inherit autotools texinfo
15 15
16EXTRA_OECONF = "'CC=${CC}' 'CXX=${CXX}' 'CFLAGS=${CFLAGS}' 'CXXFLAGS=${CXXFLAGS}' 'CPPFLAGS=${CPPFLAGS}' 'LDFLAGS=${LDFLAGS}'" 16EXTRA_OECONF = "'CC=${CC}' 'CXX=${CXX}' 'CFLAGS=${CFLAGS}' 'CXXFLAGS=${CXXFLAGS}' 'CPPFLAGS=${CPPFLAGS}' 'LDFLAGS=${LDFLAGS}'"
17 17
18CONFIGUREOPTS_remove = "--disable-dependency-tracking" 18CONFIGUREOPTS:remove = "--disable-dependency-tracking"
19CONFIGUREOPTS_remove = "--disable-silent-rules" 19CONFIGUREOPTS:remove = "--disable-silent-rules"
20EXTRA_OECONF_remove = "--disable-static" 20EXTRA_OECONF:remove = "--disable-static"
diff --git a/recipes-extended/findutils/findutils.inc b/recipes-extended/findutils/findutils.inc
index ad36429..8887675 100644
--- a/recipes-extended/findutils/findutils.inc
+++ b/recipes-extended/findutils/findutils.inc
@@ -10,7 +10,7 @@ SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
10 10
11inherit autotools gettext texinfo update-alternatives upstream-version-is-even 11inherit autotools gettext texinfo update-alternatives upstream-version-is-even
12 12
13ALTERNATIVE_${PN} = "find xargs" 13ALTERNATIVE:${PN} = "find xargs"
14ALTERNATIVE_PRIORITY = "100" 14ALTERNATIVE_PRIORITY = "100"
15 15
16BBCLASSEXTEND = "native nativesdk" 16BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/gawk/gawk_3.1.5.bb b/recipes-extended/gawk/gawk_3.1.5.bb
index 63fd32f..933c140 100644
--- a/recipes-extended/gawk/gawk_3.1.5.bb
+++ b/recipes-extended/gawk/gawk_3.1.5.bb
@@ -11,8 +11,8 @@ SECTION = "console/utils"
11LICENSE = "GPLv2" 11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 12LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
13 13
14RDEPENDS_gawk += "gawk-common" 14RDEPENDS:gawk += "gawk-common"
15RDEPENDS_pgawk += "gawk-common" 15RDEPENDS:pgawk += "gawk-common"
16PR = "r2" 16PR = "r2"
17 17
18SRC_URI = "\ 18SRC_URI = "\
@@ -28,17 +28,17 @@ inherit autotools gettext texinfo update-alternatives
28 28
29PACKAGES += "gawk-common pgawk" 29PACKAGES += "gawk-common pgawk"
30 30
31FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk" 31FILES:${PN} = "${bindir}/gawk* ${bindir}/igawk"
32FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*" 32FILES:gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
33FILES_pgawk = "${bindir}/pgawk*" 33FILES:pgawk = "${bindir}/pgawk*"
34 34
35ALTERNATIVE_${PN} = "awk" 35ALTERNATIVE:${PN} = "awk"
36ALTERNATIVE_TARGET[awk] = "${bindir}/gawk" 36ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
37ALTERNATIVE_PRIORITY = "100" 37ALTERNATIVE_PRIORITY = "100"
38 38
39CFLAGS += "-D PROTOTYPES" 39CFLAGS += "-D PROTOTYPES"
40 40
41do_install_append() { 41do_install:append() {
42 # remove the link since we don't package it 42 # remove the link since we don't package it
43 rm ${D}${bindir}/awk 43 rm ${D}${bindir}/awk
44} 44}
diff --git a/recipes-extended/gperf/gperf.inc b/recipes-extended/gperf/gperf.inc
index a8ce230..10738e4 100644
--- a/recipes-extended/gperf/gperf.inc
+++ b/recipes-extended/gperf/gperf.inc
@@ -13,7 +13,7 @@ inherit autotools
13# duplicating acinclude.m4 in every subdirectory, use absolute include path to aclocal 13# duplicating acinclude.m4 in every subdirectory, use absolute include path to aclocal
14EXTRA_AUTORECONF += " -I ${S}" 14EXTRA_AUTORECONF += " -I ${S}"
15 15
16do_configure_prepend() { 16do_configure:prepend() {
17 if [ ! -e ${S}/acinclude.m4 ]; then 17 if [ ! -e ${S}/acinclude.m4 ]; then
18 cat ${S}/aclocal.m4 > ${S}/acinclude.m4 18 cat ${S}/aclocal.m4 > ${S}/acinclude.m4
19 fi 19 fi
diff --git a/recipes-extended/grep/grep_2.5.1a.bb b/recipes-extended/grep/grep_2.5.1a.bb
index 5445c7e..1a3231e 100644
--- a/recipes-extended/grep/grep_2.5.1a.bb
+++ b/recipes-extended/grep/grep_2.5.1a.bb
@@ -27,13 +27,13 @@ SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92b
27inherit autotools gettext texinfo 27inherit autotools gettext texinfo
28 28
29EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex" 29EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex"
30EXTRA_OECONF_INCLUDED_REGEX_libc-musl = "--with-included-regex" 30EXTRA_OECONF_INCLUDED_REGEX:libc-musl = "--with-included-regex"
31 31
32EXTRA_OECONF = "--disable-perl-regexp \ 32EXTRA_OECONF = "--disable-perl-regexp \
33 ${EXTRA_OECONF_INCLUDED_REGEX}" 33 ${EXTRA_OECONF_INCLUDED_REGEX}"
34 34
35CFLAGS += "-D PROTOTYPES" 35CFLAGS += "-D PROTOTYPES"
36do_configure_prepend () { 36do_configure:prepend () {
37 rm -f ${S}/m4/init.m4 37 rm -f ${S}/m4/init.m4
38 cp -f ${WORKDIR}/Makevars ${S}/po/ 38 cp -f ${WORKDIR}/Makevars ${S}/po/
39} 39}
@@ -53,7 +53,7 @@ inherit update-alternatives
53 53
54ALTERNATIVE_PRIORITY = "100" 54ALTERNATIVE_PRIORITY = "100"
55 55
56ALTERNATIVE_${PN} = "grep egrep fgrep" 56ALTERNATIVE:${PN} = "grep egrep fgrep"
57ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" 57ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
58ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" 58ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
59ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" 59ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
diff --git a/recipes-extended/groff/groff_1.18.1.4.bb b/recipes-extended/groff/groff_1.18.1.4.bb
index a31cbf1..84b0d78 100644
--- a/recipes-extended/groff/groff_1.18.1.4.bb
+++ b/recipes-extended/groff/groff_1.18.1.4.bb
@@ -30,7 +30,7 @@ do_configure (){
30 oe_runconf 30 oe_runconf
31} 31}
32 32
33do_install_append() { 33do_install:append() {
34 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location 34 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
35 # for target as /usr/bin/perl, so fix it to /usr/bin/perl. 35 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
36 for i in afmtodit mmroff; do 36 for i in afmtodit mmroff; do
@@ -44,7 +44,7 @@ do_install_append() {
44 cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/ 44 cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/
45} 45}
46 46
47pkg_postinst_${PN}() { 47pkg_postinst:${PN}() {
48 ln -s tbl $D${bindir}/gtbl 48 ln -s tbl $D${bindir}/gtbl
49 echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> $D${sysconfdir}/profile 49 echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> $D${sysconfdir}/profile
50 echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> $D${sysconfdir}/profile 50 echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> $D${sysconfdir}/profile
diff --git a/recipes-extended/gzip/gzip.inc b/recipes-extended/gzip/gzip.inc
index 04f8f95..15fd665 100644
--- a/recipes-extended/gzip/gzip.inc
+++ b/recipes-extended/gzip/gzip.inc
@@ -8,10 +8,10 @@ SECTION = "console/utils"
8inherit autotools texinfo 8inherit autotools texinfo
9export DEFS="NO_ASM" 9export DEFS="NO_ASM"
10 10
11EXTRA_OEMAKE_class-target = "GREP=${base_bindir}/grep" 11EXTRA_OEMAKE:class-target = "GREP=${base_bindir}/grep"
12EXTRA_OECONF_append_libc-musl = " gl_cv_func_fflush_stdin=yes " 12EXTRA_OECONF:append:libc-musl = " gl_cv_func_fflush_stdin=yes "
13 13
14do_install_append () { 14do_install:append () {
15 if [ "${base_bindir}" != "${bindir}" ]; then 15 if [ "${base_bindir}" != "${bindir}" ]; then
16 # Rename and move files into /bin (FHS), which is typical place for gzip 16 # Rename and move files into /bin (FHS), which is typical place for gzip
17 install -d ${D}${base_bindir} 17 install -d ${D}${base_bindir}
@@ -25,7 +25,7 @@ do_install_append () {
25inherit update-alternatives 25inherit update-alternatives
26 26
27ALTERNATIVE_PRIORITY = "100" 27ALTERNATIVE_PRIORITY = "100"
28ALTERNATIVE_${PN} = "gunzip gzip zcat" 28ALTERNATIVE:${PN} = "gunzip gzip zcat"
29ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip" 29ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
30ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip" 30ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
31ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat" 31ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
diff --git a/recipes-extended/libidn/libidn_0.6.14.bb b/recipes-extended/libidn/libidn_0.6.14.bb
index c681560..dfd9c6e 100644
--- a/recipes-extended/libidn/libidn_0.6.14.bb
+++ b/recipes-extended/libidn/libidn_0.6.14.bb
@@ -16,7 +16,7 @@ SRC_URI = "http://alpha.gnu.org/gnu/libidn/${BPN}-${PV}.tar.gz"
16SRC_URI[md5sum] = "040f012a45feb56168853998bb87ad4d" 16SRC_URI[md5sum] = "040f012a45feb56168853998bb87ad4d"
17SRC_URI[sha256sum] = "98910c2ad664bdf4eed2c2fff88e24f8882636ec9d26669366ff03b469c05ae3" 17SRC_URI[sha256sum] = "98910c2ad664bdf4eed2c2fff88e24f8882636ec9d26669366ff03b469c05ae3"
18 18
19do_configure_prepend() { 19do_configure:prepend() {
20 # this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from 20 # this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from
21 # autoconf CVS because atm the autoconf it uses is a bit old 21 # autoconf CVS because atm the autoconf it uses is a bit old
22 # now with cross autotool, that macro is already there and this 22 # now with cross autotool, that macro is already there and this
@@ -27,7 +27,7 @@ do_configure_prepend() {
27 rm -f ${S}/lib/gl/m4/extensions.m4 27 rm -f ${S}/lib/gl/m4/extensions.m4
28} 28}
29 29
30do_install_append() { 30do_install:append() {
31 rm -rf ${D}${libdir}/Libidn.dll 31 rm -rf ${D}${libdir}/Libidn.dll
32 rm -rf ${D}${datadir}/emacs 32 rm -rf ${D}${datadir}/emacs
33} 33}
diff --git a/recipes-extended/mc/mc_4.7.5.2.bb b/recipes-extended/mc/mc_4.7.5.2.bb
index 5f56641..2d30fe7 100644
--- a/recipes-extended/mc/mc_4.7.5.2.bb
+++ b/recipes-extended/mc/mc_4.7.5.2.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "console/utils" 5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0" 6DEPENDS = "ncurses glib-2.0"
7RDEPENDS_${PN} = "ncurses-terminfo" 7RDEPENDS:${PN} = "ncurses-terminfo"
8 8
9PR = "r3" 9PR = "r3"
10 10
@@ -21,7 +21,7 @@ inherit autotools gettext pkgconfig
21 21
22EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba" 22EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-samba"
23 23
24do_install_append () { 24do_install:append () {
25 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/* 25 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
26 # These use python2 which is no longer supported 26 # These use python2 which is no longer supported
27 rm ${D}${libexecdir}/mc/extfs.d/s3+ 27 rm ${D}${libexecdir}/mc/extfs.d/s3+
@@ -30,18 +30,18 @@ do_install_append () {
30 30
31PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish" 31PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
32 32
33SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts" 33SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
34FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \ 34FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
35 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \ 35 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
36 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \ 36 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
37 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \ 37 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
38 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \ 38 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
39 ${libexecdir}/mc/extfs.d/uzip" 39 ${libexecdir}/mc/extfs.d/uzip"
40RDEPENDS_${BPN}-helpers-perl = "perl" 40RDEPENDS:${BPN}-helpers-perl = "perl"
41 41
42SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts" 42SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
43FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*" 43FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
44 44
45SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts" 45SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
46FILES_${BPN}-fish = "${libexecdir}/mc/fish" 46FILES:${BPN}-fish = "${libexecdir}/mc/fish"
47 47
diff --git a/recipes-extended/msmtp/msmtp_1.4.12.bb b/recipes-extended/msmtp/msmtp_1.4.12.bb
index e03d432..21d9f81 100644
--- a/recipes-extended/msmtp/msmtp_1.4.12.bb
+++ b/recipes-extended/msmtp/msmtp_1.4.12.bb
@@ -24,12 +24,12 @@ PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
24 24
25inherit gettext autotools update-alternatives 25inherit gettext autotools update-alternatives
26 26
27ALTERNATIVE_${PN} = "sendmail" 27ALTERNATIVE:${PN} = "sendmail"
28ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp" 28ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
29ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail" 29ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
30ALTERNATIVE_PRIORITY = "100" 30ALTERNATIVE_PRIORITY = "100"
31 31
32pkg_postinst_${PN}_linuxstdbase () { 32pkg_postinst:${PN}:linuxstdbase () {
33 # /usr/lib/sendmail is required by LSB specification 33 # /usr/lib/sendmail is required by LSB specification
34 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib 34 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib
35} 35}
diff --git a/recipes-extended/sed/sed_4.1.2.bb b/recipes-extended/sed/sed_4.1.2.bb
index 4a58442..24f479e 100644
--- a/recipes-extended/sed/sed_4.1.2.bb
+++ b/recipes-extended/sed/sed_4.1.2.bb
@@ -18,7 +18,7 @@ SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93
18 18
19inherit autotools texinfo update-alternatives gettext 19inherit autotools texinfo update-alternatives gettext
20 20
21do_configure_prepend () { 21do_configure:prepend () {
22 cp ${WORKDIR}/Makevars ${S}/po/ 22 cp ${WORKDIR}/Makevars ${S}/po/
23} 23}
24 24
@@ -31,7 +31,7 @@ do_install () {
31 fi 31 fi
32} 32}
33 33
34ALTERNATIVE_${PN} = "sed" 34ALTERNATIVE:${PN} = "sed"
35ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed" 35ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
36ALTERNATIVE_PRIORITY = "100" 36ALTERNATIVE_PRIORITY = "100"
37 37
diff --git a/recipes-extended/tar/tar.inc b/recipes-extended/tar/tar.inc
index 93e4da1..e035fa6 100644
--- a/recipes-extended/tar/tar.inc
+++ b/recipes-extended/tar/tar.inc
@@ -21,7 +21,7 @@ do_install () {
21 ln -s tar ${D}${bindir}/gtar 21 ln -s tar ${D}${bindir}/gtar
22} 22}
23 23
24do_install_append_class-target() { 24do_install:append:class-target() {
25 if [ "${base_bindir}" != "${bindir}" ]; then 25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir} 26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/tar ${D}${base_bindir}/tar 27 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
@@ -32,21 +32,21 @@ do_install_append_class-target() {
32 32
33PACKAGES =+ "${PN}-rmt" 33PACKAGES =+ "${PN}-rmt"
34 34
35FILES_${PN}-rmt = "${base_sbindir}/rmt*" 35FILES:${PN}-rmt = "${base_sbindir}/rmt*"
36 36
37inherit update-alternatives 37inherit update-alternatives
38 38
39ALTERNATIVE_PRIORITY = "100" 39ALTERNATIVE_PRIORITY = "100"
40 40
41ALTERNATIVE_${PN} = "tar" 41ALTERNATIVE:${PN} = "tar"
42ALTERNATIVE_${PN}-rmt = "rmt" 42ALTERNATIVE:${PN}-rmt = "rmt"
43ALTERNATIVE_${PN}_class-nativesdk = "" 43ALTERNATIVE:${PN}:class-nativesdk = ""
44ALTERNATIVE_${PN}-rmt_class-nativesdk = "" 44ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
45 45
46ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" 46ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
47ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt" 47ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
48 48
49PROVIDES_append_class-native = " tar-replacement-native" 49PROVIDES:append:class-native = " tar-replacement-native"
50NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" 50NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
51 51
52BBCLASSEXTEND = "native nativesdk" 52BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/texinfo/texinfo_4.8.bb b/recipes-extended/texinfo/texinfo_4.8.bb
index 13678e0..ea269cc 100644
--- a/recipes-extended/texinfo/texinfo_4.8.bb
+++ b/recipes-extended/texinfo/texinfo_4.8.bb
@@ -7,15 +7,15 @@ SECTION = "console/utils"
7LICENSE = "GPLv2" 7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9 9
10PROVIDES_append_class-native = " texinfo-4.8-replacement-native" 10PROVIDES:append:class-native = " texinfo-4.8-replacement-native"
11 11
12DEPENDS = "zlib ncurses texinfo-4.8-replacement-native" 12DEPENDS = "zlib ncurses texinfo-4.8-replacement-native"
13DEPENDS_class-native = "zlib-native ncurses-native" 13DEPENDS:class-native = "zlib-native ncurses-native"
14 14
15TARGET_PATCH = "file://use_host_makedoc.patch \ 15TARGET_PATCH = "file://use_host_makedoc.patch \
16 file://using-native-makeinfo.patch \ 16 file://using-native-makeinfo.patch \
17" 17"
18TARGET_PATCH_class-native = "" 18TARGET_PATCH:class-native = ""
19 19
20SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \ 20SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
21 file://check-locale-h.patch \ 21 file://check-locale-h.patch \
@@ -30,25 +30,25 @@ tex_texinfo = "texmf/tex/texinfo"
30 30
31inherit gettext autotools 31inherit gettext autotools
32 32
33do_install_append() { 33do_install:append() {
34 mkdir -p ${D}${datadir}/${tex_texinfo} 34 mkdir -p ${D}${datadir}/${tex_texinfo}
35 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo} 35 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
36} 36}
37 37
38do_install_append_class-native() { 38do_install:append:class-native() {
39 install -m 755 info/makedoc ${D}${bindir} 39 install -m 755 info/makedoc ${D}${bindir}
40 install -m 755 makeinfo/makeinfo ${D}${bindir} 40 install -m 755 makeinfo/makeinfo ${D}${bindir}
41} 41}
42 42
43PACKAGES += "info info-doc" 43PACKAGES += "info info-doc"
44 44
45FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info" 45FILES:info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
46FILES_info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \ 46FILES:info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \
47 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \ 47 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
48 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*" 48 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
49 49
50FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo" 50FILES:${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
51FILES_${PN}-doc = "${infodir}/texinfo* \ 51FILES:${PN}-doc = "${infodir}/texinfo* \
52 ${datadir}/${tex_texinfo} \ 52 ${datadir}/${tex_texinfo} \
53 ${mandir}/man1 ${mandir}/man5" 53 ${mandir}/man1 ${mandir}/man5"
54 54
diff --git a/recipes-extended/time/time_1.7.bb b/recipes-extended/time/time_1.7.bb
index e5713db..ccc7788 100644
--- a/recipes-extended/time/time_1.7.bb
+++ b/recipes-extended/time/time_1.7.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
8 8
9inherit texinfo update-alternatives 9inherit texinfo update-alternatives
10 10
11ALTERNATIVE_${PN} = "time" 11ALTERNATIVE:${PN} = "time"
12ALTERNATIVE_PRIORITY = "100" 12ALTERNATIVE_PRIORITY = "100"
13 13
14BBCLASSEXTEND = "native nativesdk" 14BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-extended/which/which_2.18.bb b/recipes-extended/which/which_2.18.bb
index eb6cc99..63b43c4 100644
--- a/recipes-extended/which/which_2.18.bb
+++ b/recipes-extended/which/which_2.18.bb
@@ -23,12 +23,12 @@ DEPENDS = "cwautomacros-native"
23 23
24inherit autotools texinfo update-alternatives 24inherit autotools texinfo update-alternatives
25 25
26do_configure_prepend() { 26do_configure:prepend() {
27 OLD="@ACLOCAL_CWFLAGS@" 27 OLD="@ACLOCAL_CWFLAGS@"
28 NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4" 28 NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4"
29 sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}` 29 sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}`
30} 30}
31 31
32ALTERNATIVE_${PN} = "which" 32ALTERNATIVE:${PN} = "which"
33ALTERNATIVE_PRIORITY = "100" 33ALTERNATIVE_PRIORITY = "100"
34 34