summaryrefslogtreecommitdiffstats
path: root/recipes-extended/bash/bash.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/bash/bash.inc')
-rw-r--r--recipes-extended/bash/bash.inc22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-extended/bash/bash.inc b/recipes-extended/bash/bash.inc
index 0f0d679..4767618 100644
--- a/recipes-extended/bash/bash.inc
+++ b/recipes-extended/bash/bash.inc
@@ -14,21 +14,21 @@ EXTRA_OECONF = "--enable-job-control --without-bash-malloc"
14# This is what other major distros do. And this is what we wanted. See bug#5359 and bug#7137. 14# This is what other major distros do. And this is what we wanted. See bug#5359 and bug#7137.
15CFLAGS += "-DNON_INTERACTIVE_LOGIN_SHELLS" 15CFLAGS += "-DNON_INTERACTIVE_LOGIN_SHELLS"
16 16
17ALTERNATIVE_${PN} = "bash sh" 17ALTERNATIVE:${PN} = "bash sh"
18ALTERNATIVE_LINK_NAME[bash] = "${base_bindir}/bash" 18ALTERNATIVE_LINK_NAME[bash] = "${base_bindir}/bash"
19ALTERNATIVE_TARGET[bash] = "${base_bindir}/bash" 19ALTERNATIVE_TARGET[bash] = "${base_bindir}/bash"
20ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh" 20ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
21ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash.${BPN}" 21ALTERNATIVE_TARGET[sh] = "${base_bindir}/bash.${BPN}"
22ALTERNATIVE_PRIORITY = "100" 22ALTERNATIVE_PRIORITY = "100"
23 23
24RDEPENDS_${PN} += "base-files" 24RDEPENDS:${PN} += "base-files"
25RDEPENDS_${PN}_class-nativesdk = "" 25RDEPENDS:${PN}:class-nativesdk = ""
26RDEPENDS_${PN}-ptest += "make" 26RDEPENDS:${PN}-ptest += "make"
27 27
28USERADD_PACKAGES = "${PN}-ptest" 28USERADD_PACKAGES = "${PN}-ptest"
29USERADD_PARAM_${PN}-ptest = "--create-home --user-group test" 29USERADD_PARAM:${PN}-ptest = "--create-home --user-group test"
30 30
31do_configure_prepend () { 31do_configure:prepend () {
32 if [ ! -e ${S}/acinclude.m4 ]; then 32 if [ ! -e ${S}/acinclude.m4 ]; then
33 cat ${S}/aclocal.m4 > ${S}/acinclude.m4 33 cat ${S}/aclocal.m4 > ${S}/acinclude.m4
34 fi 34 fi
@@ -38,14 +38,14 @@ do_compile_ptest () {
38 oe_runmake buildtest 38 oe_runmake buildtest
39} 39}
40 40
41do_install_append () { 41do_install:append () {
42 # Move /usr/bin/bash to /bin/bash, if need 42 # Move /usr/bin/bash to /bin/bash, if need
43 if [ "${base_bindir}" != "${bindir}" ]; then 43 if [ "${base_bindir}" != "${bindir}" ]; then
44 mkdir -p ${D}${base_bindir} 44 mkdir -p ${D}${base_bindir}
45 mv ${D}${bindir}/bash ${D}${base_bindir} 45 mv ${D}${bindir}/bash ${D}${base_bindir}
46 fi 46 fi
47} 47}
48do_install_append_class-target () { 48do_install:append:class-target () {
49 # Clean host path in bashbug 49 # Clean host path in bashbug
50 sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \ 50 sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
51 -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug 51 -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
@@ -58,12 +58,12 @@ do_install_ptest () {
58 -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile 58 -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
59} 59}
60 60
61pkg_postinst_${PN} () { 61pkg_postinst:${PN} () {
62 grep -q "^${base_bindir}/bash$" $D${sysconfdir}/shells || echo ${base_bindir}/bash >> $D${sysconfdir}/shells 62 grep -q "^${base_bindir}/bash$" $D${sysconfdir}/shells || echo ${base_bindir}/bash >> $D${sysconfdir}/shells
63} 63}
64 64
65pkg_postrm_${PN} () { 65pkg_postrm:${PN} () {
66 printf "$(grep -v "^${base_bindir}/bash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells 66 printf "$(grep -v "^${base_bindir}/bash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
67} 67}
68 68
69RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}" 69RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/sh /bin/bash', '', d)}"