summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-29 23:59:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-30 00:02:10 +0100
commit80747190ccce6628ce8815cf856f6ab867a00b5d (patch)
tree07be151fe85a5cf4207b8606fbe566e339e105e5 /recipes-devtools
parent27eafbb395fd4f607249b2e57085012e40283926 (diff)
downloadmeta-gplv2-80747190ccce6628ce8815cf856f6ab867a00b5d.tar.gz
meta-gplv2: Convert to new override syntax
This converts the layer to the new override syntax. This was done using <oe-core>/scripts/contrib/convert-overrides.py <this-layer> with no manual fixes. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/bison/bison_2.3.bb2
-rw-r--r--recipes-devtools/elfutils/elfutils_0.148.bb24
-rw-r--r--recipes-devtools/m4/m4-1.4.9.inc2
-rw-r--r--recipes-devtools/mtools/mtools_3.9.9.bb6
-rw-r--r--recipes-devtools/patch/patch.inc2
-rw-r--r--recipes-devtools/rsync/rsync.inc2
6 files changed, 19 insertions, 19 deletions
diff --git a/recipes-devtools/bison/bison_2.3.bb b/recipes-devtools/bison/bison_2.3.bb
index 182e880..c84fd9a 100644
--- a/recipes-devtools/bison/bison_2.3.bb
+++ b/recipes-devtools/bison/bison_2.3.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "52f78aa4761a74ceb7fdf770f3554dd84308c3b93c4255e3a5c17558ec
20inherit autotools gettext texinfo 20inherit autotools gettext texinfo
21acpaths = "-I ${S}/m4" 21acpaths = "-I ${S}/m4"
22 22
23do_configure_prepend () { 23do_configure:prepend () {
24 rm -f ${S}/m4/*gl.m4 24 rm -f ${S}/m4/*gl.m4
25 cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/ 25 cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/
26} 26}
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bb b/recipes-devtools/elfutils/elfutils_0.148.bb
index 3c0f9f0..848e2cf 100644
--- a/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -42,11 +42,11 @@ SRC_URI += "\
42" 42"
43 43
44# Only apply when building musl based target recipe 44# Only apply when building musl based target recipe
45SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch" 45SRC_URI:append:libc-musl = " file://musl-support-for-elfutils-0.148.patch"
46 46
47# The buildsystem wants to generate 2 .h files from source using a binary it just built, 47# The buildsystem wants to generate 2 .h files from source using a binary it just built,
48# which can not pass the cross compiling, so let's work around it by adding 2 .h files 48# which can not pass the cross compiling, so let's work around it by adding 2 .h files
49# along with the do_configure_prepend() 49# along with the do_configure:prepend()
50 50
51SRC_URI += "\ 51SRC_URI += "\
52 file://i386_dis.h \ 52 file://i386_dis.h \
@@ -67,9 +67,9 @@ CFLAGS += "-Wno-error=format-truncation="
67CFLAGS += "-Wno-error=stringop-overflow=" 67CFLAGS += "-Wno-error=stringop-overflow="
68 68
69EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 69EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
70EXTRA_OECONF_append_class-native = " --without-bzlib" 70EXTRA_OECONF:append:class-native = " --without-bzlib"
71 71
72do_configure_prepend() { 72do_configure:prepend() {
73 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am 73 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
74 74
75 cp ${WORKDIR}/*dis.h ${S}/libcpu 75 cp ${WORKDIR}/*dis.h ${S}/libcpu
@@ -79,15 +79,15 @@ do_configure_prepend() {
79# but some recipes e.g. gcc 4.5 depends on libelf so we 79# but some recipes e.g. gcc 4.5 depends on libelf so we
80# build only libelf for musl cases 80# build only libelf for musl cases
81 81
82EXTRA_OEMAKE_libc-musl = "-C libelf" 82EXTRA_OEMAKE:libc-musl = "-C libelf"
83EXTRA_OEMAKE_class-native = "" 83EXTRA_OEMAKE:class-native = ""
84EXTRA_OEMAKE_class-nativesdk = "" 84EXTRA_OEMAKE:class-nativesdk = ""
85 85
86BBCLASSEXTEND = "native nativesdk" 86BBCLASSEXTEND = "native nativesdk"
87 87
88# Package utilities separately 88# Package utilities separately
89PACKAGES =+ "${PN}-binutils libelf libasm libdw" 89PACKAGES =+ "${PN}-binutils libelf libasm libdw"
90FILES_${PN}-binutils = "\ 90FILES:${PN}-binutils = "\
91 ${bindir}/eu-addr2line \ 91 ${bindir}/eu-addr2line \
92 ${bindir}/eu-ld \ 92 ${bindir}/eu-ld \
93 ${bindir}/eu-nm \ 93 ${bindir}/eu-nm \
@@ -95,13 +95,13 @@ FILES_${PN}-binutils = "\
95 ${bindir}/eu-size \ 95 ${bindir}/eu-size \
96 ${bindir}/eu-strip" 96 ${bindir}/eu-strip"
97 97
98FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" 98FILES:libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
99FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" 99FILES:libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
100FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" 100FILES:libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
101# Some packages have the version preceeding the .so instead properly 101# Some packages have the version preceeding the .so instead properly
102# versioned .so.<version>, so we need to reorder and repackage. 102# versioned .so.<version>, so we need to reorder and repackage.
103#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" 103#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
104#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" 104#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
105 105
106# The package contains symlinks that trip up insane 106# The package contains symlinks that trip up insane
107INSANE_SKIP_${MLPREFIX}libdw = "dev-so" 107INSANE_SKIP:${MLPREFIX}libdw = "dev-so"
diff --git a/recipes-devtools/m4/m4-1.4.9.inc b/recipes-devtools/m4/m4-1.4.9.inc
index 8c75dab..41f46cd 100644
--- a/recipes-devtools/m4/m4-1.4.9.inc
+++ b/recipes-devtools/m4/m4-1.4.9.inc
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe\
8PR = "r2" 8PR = "r2"
9SRC_URI += "file://fix_for_circular_dependency.patch" 9SRC_URI += "file://fix_for_circular_dependency.patch"
10 10
11SRC_URI_append_class-target = "\ 11SRC_URI:append:class-target = "\
12 file://0001-freeze-fix-compilation-error-with-security-flags-ena.patch \ 12 file://0001-freeze-fix-compilation-error-with-security-flags-ena.patch \
13 file://0002-build-don-t-need-charset.alias-when-building-for-mus.patch \ 13 file://0002-build-don-t-need-charset.alias-when-building-for-mus.patch \
14" 14"
diff --git a/recipes-devtools/mtools/mtools_3.9.9.bb b/recipes-devtools/mtools/mtools_3.9.9.bb
index d28fc48..8e106b0 100644
--- a/recipes-devtools/mtools/mtools_3.9.9.bb
+++ b/recipes-devtools/mtools/mtools_3.9.9.bb
@@ -8,8 +8,8 @@ PR = "r6"
8 8
9DEPENDS += "virtual/libiconv" 9DEPENDS += "virtual/libiconv"
10 10
11RDEPENDS_${PN}_libc-glibc = "glibc-gconv-ibm850" 11RDEPENDS:${PN}:libc-glibc = "glibc-gconv-ibm850"
12RRECOMMENDS_${PN}_libc-glibc = "\ 12RRECOMMENDS:${PN}:libc-glibc = "\
13 glibc-gconv-ibm437 \ 13 glibc-gconv-ibm437 \
14 glibc-gconv-ibm737 \ 14 glibc-gconv-ibm737 \
15 glibc-gconv-ibm775 \ 15 glibc-gconv-ibm775 \
@@ -46,7 +46,7 @@ BBCLASSEXTEND = "native nativesdk"
46PACKAGECONFIG ??= "" 46PACKAGECONFIG ??= ""
47PACKAGECONFIG[libbsd] = "ac_cv_lib_bsd_main=yes,ac_cv_lib_bsd_main=no,libbsd" 47PACKAGECONFIG[libbsd] = "ac_cv_lib_bsd_main=yes,ac_cv_lib_bsd_main=no,libbsd"
48 48
49do_install_prepend () { 49do_install:prepend () {
50 # Create bindir to fix parallel installation issues 50 # Create bindir to fix parallel installation issues
51 mkdir -p ${D}/${bindir} 51 mkdir -p ${D}/${bindir}
52 mkdir -p ${D}/${datadir} 52 mkdir -p ${D}/${datadir}
diff --git a/recipes-devtools/patch/patch.inc b/recipes-devtools/patch/patch.inc
index cbfb8cf..a12d426 100644
--- a/recipes-devtools/patch/patch.inc
+++ b/recipes-devtools/patch/patch.inc
@@ -10,5 +10,5 @@ S = "${WORKDIR}/patch-${PV}"
10 10
11inherit autotools update-alternatives 11inherit autotools update-alternatives
12 12
13ALTERNATIVE_${PN} = "patch" 13ALTERNATIVE:${PN} = "patch"
14ALTERNATIVE_PRIORITY = "100" 14ALTERNATIVE_PRIORITY = "100"
diff --git a/recipes-devtools/rsync/rsync.inc b/recipes-devtools/rsync/rsync.inc
index 26c023a..00e0860 100644
--- a/recipes-devtools/rsync/rsync.inc
+++ b/recipes-devtools/rsync/rsync.inc
@@ -10,7 +10,7 @@ SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
10 10
11inherit autotools 11inherit autotools
12 12
13do_install_append() { 13do_install:append() {
14 install -d ${D}${sysconfdir} 14 install -d ${D}${sysconfdir}
15 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} 15 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
16} 16}