summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-27 10:38:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-29 23:56:44 +0100
commit27eafbb395fd4f607249b2e57085012e40283926 (patch)
tree915d0500a27f6462fafb7c53beadce1e4d91cc00 /recipes-devtools
parentb3fa26bc777ec0136ce189d90123b50f6ee567b9 (diff)
downloadmeta-gplv2-27eafbb395fd4f607249b2e57085012e40283926.tar.gz
recipes: Drop libc-uclibc overrides and patch
These haven't been used for a long time and can therefore be removed. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch91
-rw-r--r--recipes-devtools/elfutils/elfutils_0.148.bb9
-rw-r--r--recipes-devtools/m4/m4.inc1
-rw-r--r--recipes-devtools/mtools/mtools_3.9.9.bb2
4 files changed, 2 insertions, 101 deletions
diff --git a/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch b/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch
deleted file mode 100644
index 3cf16ac..0000000
--- a/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch
+++ /dev/null
@@ -1,91 +0,0 @@
1on uclibc systems libintl and libuargp are separate from libc.
2so they need to be specified on commandline when we use proxy-libintl
3then libintl is a static archive so it should be listed last since
4elfutils does not respect disable-nls we need to link in libintl
5
6We add a new option --enable-uclibc which will be used to control
7the uclibc specific configurations during build.
8
9Signed-off-by: Khem Raj <raj.khem>
10
11Upstream-Status: Inappropriate [uclibc specific]
12
13Index: elfutils-0.148/configure.ac
14===================================================================
15--- elfutils-0.148.orig/configure.ac
16+++ elfutils-0.148/configure.ac
17@@ -55,9 +55,16 @@ AS_IF([test "$use_locks" = yes], [AC_DEF
18
19 AH_TEMPLATE([USE_LOCKS], [Defined if libraries should be thread-safe.])
20
21+AC_ARG_ENABLE([uclibc],
22+AS_HELP_STRING([--enable-uclibc], [Use uclibc for system libraries]),
23+use_uclibc=yes, use_uclibc=no)
24+AM_CONDITIONAL(USE_UCLIBC, test "$use_uclibc" = yes)
25+AS_IF([test "$use_uclibc" = yes], [AC_DEFINE(USE_UCLIBC)])
26+
27+AH_TEMPLATE([USE_UCLIBC], [Defined if uclibc libraries are used.])
28+
29 dnl Add all the languages for which translations are available.
30 ALL_LINGUAS=
31-
32 AC_PROG_CC
33 AC_PROG_RANLIB
34 AC_PROG_YACC
35Index: elfutils-0.148/libelf/Makefile.am
36===================================================================
37--- elfutils-0.148.orig/libelf/Makefile.am
38+++ elfutils-0.148/libelf/Makefile.am
39@@ -93,7 +93,12 @@ if !MUDFLAP
40 libelf_pic_a_SOURCES =
41 am_libelf_pic_a_OBJECTS = $(libelf_a_SOURCES:.c=.os)
42
43+
44 libelf_so_LDLIBS =
45+if USE_UCLIBC
46+libelf_so_LDLIBS += -lintl -luargp
47+endif
48+
49 if USE_LOCKS
50 libelf_so_LDLIBS += -lpthread
51 endif
52Index: elfutils-0.148/libdw/Makefile.am
53===================================================================
54--- elfutils-0.148.orig/libdw/Makefile.am
55+++ elfutils-0.148/libdw/Makefile.am
56@@ -98,6 +98,11 @@ if !MUDFLAP
57 libdw_pic_a_SOURCES =
58 am_libdw_pic_a_OBJECTS = $(libdw_a_SOURCES:.c=.os)
59
60+libdw_so_LDLIBS =
61+if USE_UCLIBC
62+libdw_so_LDLIBS += -lintl -luargp
63+endif
64+
65 libdw_so_SOURCES =
66 libdw.so: $(srcdir)/libdw.map libdw_pic.a \
67 ../libdwfl/libdwfl_pic.a ../libebl/libebl.a \
68@@ -108,7 +113,7 @@ libdw.so: $(srcdir)/libdw.map libdw_pic.
69 -Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
70 -Wl,--version-script,$<,--no-undefined \
71 -Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
72- -ldl $(zip_LIBS)
73+ -ldl $(zip_LIBS) $(libdw_so_LDLIBS)
74 if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
75 ln -fs $@ $@.$(VERSION)
76
77Index: elfutils-0.148/libcpu/Makefile.am
78===================================================================
79--- elfutils-0.148.orig/libcpu/Makefile.am
80+++ elfutils-0.148/libcpu/Makefile.am
81@@ -63,6 +63,10 @@ i386_parse_CFLAGS = -DNMNES="`wc -l < i3
82 i386_lex.o: i386_parse.h
83 i386_gendis_LDADD = $(libeu) -lm $(libmudflap)
84
85+if USE_UCLIBC
86+i386_gendis_LDADD += -luargp -lintl
87+endif
88+
89 i386_parse.h: i386_parse.c ;
90
91 noinst_HEADERS = memory-access.h i386_parse.h i386_data.h
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bb b/recipes-devtools/elfutils/elfutils_0.148.bb
index 654a715..3c0f9f0 100644
--- a/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -44,9 +44,6 @@ SRC_URI += "\
44# Only apply when building musl based target recipe 44# Only apply when building musl based target recipe
45SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch" 45SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch"
46 46
47# Only apply when building uclibc based target recipe
48SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.148.patch"
49
50# The buildsystem wants to generate 2 .h files from source using a binary it just built, 47# The buildsystem wants to generate 2 .h files from source using a binary it just built,
51# which can not pass the cross compiling, so let's work around it by adding 2 .h files 48# which can not pass the cross compiling, so let's work around it by adding 2 .h files
52# along with the do_configure_prepend() 49# along with the do_configure_prepend()
@@ -71,7 +68,6 @@ CFLAGS += "-Wno-error=stringop-overflow="
71 68
72EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 69EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
73EXTRA_OECONF_append_class-native = " --without-bzlib" 70EXTRA_OECONF_append_class-native = " --without-bzlib"
74EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
75 71
76do_configure_prepend() { 72do_configure_prepend() {
77 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am 73 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
@@ -79,12 +75,11 @@ do_configure_prepend() {
79 cp ${WORKDIR}/*dis.h ${S}/libcpu 75 cp ${WORKDIR}/*dis.h ${S}/libcpu
80} 76}
81 77
82# we can not build complete elfutils when using uclibc or musl 78# we can not build complete elfutils when using musl
83# but some recipes e.g. gcc 4.5 depends on libelf so we 79# but some recipes e.g. gcc 4.5 depends on libelf so we
84# build only libelf for uclibc and musl cases 80# build only libelf for musl cases
85 81
86EXTRA_OEMAKE_libc-musl = "-C libelf" 82EXTRA_OEMAKE_libc-musl = "-C libelf"
87EXTRA_OEMAKE_libc-uclibc = "-C libelf"
88EXTRA_OEMAKE_class-native = "" 83EXTRA_OEMAKE_class-native = ""
89EXTRA_OEMAKE_class-nativesdk = "" 84EXTRA_OEMAKE_class-nativesdk = ""
90 85
diff --git a/recipes-devtools/m4/m4.inc b/recipes-devtools/m4/m4.inc
index 4a83929..75d8bbe 100644
--- a/recipes-devtools/m4/m4.inc
+++ b/recipes-devtools/m4/m4.inc
@@ -6,5 +6,4 @@ GNU M4 also has built-in functions for including files, running shell commands,
6inherit autotools texinfo 6inherit autotools texinfo
7 7
8EXTRA_OEMAKE += "'infodir=${infodir}'" 8EXTRA_OEMAKE += "'infodir=${infodir}'"
9LDFLAGS_prepend_libc-uclibc = " -lrt "
10SRC_URI = "${GNU_MIRROR}/m4/m4-${PV}.tar.gz" 9SRC_URI = "${GNU_MIRROR}/m4/m4-${PV}.tar.gz"
diff --git a/recipes-devtools/mtools/mtools_3.9.9.bb b/recipes-devtools/mtools/mtools_3.9.9.bb
index 2904ff4..d28fc48 100644
--- a/recipes-devtools/mtools/mtools_3.9.9.bb
+++ b/recipes-devtools/mtools/mtools_3.9.9.bb
@@ -41,8 +41,6 @@ inherit autotools texinfo
41 41
42EXTRA_OECONF = "--without-x" 42EXTRA_OECONF = "--without-x"
43 43
44LDFLAGS_append_libc-uclibc = " -liconv "
45
46BBCLASSEXTEND = "native nativesdk" 44BBCLASSEXTEND = "native nativesdk"
47 45
48PACKAGECONFIG ??= "" 46PACKAGECONFIG ??= ""