summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb48
-rw-r--r--recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch39
-rw-r--r--recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules2
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb92
-rw-r--r--recipes-virtualization/mux-server/files/mux-server-1.02.tar.gzbin0 -> 10021 bytes
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb16
6 files changed, 197 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 0000000..a913524
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19inherit deploy
20
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1"
22SRCREV = "39f1e585e0a70634e009b2e720407b27f787ace1"
23SRCREV_t2080qds = "46065e277a853ca3fa80040d3b00d7582b619a47"
24SRCREV_t2080qds-64b = "46065e277a853ca3fa80040d3b00d7582b619a47"
25
26S = "${WORKDIR}/git"
27
28do_install () {
29 make install
30
31 M=`echo ${MACHINE} | sed s/-64b//g`
32 install -d ${D}/boot/hv-cfg
33 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
34}
35
36do_deploy () {
37 M=`echo ${MACHINE} | sed s/-64b//g`
38 install -d ${DEPLOYDIR}/hv-cfg
39 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
40}
41addtask deploy after do_install
42
43PACKAGES += "${PN}-image"
44FILES_${PN}-image += "/boot"
45
46COMPATIBLE_HOST_fslmachine = ".*"
47COMPATIBLE_HOST ?= "(none)"
48ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch b/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
new file mode 100644
index 0000000..a562273
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
@@ -0,0 +1,39 @@
1From 59e68351114a65a1f315ded1ee92f4370b8547e2 Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com>
3Date: Mon, 8 Jul 2013 17:03:43 +0800
4Subject: [PATCH] fix sizeof-pointer-memaccess error
5
6build: src/livetree.c
7.../hypervisor/git-r3/git/src/devtree.c: In function 'read_intmap':
8.../hypervisor/git-r3/git/src/devtree.c:1513:25: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
9 memset(ent, 0, sizeof(ent));
10 ^
11cc1: all warnings being treated as errors
12build: src/ipi_doorbell.c
13make[1]: *** [bin/devtree.o] Error 1
14make[1]: *** Waiting for unfinished jobs....
15make[1]: Leaving directory `.../hypervisor/git-r3/git/output'
16make: *** [all] Error 2
17ERROR: oe_runmake failed
18
19Signed-off-by: Ting Liu <b28495@freescale.com>
20---
21 src/devtree.c | 2 +-
22 1 files changed, 1 insertions(+), 1 deletions(-)
23
24diff --git a/src/devtree.c b/src/devtree.c
25index f3710e4..3295e20 100644
26--- a/src/devtree.c
27+++ b/src/devtree.c
28@@ -1510,7 +1510,7 @@ static void read_intmap(dt_node_t *node)
29 }
30
31 if (imap + ent->parent_naddr + ent->parent_nint > imap_end) {
32- memset(ent, 0, sizeof(ent));
33+ memset(ent, 0, sizeof(intmap_entry_t));
34 break;
35 }
36
37--
381.7.5.4
39
diff --git a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
new file mode 100644
index 0000000..5edfa11
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
@@ -0,0 +1,2 @@
1# Add rule to handle setting up device node for FSL HV mgmt driver
2SUBSYSTEM=="misc", KERNEL=="fsl-hv", NAME="fsl-hv"
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 0000000..318c942
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,92 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12S = "${WORKDIR}/git"
13
14# TODO: fix dtc to use the already built package
15SRC_URI = " \
16 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \
17 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;nobranch=1 \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;nobranch=1 \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;nobranch=1 \
21 file://81-fsl-embedded-hv.rules \
22 "
23
24SRCREV_FORMAT="hypervisor"
25SRCREV = "acbde15272d46a80bcf4a00d7d18ca4a86e49c16"
26SRCREV_t2080qds = "2a430ebaa59841fdb49c0c87f8766cc2ef99123b"
27SRCREV_t2080qds-64b = "2a430ebaa59841fdb49c0c87f8766cc2ef99123b"
28SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
29SRCREV_libos = "4691387e15be78d140142104f30b3f356281c46a"
30SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
31SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
32
33EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
34
35DEFCONFIG = "defconfig"
36DEFCONFIG_powerpc64 = "64bit_defconfig"
37
38COMPATIBLE_HOST_fslmachine = ".*"
39COMPATIBLE_HOST ?= "(none)"
40
41inherit cml1
42do_configure () {
43 oe_runmake ${DEFCONFIG}
44}
45
46PKG_HV_HYPERTRK_SUPPORT = "n"
47do_compile () {
48 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
49 then
50 oe_runmake silentoldconfig
51 export HV_DIR=$PWD
52 cd hypertrk
53 oe_runmake deploy
54 cd ..
55 fi
56
57 oe_runmake
58 oe_runmake partman
59}
60
61do_install () {
62 install -d ${D}/${bindir}
63 install ${S}/output/bin/linux/partman ${D}/${bindir}/partman
64
65 install -d ${D}${sysconfdir}/udev/rules.d
66 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
67
68 install -d ${D}/boot/hv
69 install ${S}/output/.config ${D}/boot/hv/hypervisor.config
70 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
71 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
72 ${D}/boot/hv/
73}
74
75do_deploy () {
76 install -d ${DEPLOYDIR}/hv/
77 install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config
78 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
79 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
80 ${DEPLOYDIR}/hv/
81}
82addtask deploy before do_build after do_install
83
84do_deploy_append() {
85 rm -f ${S}/../hv
86}
87
88INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
89ALLOW_EMPTY_${PN} = "1"
90PACKAGES_prepend = "${PN}-image ${PN}-partman "
91FILES_${PN}-image = "/boot/"
92FILES_${PN}-partman = "${bindir}/partman"
diff --git a/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz b/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz
new file mode 100644
index 0000000..d8f2014
--- /dev/null
+++ b/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz
Binary files differ
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
new file mode 100644
index 0000000..ab9cce1
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing"
2SECTION = "mux-server"
3LICENSE = "LGPL-2.1"
4# TODO: add a dedicated COPYING file
5LIC_FILES_CHKSUM = "file://mux_server.c;endline=9;md5=e59eeb0812bb88b7af2d932f2dc22aed"
6
7SRC_URI = "file://mux-server-${PV}.tar.gz;name=mux_server"
8
9EXTRA_OEMAKE='HOSTCC="${CC}"'
10
11do_install () {
12 install -d ${D}${bindir}
13 install -m 755 mux_server ${D}${bindir}
14}
15
16BBCLASSEXTEND = "native nativesdk"