summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hypervisor/hypervisor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hypervisor/hypervisor_git.bb')
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 0000000..318c942
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,92 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12S = "${WORKDIR}/git"
13
14# TODO: fix dtc to use the already built package
15SRC_URI = " \
16 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor;nobranch=1 \
17 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig;nobranch=1 \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos;nobranch=1 \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk;nobranch=1 \
21 file://81-fsl-embedded-hv.rules \
22 "
23
24SRCREV_FORMAT="hypervisor"
25SRCREV = "acbde15272d46a80bcf4a00d7d18ca4a86e49c16"
26SRCREV_t2080qds = "2a430ebaa59841fdb49c0c87f8766cc2ef99123b"
27SRCREV_t2080qds-64b = "2a430ebaa59841fdb49c0c87f8766cc2ef99123b"
28SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
29SRCREV_libos = "4691387e15be78d140142104f30b3f356281c46a"
30SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
31SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
32
33EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
34
35DEFCONFIG = "defconfig"
36DEFCONFIG_powerpc64 = "64bit_defconfig"
37
38COMPATIBLE_HOST_fslmachine = ".*"
39COMPATIBLE_HOST ?= "(none)"
40
41inherit cml1
42do_configure () {
43 oe_runmake ${DEFCONFIG}
44}
45
46PKG_HV_HYPERTRK_SUPPORT = "n"
47do_compile () {
48 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
49 then
50 oe_runmake silentoldconfig
51 export HV_DIR=$PWD
52 cd hypertrk
53 oe_runmake deploy
54 cd ..
55 fi
56
57 oe_runmake
58 oe_runmake partman
59}
60
61do_install () {
62 install -d ${D}/${bindir}
63 install ${S}/output/bin/linux/partman ${D}/${bindir}/partman
64
65 install -d ${D}${sysconfdir}/udev/rules.d
66 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
67
68 install -d ${D}/boot/hv
69 install ${S}/output/.config ${D}/boot/hv/hypervisor.config
70 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
71 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
72 ${D}/boot/hv/
73}
74
75do_deploy () {
76 install -d ${DEPLOYDIR}/hv/
77 install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config
78 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
79 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
80 ${DEPLOYDIR}/hv/
81}
82addtask deploy before do_build after do_install
83
84do_deploy_append() {
85 rm -f ${S}/../hv
86}
87
88INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
89ALLOW_EMPTY_${PN} = "1"
90PACKAGES_prepend = "${PN}-image ${PN}-partman "
91FILES_${PN}-image = "/boot/"
92FILES_${PN}-partman = "${bindir}/partman"