summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-10 03:45:00 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-11 16:48:28 +0800
commit58178d176e44689069692cad033a24370899b14d (patch)
treecf1b56c66f788f1f89a4a35d1f28f364bc38d201 /recipes-virtualization
parent851c7ff26de131b871bd5a64274c1a2b13d60fc3 (diff)
downloadmeta-fsl-ppc-58178d176e44689069692cad033a24370899b14d.tar.gz
hypervisor: fix sizeof-pointer-memaccess error
Fix the below build error: | build: src/livetree.c | .../hypervisor/git-r3/git/src/devtree.c: In function 'read_intmap': | .../hypervisor/git-r3/git/src/devtree.c:1513:25: error: argument to | 'sizeof' in 'memset' call is the same expression as the destination; | did you mean to dereference it? [-Werror=sizeof-pointer-memaccess] | memset(ent, 0, sizeof(ent)); | ^ | cc1: all warnings being treated as errors | build: src/ipi_doorbell.c | make[1]: *** [bin/devtree.o] Error 1 | make[1]: *** Waiting for unfinished jobs.... | make[1]: Leaving directory `.../hypervisor/git-r3/git/output' | make: *** [all] Error 2 | ERROR: oe_runmake failed Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch39
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch b/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
new file mode 100644
index 0000000..a562273
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
@@ -0,0 +1,39 @@
1From 59e68351114a65a1f315ded1ee92f4370b8547e2 Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com>
3Date: Mon, 8 Jul 2013 17:03:43 +0800
4Subject: [PATCH] fix sizeof-pointer-memaccess error
5
6build: src/livetree.c
7.../hypervisor/git-r3/git/src/devtree.c: In function 'read_intmap':
8.../hypervisor/git-r3/git/src/devtree.c:1513:25: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
9 memset(ent, 0, sizeof(ent));
10 ^
11cc1: all warnings being treated as errors
12build: src/ipi_doorbell.c
13make[1]: *** [bin/devtree.o] Error 1
14make[1]: *** Waiting for unfinished jobs....
15make[1]: Leaving directory `.../hypervisor/git-r3/git/output'
16make: *** [all] Error 2
17ERROR: oe_runmake failed
18
19Signed-off-by: Ting Liu <b28495@freescale.com>
20---
21 src/devtree.c | 2 +-
22 1 files changed, 1 insertions(+), 1 deletions(-)
23
24diff --git a/src/devtree.c b/src/devtree.c
25index f3710e4..3295e20 100644
26--- a/src/devtree.c
27+++ b/src/devtree.c
28@@ -1510,7 +1510,7 @@ static void read_intmap(dt_node_t *node)
29 }
30
31 if (imap + ent->parent_naddr + ent->parent_nint > imap_end) {
32- memset(ent, 0, sizeof(ent));
33+ memset(ent, 0, sizeof(intmap_entry_t));
34 break;
35 }
36
37--
381.7.5.4
39
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
index dc86406..ff89bfa 100644
--- a/recipes-virtualization/hypervisor/hypervisor_git.bb
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -18,6 +18,7 @@ SRC_URI = " \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \ 18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \ 19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \ 20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \
21 file://0001-fix-sizeof-pointer-memaccess-error.patch \
21 file://81-fsl-embedded-hv.rules \ 22 file://81-fsl-embedded-hv.rules \
22 " 23 "
23 24