summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-virtualization
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-virtualization')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb46
-rw-r--r--recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules2
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb90
-rw-r--r--recipes-virtualization/mux-server/files/mux-server-1.02.tar.gzbin0 -> 10021 bytes
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb16
5 files changed, 154 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 0000000..2c6bb85
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_HOST_fslmachine = ".*"
19COMPATIBLE_HOST ?= "(none)"
20
21inherit deploy
22
23SRCREV = "d037ab9d5b9ecd58e10a7dac2b601d781ed9b5bf"
24SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git"
25
26S = "${WORKDIR}/git"
27
28do_install () {
29 make install
30
31 M=`echo ${MACHINE} | sed s/-64b//g`
32 install -d ${D}/boot/hv-cfg
33 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
34}
35
36do_deploy () {
37 M=`echo ${MACHINE} | sed s/-64b//g`
38 install -d ${DEPLOYDIR}/hv-cfg
39 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
40}
41addtask deploy after do_install
42
43PACKAGES += "${PN}-image"
44FILES_${PN}-image += "/boot"
45
46ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
new file mode 100644
index 0000000..5edfa11
--- /dev/null
+++ b/recipes-virtualization/hypervisor/files/81-fsl-embedded-hv.rules
@@ -0,0 +1,2 @@
1# Add rule to handle setting up device node for FSL HV mgmt driver
2SUBSYSTEM=="misc", KERNEL=="fsl-hv", NAME="fsl-hv"
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 0000000..dc86406
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,90 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12S = "${WORKDIR}/git"
13
14# TODO: fix dtc to use the already built package
15SRC_URI = " \
16 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor \
17 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \
21 file://81-fsl-embedded-hv.rules \
22 "
23
24SRCREV_FORMAT="hypervisor"
25SRCREV = "e6092cdf2a225c66c1ea46b1151eb828da29d139"
26SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
27SRCREV_libos = "5268371581f3ef3959be2a53235edfa6a8c6aa7c"
28SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
29SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
30
31EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
32
33DEFCONFIG = "defconfig"
34DEFCONFIG_powerpc64 = "64bit_defconfig"
35
36COMPATIBLE_HOST_fslmachine = ".*"
37COMPATIBLE_HOST ?= "(none)"
38
39inherit cml1
40do_configure () {
41 oe_runmake ${DEFCONFIG}
42}
43
44PKG_HV_HYPERTRK_SUPPORT = "n"
45do_compile () {
46 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
47 then
48 oe_runmake silentoldconfig
49 export HV_DIR=$PWD
50 cd hypertrk
51 oe_runmake deploy
52 cd ..
53 fi
54
55 oe_runmake
56 oe_runmake partman
57}
58
59do_install () {
60 install -d ${D}/${bindir}
61 install ${S}/output/bin/linux/partman ${D}/${bindir}/partman
62
63 install -d ${D}${sysconfdir}/udev/rules.d
64 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
65
66 install -d ${D}/boot/hv
67 install ${S}/output/.config ${D}/boot/hv/hypervisor.config
68 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
69 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
70 ${D}/boot/hv/
71}
72
73do_deploy () {
74 install -d ${DEPLOYDIR}/hv/
75 install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config
76 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
77 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
78 ${DEPLOYDIR}/hv/
79}
80addtask deploy before do_build after do_install
81
82do_deploy_append() {
83 rm -f ${S}/../hv
84}
85
86INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
87ALLOW_EMPTY_${PN} = "1"
88PACKAGES_prepend = "${PN}-image ${PN}-partman "
89FILES_${PN}-image = "/boot/"
90FILES_${PN}-partman = "${bindir}/partman"
diff --git a/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz b/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz
new file mode 100644
index 0000000..d8f2014
--- /dev/null
+++ b/recipes-virtualization/mux-server/files/mux-server-1.02.tar.gz
Binary files differ
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
new file mode 100644
index 0000000..ab9cce1
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing"
2SECTION = "mux-server"
3LICENSE = "LGPL-2.1"
4# TODO: add a dedicated COPYING file
5LIC_FILES_CHKSUM = "file://mux_server.c;endline=9;md5=e59eeb0812bb88b7af2d932f2dc22aed"
6
7SRC_URI = "file://mux-server-${PV}.tar.gz;name=mux_server"
8
9EXTRA_OEMAKE='HOSTCC="${CC}"'
10
11do_install () {
12 install -d ${D}${bindir}
13 install -m 755 mux_server ${D}${bindir}
14}
15
16BBCLASSEXTEND = "native nativesdk"