summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-06-14 14:25:22 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:48 +0800
commit2c1f33c0f57310142ad098ed8a7a582da74d908d (patch)
treecd8beedea1a184b0c3ca406caaafae6b2c70c2e2 /recipes-bsp
parent3e16ce67517c88bce6d8a8258e9c7e3a01b58747 (diff)
downloadmeta-fsl-ppc-2c1f33c0f57310142ad098ed8a7a582da74d908d.tar.gz
pkc-firmware: add recipe for sdk v1.6
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/pkc-firmware/pkc-firmware_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
new file mode 100644
index 0000000..3cc5d44
--- /dev/null
+++ b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "U-boot firmware for c293pcie support "
2HOMEPAGE = "http://u-boot.sf.net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
5
6INHIBIT_DEFAULT_DEPS = "1"
7DEPENDS = "virtual/${TARGET_PREFIX}gcc libgcc"
8
9inherit deploy
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1"
14SRCREV = "b891873c1eea7a7d53f9472ea601712897cb17b7"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
19
20do_compile () {
21 unset LDFLAGS
22 unset CFLAGS
23 unset CPPFLAGS
24 oe_runmake C293QDS_36BIT_SDCARD
25}
26
27do_install(){
28 install -d ${D}${sysconfdir}/crypto/
29 install ${S}/u-boot.bin ${D}${sysconfdir}/crypto/pkc-firmware.bin
30}
31
32do_deploy(){
33 install -d ${DEPLOYDIR}/pkc-firmware
34 install ${S}/u-boot.bin ${DEPLOYDIR}/pkc-firmware/pkc-firmware.bin
35}
36
37addtask deploy after do_install
38
39FILES_{PN} += "/etc/crypto/pkc-firmware.bin"
40COMPATIBLE_MACHINE = "(c293pcie)"
41