summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-06-14 13:14:06 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:48 +0800
commit3e16ce67517c88bce6d8a8258e9c7e3a01b58747 (patch)
tree380589cae1ead911945da95d43c8c65c77224645 /recipes-bsp
parentfa44d9aee4a24e470aab18cde7ce4ba3cf14c63c (diff)
downloadmeta-fsl-ppc-3e16ce67517c88bce6d8a8258e9c7e3a01b58747.tar.gz
cs4315-firmware: add recipe for sdk v1.6
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cs4315-firmware/cs4315-firmware_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-bsp/cs4315-firmware/cs4315-firmware_git.bb b/recipes-bsp/cs4315-firmware/cs4315-firmware_git.bb
new file mode 100644
index 0000000..153e8f8
--- /dev/null
+++ b/recipes-bsp/cs4315-firmware/cs4315-firmware_git.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Firmware image for the Cortina CS4315 PHY"
2LICENSE = "Cortina"
3LIC_FILES_CHKSUM = "file://Cortina-EULA;md5=ef3a0b9eaf40547d263a4f67040dc56e"
4
5inherit deploy
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/firmware.git;nobranch=1"
8SRCREV = "ad5a3108f9ede39ea41fde18d4ac0cc7680cf650"
9
10S = "${WORKDIR}/git"
11
12do_install () {
13 install -d ${D}/boot
14 install -m 644 ${S}/cs4315-cs4340-PHY-ucode.txt ${D}/boot/
15}
16
17do_deploy () {
18 install -d ${DEPLOYDIR}/
19 install -m 644 ${S}/cs4315-cs4340-PHY-ucode.txt ${DEPLOYDIR}/
20}
21addtask deploy before do_build after do_install
22
23PACKAGES += "${PN}-image"
24FILES_${PN}-image += "/boot"
25COMPATIBLE_MACHINE = "(t2080rdb|t2080rdb-64b|t4240rdb|t4240rdb-64b)"
26ALLOW_EMPTY_${PN} = "1"