summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-07-10 03:45:01 +0000
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-11 16:55:52 +0800
commit417ec03961696ea1bd4bb8f160df23418c910cd5 (patch)
tree5dc7809952450fff57bfd95edf57245cb3117f8d /recipes-bsp/u-boot
parent58178d176e44689069692cad033a24370899b14d (diff)
downloadmeta-fsl-ppc-417ec03961696ea1bd4bb8f160df23418c910cd5.tar.gz
u-boot: append sdk version into uboot version
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index c3aa105..008e253 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -39,6 +39,8 @@ EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc
39 39
40PACKAGE_ARCH = "${MACHINE_ARCH}" 40PACKAGE_ARCH = "${MACHINE_ARCH}"
41 41
42UBOOT_LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
43
42USRC ?= "" 44USRC ?= ""
43S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}' 45S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}'
44 46
@@ -47,6 +49,12 @@ do_compile () {
47 unset CFLAGS 49 unset CFLAGS
48 unset CPPFLAGS 50 unset CPPFLAGS
49 51
52 if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
53 then
54 echo ${UBOOT_LOCALVERSION} > ${B}/.scmversion
55 echo ${UBOOT_LOCALVERSION} > ${S}/.scmversion
56 fi
57
50 if [ "x${UBOOT_MACHINES}" = "x" ]; then 58 if [ "x${UBOOT_MACHINES}" = "x" ]; then
51 UBOOT_MACHINES=${UBOOT_MACHINE} 59 UBOOT_MACHINES=${UBOOT_MACHINE}
52 fi 60 fi